summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-11-19 03:35:39 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-11-19 03:35:39 +0000
commite1b66f7aed7bf4f835c160de69168e1da697b1ca (patch)
treea4f63e7ef146eb3eaaafd403f0dc057ab199e2c0 /x11-drivers/synaptics-git/synaptics-git-9999.ebuild
parentgit, not svn (diff)
downloadje_fro-e1b66f7aed7bf4f835c160de69168e1da697b1ca.tar.gz
je_fro-e1b66f7aed7bf4f835c160de69168e1da697b1ca.tar.bz2
je_fro-e1b66f7aed7bf4f835c160de69168e1da697b1ca.zip
namechange
svn path=/; revision=116
Diffstat (limited to 'x11-drivers/synaptics-git/synaptics-git-9999.ebuild')
-rw-r--r--x11-drivers/synaptics-git/synaptics-git-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-drivers/synaptics-git/synaptics-git-9999.ebuild b/x11-drivers/synaptics-git/synaptics-git-9999.ebuild
new file mode 100644
index 0000000..daffb8f
--- /dev/null
+++ b/x11-drivers/synaptics-git/synaptics-git-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EGIT_REPO_URI="http://web.telia.com/~u89404340/touchpad/synaptics/.git/"
+inherit git
+
+DESCRIPTION="The latest from the synaptics git tree."
+HOMEPAGE="http://web.telia.com/~u89404340/touchpad/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-server
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ git_src_unpack
+
+ # Switch up the CC and CFLAGS stuff.
+ sed -i \
+ -e "s:CC = gcc:CC = $(tc-getCC):g" \
+ -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
+ "${S}"/Makefile
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ MANDIR="${D}"/usr/share/man \
+ install || die
+
+ dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
+ dodoc COMPATIBILITY FILES INSTALL* LICENSE NEWS TODO README*
+
+}