summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/compizconfig-python/compizconfig-python-0.5.2.ebuild')
-rw-r--r--dev-python/compizconfig-python/compizconfig-python-0.5.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/compizconfig-python/compizconfig-python-0.5.2.ebuild b/dev-python/compizconfig-python/compizconfig-python-0.5.2.ebuild
new file mode 100644
index 0000000..2699532
--- /dev/null
+++ b/dev-python/compizconfig-python/compizconfig-python-0.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="Compizconfig Python Bindings"
+HOMEPAGE="http://opencompositing.org"
+SRC_URI="http://releases.compiz-fusion.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND="~x11-libs/libcompizconfig-${PV}
+ >=dev-libs/glib-2.6
+ || ( >=dev-lang/python-2.4 >=dev-lang/python-2.5 )
+ dev-python/pyrex"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ eautoreconf || die "eautoreconf failed"
+
+ econf || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ einfo "Please report all bugs at http://forums.gentoo-xeffects.org/"
+ einfo "Thank you on behalf of the Gentoo Xeffects team"
+}