summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mplayer/mplayer-1.0.20070814.ebuild')
-rw-r--r--media-video/mplayer/mplayer-1.0.20070814.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-video/mplayer/mplayer-1.0.20070814.ebuild b/media-video/mplayer/mplayer-1.0.20070814.ebuild
index ed29eac..b7b9915 100644
--- a/media-video/mplayer/mplayer-1.0.20070814.ebuild
+++ b/media-video/mplayer/mplayer-1.0.20070814.ebuild
@@ -9,8 +9,9 @@ IUSE="3dnow 3dnowext a52 aac aalib alsa altivec amrnb amrwb arts bidi bl bindist
cddb cdio cdparanoia cpudetection custom-cflags dga doc dts dvb directfb dvd
dv enca encode esd fbcon ftp gif ggi gtk iconv ipv6 ivtv jack joystick
jpeg libcaca lirc live livecd lzo mad md5sum mmx mmxext mp2 mp3 musepack nas
-unicode vorbis opengl openal oss png pnm quicktime radio rar real rtc samba sdl
-speex srt sse sse2 ssse3 svga teletext tga theora tivo truetype v4l v4l2 vidix win32codecs X x264 xanim xinerama xv xvid xvmc zoran"
+unicode vorbis opengl openal oss png pnm pvr quicktime radio rar real rtc samba sdl
+speex srt sse sse2 ssse3 svga teletext tga theora tivo truetype v4l v4l2 vidix
+win32codecs X x264 xanim xinerama xv xvid xvmc zoran"
VIDEO_CARDS="i810 nvidia s3virge mga tdfx vesa"
@@ -286,7 +287,7 @@ src_compile() {
# The build will break if you have media-tv/ivtv installed and
# linux-headers != 2.6.18
# See also, bug 164748
- myconf="${myconf} --disable-pvr"
+ use pvr || myconf="${myconf} --disable-pvr"
#########
# Codecs #
@@ -325,7 +326,7 @@ src_compile() {
# Video Output #
#############
- for x in directfb ivtv ggi md5sum sdl xinerama; do
+ for x in directfb ggi md5sum sdl xinerama; do
use ${x} || myconf="${myconf} --disable-${x}"
done
use aalib || myconf="${myconf} --disable-aa"
@@ -338,8 +339,8 @@ src_compile() {
use video_cards_vesa || myconf="${myconf} --disable-vesa"
use vidix || myconf="${myconf} --disable-vidix-internal \
--disable-vidix-external"
- use zoran || myconf="${myconf} --disable-zr"
-
+ use zoran || myconf="${myconf} --disable-zr" \
+ use ivtv || myconf="${myconf} --disable-ivtv"
# GTK gmplayer gui
myconf="${myconf} $(use_enable gtk gui)"