summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/naga/naga-3.0.ebuild')
-rw-r--r--sci-libs/naga/naga-3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/naga/naga-3.0.ebuild b/sci-libs/naga/naga-3.0.ebuild
new file mode 100644
index 0000000..dd558e8
--- /dev/null
+++ b/sci-libs/naga/naga-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=4
+
+inherit subversion java-pkg-2 java-ant-2
+
+ESVN_REPO_URI="http://naga.googlecode.com/svn/trunk@78"
+
+DESCRIPTION="Simplified Java NIO asynchronous sockets"
+HOMEPAGE="http://code.google.com/p/naga/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+JAVA_PKG_BSFIX="off"
+
+src_compile() {
+ eant build
+}
+src_install() {
+ java-pkg_newjar _DIST/naga-debug-3_0-r49.jar ${PN}.jar
+}