summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/mactel-linux-sources/mactel-linux-sources-2.6.24-r2.ebuild')
-rw-r--r--sys-kernel/mactel-linux-sources/mactel-linux-sources-2.6.24-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/mactel-linux-sources/mactel-linux-sources-2.6.24-r2.ebuild b/sys-kernel/mactel-linux-sources/mactel-linux-sources-2.6.24-r2.ebuild
new file mode 100644
index 0000000..34381e6
--- /dev/null
+++ b/sys-kernel/mactel-linux-sources/mactel-linux-sources-2.6.24-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="3"
+K_SECURITY_UNSUPPORTED="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Sources for the Linux kernel with mactel-linux and gentoo patches."
+HOMEPAGE="http://www.kernel.org
+ http://dev.gentoo.org/~dsd/genpatches
+ http://mactel-linux.org"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+KEYWORDS="~amd64 ~x86"
+
+PATCHDIR="${FILESDIR}/${PV}-mactel-patches-r149/"
+
+UNIPATCH_LIST="${PATCHDIR}/appletouch.patch \
+${PATCHDIR}/appletouch-add-macbook3-trackpad.patch \
+${PATCHDIR}/applesmc-macbook2.patch \
+${PATCHDIR}/applesmc-retry-when-accessing-keys.patch \
+${PATCHDIR}/applesmc_int.patch \
+${PATCHDIR}/sigmatel_audio_display_all_controls_when_subsystem_id_is_wrong.patch \
+${PATCHDIR}/sigmatel_audio_fix_macbook_v2.patch \
+${PATCHDIR}/appletouch-new.patch"
+
+UNIPATCH_STRICTORDER="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, see:"
+ einfo "${HOMEPAGE}"
+ einfo "Report any problems to je_fro@gentoo.org"
+}
+