summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/ati-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog1339
-rw-r--r--x11-drivers/ati-drivers/Manifest11
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.593.ebuild448
-rw-r--r--x11-drivers/ati-drivers/files/09ati3
-rw-r--r--x11-drivers/ati-drivers/files/ati-drivers-xen.patch62
-rw-r--r--x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch42
-rw-r--r--x11-drivers/ati-drivers/files/ati-powermode.sh.patch32
-rw-r--r--x11-drivers/ati-drivers/files/atieventsd.init20
-rw-r--r--x11-drivers/ati-drivers/files/atieventsd.rc622
-rw-r--r--x11-drivers/ati-drivers/files/libGL.la.in32
-rw-r--r--x11-drivers/ati-drivers/metadata.xml11
11 files changed, 0 insertions, 2022 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
deleted file mode 100644
index 68e6cf8..0000000
--- a/x11-drivers/ati-drivers/ChangeLog
+++ /dev/null
@@ -1,1339 +0,0 @@
-# ChangeLog for x11-drivers/ati-drivers
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.145 2009/03/12 11:57:23 flameeyes Exp $
-
- 12 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
- ati-drivers-8.561.ebuild, ati-drivers-8.573.ebuild,
- ati-drivers-8.573-r1.ebuild, ati-drivers-8.582.ebuild:
- Remove binchecks restriction (package installs binaries!).
-
- 26 Feb 2009; Jeff Gardner <je_fro@gentoo.org>
- +files/8.582/ati-powermode-opt-path-2.patch,
- +files/8.582/ati-drivers-xen-8.552.patch, +ati-drivers-8.582.ebuild:
- Add needed files
-
-*ati-drivers-8.582 (26 Feb 2009)
-
- 26 Feb 2009; Jeff Gardner <je_fro@gentoo.org>
- +files/8.582/ati-powermode-opt-path-2.patch,
- +files/8.582/ati-drivers-xen-8.552.patch, +ati-drivers-8.582.ebuild:
- Latest for testing
-
- 05 Feb 2009; Jeff Gardner <je_fro@gentoo.org> ChangeLog:
- Add libstdc++-v3 to RDEPEND, close bug #249192.
-
- 03 Feb 2009; Gordon Malm <gengor@gentoo.org> ati-drivers-8.542.ebuild:
- Fix compile with kernel 2.6.28, bug #252695 thanks to Sasha Medvedev.
-
- 03 Feb 2009; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.573.ebuild:
- Small cleanup.
-
- 03 Feb 2009; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.573.ebuild:
- Make authatieventsd.sh executable to fix bug #242582 thanks to Uros.
-
- 03 Feb 2009; Jeff Gardner <je_fro@gentoo.org> ChangeLog:
- Bump to latest. Thanks to Tomas Chvatal and Ben Vighy to name a few.
-
- 03 Jan 2009; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.561.ebuild:
- Cleanups
-
-*ati-drivers-8.561 (17 Dec 2008)
-
- 17 Dec 2008; Luca Barbato <lu_zero@gentoo.org>
- +files/8.552/ati-drivers-xen-8.552.patch, ati-drivers-8.542.ebuild,
- +ati-drivers-8.561.ebuild:
- Version bump + xen patch from git://github.com/tarsius/tarsius-tree.git
- see Bug #250590
-
- 25 Nov 2008; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.552-r2.ebuild:
- fix xorg-server deps
-
- 22 Nov 2008; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.552-r2.ebuild:
- Check for MAGIC_SYSRQ
-
-*ati-drivers-8.552-r2 (19 Nov 2008)
-
- 19 Nov 2008; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.552-r2.ebuild:
- New revision, supporting xorg 1.5
-
-*ati-drivers-8.552-r1 (15 Nov 2008)
-
- 15 Nov 2008; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.552.ebuild,
- +ati-drivers-8.552-r1.ebuild:
- Update ebuilds with support for xorg 1.5 and 1.4
-
-*ati-drivers-8.552 (15 Nov 2008)
-
- 15 Nov 2008; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.552.ebuild:
- Version bump
-
- 19 Oct 2008; Jeff Gardner <je_fro@gentoo.org> ChangeLog:
- Fix to check for UNUSED_SYMBOLS.
-
- 17 Oct 2008; Jeff Gardner <je_fro@gentoo.org>
- +files/8.542/ati-drivers-2.6.27.patch, ati-drivers-8.542.ebuild:
- Adding patch to finally fix bug #239248, thanks to Rodolphe Rocca and
- Thomas S. Howard.
-
- 17 Oct 2008; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.542.ebuild:
- Fix malformed header
-
-*ati-drivers-8.542 (17 Oct 2008)
-
- 17 Oct 2008; Jeff Gardner <je_fro@gentoo.org> +ati-drivers-8.542.ebuild:
- Latest version, thanks to Josh Saddler, closing bug #239248.
-
-*ati-drivers-8.532 (29 Sep 2008)
-
- 29 Sep 2008; Jeff Gardner <je_fro@gentoo.org>
- +files/8.532/ati-powermode-opt-path-2.patch, +ati-drivers-8.532.ebuild:
- Latest driver for testing, thanks to everyone on bug #238143.
-
- 09 Sep 2008; <b33fc0d3@gentoo.org> ati-drivers-8.493.ebuild,
- ati-drivers-8.501.ebuild, ati-drivers-8.512.ebuild,
- ati-drivers-8.522.ebuild:
- Made PREEMPT_RCU error message slightly more verbose
-
-*ati-drivers-8.522 (22 Aug 2008)
-*ati-drivers-8.512 (22 Aug 2008)
-
- 22 Aug 2008; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.512.ebuild,
- +ati-drivers-8.522.ebuild:
- New (broken) driver
-
- 09 Jul 2008; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.501.ebuild:
- stable x86, bug 230772
-
-*ati-drivers-8.501 (20 Jun 2008)
-
- 20 Jun 2008; Jeff Gardner <je_fro@gentoo.org> +ati-drivers-8.501.ebuild:
- latest from ati
-
-*ati-drivers-8.493 (24 May 2008)
-
- 24 May 2008; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.493.ebuild:
- New version, thanks to Thomas S. Howard <thoward1120@sbcglobal.net> for
- the input on Bug #223281
-
- 16 May 2008; Jeff Gardner <je_fro@gentoo.org>
- -files/8.42.3/linux-2.6.23.patch, -files/8.42.3/warnings.patch,
- -ati-drivers-8.42.3.ebuild:
- Spring cleaning, removed p.masked ebuild.
-
- 04 May 2008; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.471.3.ebuild:
- stable x86, bug 217401
-
-*ati-drivers-8.476 (26 Apr 2008)
-
- 26 Apr 2008; Luca Barbato <lu_zero@gentoo.org>
- +files/8.476/ati-powermode-opt-path-2.patch, +ati-drivers-8.476.ebuild:
- New version
-
- 20 Apr 2008; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.471.3.ebuild:
- Die on 2.6.25 kernels until fixed - see bug #218422.
-
- 13 Apr 2008; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.471.3.ebuild:
- Remove old dep
-
- 21 Mar 2008; Samuli Suominen <drac@gentoo.org> ati-drivers-8.471.3.ebuild:
- amd64 stable, tested with current stable gentoo-sources-2.6.24-r3 and HD2600
- PRO which didn't have any drivers in stable before this.
-
-*ati-drivers-8.471.3 (13 Mar 2008)
-
- 13 Mar 2008; Jeff Gardner <je_fro@gentoo.org>
- +files/8.471.3/ati-powermode-opt-path-2.patch,
- +ati-drivers-8.471.3.ebuild:
- Bump to latest. Thanks to James Le Cuirot, Paolo Pedroni, and Jory Pratt.
-
- 12 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
- Removing Marien Zwart (marienz, #107204) from metadata.xml.
-
- 03 Mar 2008; Jeff Gardner <je_fro@gentoo.org>
- ati-drivers-8.455.2-r1.ebuild:
- Add inputproto as dependency to fix bug 212202. Thanks to Matthias
- Wieding-Drewes
-
- 29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> ati-drivers-8.34.8.ebuild,
- ati-drivers-8.35.5.ebuild, ati-drivers-8.36.5.ebuild,
- ati-drivers-8.37.6.ebuild, ati-drivers-8.37.6-r1.ebuild,
- ati-drivers-8.39.4.ebuild, ati-drivers-8.40.4.ebuild,
- ati-drivers-8.42.3.ebuild, ati-drivers-8.433.ebuild,
- ati-drivers-8.443.1-r1.ebuild, ati-drivers-8.452.ebuild,
- ati-drivers-8.455.2.ebuild, ati-drivers-8.455.2-r1.ebuild:
- Remove icon extension from desktop entry to match Icon Theme Specification.
-
- 24 Feb 2008; Donnie Berkholz <dberkholz@gentoo.org>; ChangeLog:
- Update my email.
-
-*ati-drivers-8.455.2-r1 (19 Feb 2008)
-
- 19 Feb 2008; Jeff Gardner <je_fro@gentoo.org>
- +ati-drivers-8.455.2-r1.ebuild:
- Fix SRC_URI thanks to kroemmelbein on bug #210139
-
-*ati-drivers-8.455.2 (17 Feb 2008)
-
- 17 Feb 2008; Jeff Gardner <je_fro@gentoo.org>
- +files/8.455.2/ati-powermode-opt-path-2.patch,
- +ati-drivers-8.455.2.ebuild:
- Simple bump to latest version, closes bug #210139
-
- 04 Feb 2008; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.40.4.ebuild:
- Adding PCI_LEGACY check to take care of bug #208776.
-
- 30 Jan 2008; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.452.ebuild:
- ebuild to die if PCI_LEGACY not present with a 2.6.24 kernel, thanks to Jory
- Pratt
-
- 25 Jan 2008; Jeff Gardner <je_fro@gentoo.org> metadata.xml:
- Adding myself as a maintainer in metadata.xml
-
-*ati-drivers-8.452 (25 Jan 2008)
-
- 25 Jan 2008; Jeff Gardner <je_fro@gentoo.org>
- +files/8.452/ati-powermode-opt-path-2.patch, +ati-drivers-8.452.ebuild:
- The latest and greatest from ATI, thanks to Jory Pratt.
-
- 24 Dec 2007; Jeff Gardner <je_fro@gentoo.org>
- files/8.443.1/ati-powermode-opt-path-2.patch,
- ati-drivers-8.443.1-r1.ebuild:
- Fixing the patch
-
-*ati-drivers-8.443.1-r1 (24 Dec 2007)
-
- 24 Dec 2007; Jeff Gardner <je_fro@gentoo.org> -ati-drivers-8.443.1.ebuild,
- +ati-drivers-8.443.1-r1.ebuild:
- Introducing the ati-powermode-opt-path-2 combined patch. Thanks as always to
- Jory Pratt and Bernd Steinhauser.
-
- 24 Dec 2007; Jeff Gardner <je_fro@gentoo.org>
- +files/8.443.1/ati-powermode-opt-path-2.patch, ati-drivers-8.443.1.ebuild:
- Fixup wrt bug #202906. Thanks to Jory Pratt and Bernd Steinhauser.
-
-*ati-drivers-8.443.1 (21 Dec 2007)
-
- 21 Dec 2007; <jeff@gentoo.org>
- +files/8.443.1/ati-powermode-opt-path-1.patch,
- +ati-drivers-8.443.1.ebuild:
- Version bump, thanks to Bernd Steinhauser and especially Jory Pratt.
-
- 01 Dec 2007; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.433.ebuild:
- Adding emul-linux-x86-xlibs as a dep for amd64 systems
-
-*ati-drivers-8.433 (26 Nov 2007)
-
- 26 Nov 2007; Jeff Gardner <je_fro@gentoo.org>
- +files/8.433/ati-powermode-opt-path-1.patch, +ati-drivers-8.433.ebuild:
- Revision bump, thanks to Jory Pratt.
-
- 23 Nov 2007; Samuli Suominen <drac@gentoo.org> ati-drivers-8.40.4.ebuild:
- amd64 stable wrt #195524
-
- 20 Nov 2007; William L. Thomson Jr. <wltjr@gentoo.org>
- ati-drivers-8.42.3.ebuild:
- elog warning added per bug# 199720
-
-*ati-drivers-8.42.3 (19 Nov 2007)
-
- 19 Nov 2007; William L. Thomson Jr. <wltjr@gentoo.org>
- +files/8.42.3/linux-2.6.23.patch, +files/8.42.3/warnings.patch,
- +ati-drivers-8.42.3.ebuild:
- Bumped to latest release per bug #196820.
-
- 01 Nov 2007; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.40.4.ebuild:
- stable x86, bug 195524
-
- 09 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.32.5.ebuild:
- Stop providing virtual/opengl to get rid of the remaining repoman warnings.
-
- 09 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.32.5.ebuild, ati-drivers-8.33.6.ebuild,
- ati-drivers-8.33.6-r1.ebuild, ati-drivers-8.37.6-r1.ebuild,
- ati-drivers-8.40.4.ebuild:
- Fix quoting issues caught by latest repoman.
-
- 08 Sep 2007; Christoph Mende <angelos@gentoo.org>
- ati-drivers-8.39.4.ebuild:
- Stable on amd64 wrt bug #188794
-
- 21 Aug 2007; Markus Ullmann <jokey@gentoo.org> ati-drivers-8.39.4.ebuild:
- Stable on x86 wrt bug #188794
-
- 14 Aug 2007; Jeff Gardner <je_fro@gentoo.org> +ati-drivers-8.28.8.ebuild,
- ati-drivers-8.40.4.ebuild:
- adding doins common/etc/ati/signature to try and avoid watermark
-
- 14 Aug 2007; Jeff Gardner <je_fro@gentoo.org>
- -files/ati-drivers-8.28.8-linux-2.6.18.patch, -ati-drivers-8.28.8.ebuild,
- -ati-drivers-8.28.8-r1.ebuild, -ati-drivers-8.29.6.ebuild,
- -ati-drivers-8.30.3.ebuild, -ati-drivers-8.30.3-r1.ebuild:
- Remove obsolete files.
-
-*ati-drivers-8.40.4 (14 Aug 2007)
-
- 14 Aug 2007; <jeff@gentoo.org> +files/8.40.4/ati-drivers-2.6.23.patch,
- +files/8.40.4/ati-drivers-8.40.4-warnings.patch,
- +ati-drivers-8.40.4.ebuild:
- revbump thanks to Jory Pratt
-
- 05 Aug 2007; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.39.4.ebuild:
- Change to 'sh ${src}' instead of chmodding wrt bug #187821
-
- 04 Aug 2007; Jeff Gardner <je_fro@gentoo.org> ati-drivers-8.39.4.ebuild:
- Switch to EMULTILIB_PKG thanks to Jakub Moc and bug 187706.
-
-*ati-drivers-8.39.4 (03 Aug 2007)
-
- 03 Aug 2007; Jeff Gardner <je_fro@gentoo.org> +ati-drivers-8.39.4.ebuild:
- Revision bump - several changes wrt bug #183480. Special thanks to Jory
- Pratt and Jonathan Adamczewski.
-
- 01 Aug 2007; Jeff Gardner <je_fro@gentoo.org>
- ati-drivers-8.37.6-r1.ebuild:
- Fix kernel_is syntax.
-
- 01 Aug 2007; Jeff Gardner <je_fro@gentoo.org>
- +files/8.37.6/fix-ioctl-for-2.6.22.patch, ati-drivers-8.37.6-r1.ebuild:
- Add patch to allow compilation with 2.6.22 kernels. See bug #182597.
-
- 22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.28.8-r1.ebuild, ati-drivers-8.29.6.ebuild,
- ati-drivers-8.30.3.ebuild, ati-drivers-8.30.3-r1.ebuild,
- ati-drivers-8.32.5.ebuild, ati-drivers-8.33.6.ebuild,
- ati-drivers-8.33.6-r1.ebuild:
- Drop virtual/x11 references.
-
- 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.28.8-r1.ebuild, ati-drivers-8.29.6.ebuild,
- ati-drivers-8.30.3.ebuild, ati-drivers-8.30.3-r1.ebuild,
- ati-drivers-8.32.5.ebuild, ati-drivers-8.33.6.ebuild,
- ati-drivers-8.33.6-r1.ebuild:
- (QA) RESTRICT clean up.
-
- 01 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.29.6.ebuild, ati-drivers-8.30.3.ebuild,
- ati-drivers-8.30.3-r1.ebuild, ati-drivers-8.32.5.ebuild,
- ati-drivers-8.33.6-r1.ebuild, ati-drivers-8.34.8.ebuild,
- ati-drivers-8.35.5.ebuild, ati-drivers-8.36.5.ebuild,
- ati-drivers-8.37.6.ebuild, ati-drivers-8.37.6-r1.ebuild:
- (QA) RESTRICT="multilib-pkg-force" -> EMULTILIB_PKG="true"
-
- 17 Jun 2007; Marien Zwart <marienz@gentoo.org>
- ati-drivers-8.37.6-r1.ebuild:
- Add multilib to IUSE, fixes bug #182123, thanks to jakub for reporting.
-
-*ati-drivers-8.37.6-r1 (05 Jun 2007)
-
- 05 Jun 2007; Marien Zwart <marienz@gentoo.org> +files/libGL.la.in,
- +ati-drivers-8.37.6-r1.ebuild:
- Add a check for paravirt in the kernel (bug #165634, thanks to Elias Probst
- for the patch), add a dependency on emul-linux-x86-compat on amd64 for a 32
- bit libstdc++ (bug #173962, thanks to Bernd Steinhauser and Christoph
- Mende), create a (hopefully) sane libGL.la (should fix bug #179713, thanks
- to Anarchy on irc for the initial implementation).
-
-*ati-drivers-8.37.6 (01 Jun 2007)
-
- 01 Jun 2007; Marien Zwart <marienz@gentoo.org> +ati-drivers-8.37.6.ebuild:
- Version bump.
-
- 25 May 2007; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.35.5.ebuild:
- x86/amd64 stable, bug 179526
-
-*ati-drivers-8.36.5 (24 May 2007)
-
- 24 May 2007; Marien Zwart <marienz@gentoo.org> +ati-drivers-8.36.5.ebuild:
- Version bump with improvements from Bugs Bunny <anarchpenguin@gmail.com>,
- closes bug #175337 and should fix bug #169125.
-
- 18 May 2007; Marien Zwart <marienz@gentoo.org> files/atieventsd.init:
- Fix line endings issue (bug #179062), thanks to Elias Probst
- <mail@eliasprobst.eu> for reporting.
-
- 18 May 2007; Roy Marples <uberlord@gentoo.org> files/atieventsd.init:
- Fix the init script to work on baselayout-2
-
- 30 Mar 2007; Marien Zwart <marienz@gentoo.org>
- +files/ati-drivers-8.35.5-2.6.19.patch,
- files/ati-drivers-8.35.5-2.6.20.patch, ati-drivers-8.35.5.ebuild:
- Fix compilation with a 2.6.19 kernel (bug #172727).
-
-*ati-drivers-8.35.5 (29 Mar 2007)
-
- 29 Mar 2007; Marien Zwart <marienz@gentoo.org>
- +files/ati-drivers-8.35.5-2.6.20.patch, -ati-drivers-8.33.6-r2.ebuild,
- ati-drivers-8.34.8.ebuild, +ati-drivers-8.35.5.ebuild:
- Version bump. Add missing dependencies noticed by Paul Thomas
- <thomaspu@gmail.com>, closes bug #172683.
-
- 10 Mar 2007; Marien Zwart <marienz@gentoo.org>
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.28.8-r1.ebuild, ati-drivers-8.29.6.ebuild,
- ati-drivers-8.30.3.ebuild, ati-drivers-8.30.3-r1.ebuild,
- ati-drivers-8.32.5.ebuild, ati-drivers-8.33.6.ebuild,
- ati-drivers-8.33.6-r1.ebuild:
- Remove weird dyn_unpack hack (removal requested by Kugelfang). Should have
- no effect for "normal" portage versions, users of the experimental portage
- the hack was for should be fine on 8.34.8.
-
- 04 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.28.8-r1.ebuild:
- stable x86; bug 148424
-
- 24 Feb 2007; Marien Zwart <marienz@gentoo.org> ati-drivers-8.34.8.ebuild:
- Apply another patch from desbaine@yahoo.com to fix compilation with
- --as-needed. Closes bug #168207.
-
- 24 Feb 2007; Marien Zwart <marienz@gentoo.org> ati-drivers-8.34.8.ebuild:
- Apply a patch from desbaine@yahoo.com to fix bug #168163: make ati-drivers
- compile if a previous version is not installed.
-
-*ati-drivers-8.34.8 (22 Feb 2007)
-
- 22 Feb 2007; Marien Zwart <marienz@gentoo.org> +files/atieventsd.init,
- +ati-drivers-8.34.8.ebuild:
- Version bump, based on the 8.33.6-r2 ebuild with some further cleanup.
- Closes bug #167903.
-
- 12 Feb 2007; Simon Stelling <blubb@gentoo.org> ati-drivers-8.32.5.ebuild:
- RESTRICT=test and mark stable on amd64; bug 148424
-
- 10 Feb 2007; Marien Zwart <marienz@gentoo.org>
- ati-drivers-8.33.6-r2.ebuild:
- Fix lack of glx extension.
-
-*ati-drivers-8.33.6-r2 (10 Feb 2007)
-
- 10 Feb 2007; Marien Zwart <marienz@gentoo.org>
- +files/ati-powermode-opt-path.patch, +ati-drivers-8.33.6-r2.ebuild:
- Experimental new ebuild (package.masked, work in progress).
-
-*ati-drivers-8.33.6-r1 (09 Feb 2007)
-
- 09 Feb 2007; Marien Zwart <marienz@gentoo.org>
- +ati-drivers-8.33.6-r1.ebuild:
- Hopefully fix support for 32 bit dri on amd64 (multilib) (bug #165871,
- thanks to Alejandro Wainzinger for reporting).
-
- 08 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
- ati-drivers-8.32.5.ebuild:
- stable x86; bug #148424
-
-*ati-drivers-8.28.8-r1 (05 Feb 2007)
-
- 05 Feb 2007; Marien Zwart <marienz@gentoo.org>
- +files/ati-drivers-8.28.8-linux-2.6.18.patch,
- +ati-drivers-8.28.8-r1.ebuild:
- Revision bump to 8.28.8 (last version that works with a couple of chipsets)
- to compile with older kernels thanks to a patch from alonbl@gentoo.org (bug
- #148424). Some minor cleanup and RESTRICT=stricter fixes.
-
-*ati-drivers-8.33.6 (05 Feb 2007)
-
- 05 Feb 2007; Marien Zwart <marienz@gentoo.org>
- +files/ati-drivers-2.6.20.patch, metadata.xml, +ati-drivers-8.33.6.ebuild:
- Version bump, closes bug #161378. Minor ebuild cleanup, skip more stuff for
- FEATURES stricter and test. Add myself to metadata.xml.
-
- 31 Jan 2007; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.32.5.ebuild:
- add libXrandr dep needed by aticonfig
-
-*ati-drivers-8.32.5 (25 Dec 2006)
-
- 25 Dec 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.32.5.ebuild:
- New version
-
- 03 Dec 2006; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.30.3-r1.ebuild:
- typo, thanks Anarchy
-
- 03 Dec 2006; Luca Barbato <lu_zero@gentoo.org>
- +files/ati-drivers-2.6.19.patch, ati-drivers-8.30.3-r1.ebuild:
- ebuild cleanup from Anarchy&genstef (featuring dsd) see bug #143509
-
-*ati-drivers-8.30.3-r1 (02 Nov 2006)
-
- 02 Nov 2006; Chris Bainbridge <chrb@gentoo.org>
- +ati-drivers-8.30.3-r1.ebuild:
- Config files installed to /etc/ati, bug #153780
-
-*ati-drivers-8.30.3 (01 Nov 2006)
-
- 01 Nov 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.30.3.ebuild:
- New version, thanks to Jory for the test and the help.
-
- 13 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
- ati-drivers-8.27.10-r1.ebuild, ati-drivers-8.28.8.ebuild,
- ati-drivers-8.29.6.ebuild:
- TEXTREL->TEXTRELS for bug #145040.
-
-*ati-drivers-8.29.6 (25 Sep 2006)
-
- 25 Sep 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.29.6.ebuild:
- New version
-
- 18 Sep 2006; Luca Barbato <lu_zero@gentoo.org>
- -files/fglrx-2.6.12-inter_module_get.patch,
- -files/fglrx-2.6.12-pci_name.patch, -files/fglrx-2.6.14-access_ok.patch,
- -files/fglrx-2.6.14-compat_ioctl.patch,
- -files/ati-drivers-8.22.5-intermodule.patch,
- -files/ati-drivers-8.23.7-gcc41.patch,
- -files/ati-drivers-8.23.7-noiommu.patch, -files/ioctl32.patch,
- -files/fglrx-8.14.13-alt-2.6.12-agp.patch, -files/p1.patch,
- -files/8.8.25-smp.patch, -files/8.8.25-via-amd64.patch,
- -files/ati-drivers-8.20.8-linux-2.6.15.patch,
- -files/ati-drivers-8.21.7-linux-2.6.15.patch,
- -ati-drivers-8.14.13-r2.ebuild, -ati-drivers-8.14.13-r3.ebuild,
- -ati-drivers-8.14.13-r4.ebuild, -ati-drivers-8.14.13-r5.ebuild,
- -ati-drivers-8.16.20.ebuild, -ati-drivers-8.16.20-r1.ebuild,
- -ati-drivers-8.18.6.ebuild, -ati-drivers-8.18.6-r1.ebuild,
- -ati-drivers-8.18.8.ebuild, -ati-drivers-8.18.8-r1.ebuild,
- -ati-drivers-8.18.8-r2.ebuild, -ati-drivers-8.19.10.ebuild,
- -ati-drivers-8.20.8.ebuild, -ati-drivers-8.21.7.ebuild,
- -ati-drivers-8.21.7-r1.ebuild, -ati-drivers-8.22.5.ebuild,
- -ati-drivers-8.23.7.ebuild, -ati-drivers-8.24.8.ebuild,
- -ati-drivers-8.25.18.ebuild, -ati-drivers-8.26.18.ebuild,
- -ati-drivers-8.26.18-r1.ebuild, -ati-drivers-8.27.10.ebuild:
- Cleanup
-
-*ati-drivers-8.28.8 (31 Aug 2006)
-
- 31 Aug 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.28.8.ebuild:
- New version
-
-*ati-drivers-8.27.10-r1 (04 Aug 2006)
-
- 04 Aug 2006; Chris Bainbridge <chrb@gentoo.org>
- +files/ati-powermode.sh.patch, files/atieventsd.rc6,
- +ati-drivers-8.27.10-r1.ebuild:
- Fix to work with xorg 7.0, fix eventsd init script, fix power state restore,
- thanks to Armando Di Cianno and Christian Affolter in bug #139458
-
-*ati-drivers-8.27.10 (01 Aug 2006)
-
- 01 Aug 2006; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.27.10.ebuild:
- New version
-
- 20 Jul 2006; Simon Stelling <blubb@gentoo.org>
- ati-drivers-8.21.7-r1.ebuild:
- stable on amd64
-
- 09 Jul 2006; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.26.18-r1.ebuild:
- Typo spotted by Gothgirl
-
-*ati-drivers-8.26.18-r1 (06 Jul 2006)
-
- 06 Jul 2006; Luca Barbato <lu_zero@gentoo.org> files/09ati,
- +files/atieventsd.rc6, +ati-drivers-8.26.18-r1.ebuild:
- Add support for acpi, thanks to Armando Di Cianno <armando@goodship.net> for
- the initial ebuild, see bug #138414
-
-*ati-drivers-8.26.18 (27 Jun 2006)
-
- 27 Jun 2006; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.25.18.ebuild,
- +ati-drivers-8.26.18.ebuild:
- New version
-
- 03 Jun 2006; Joshua Baergen <joshuabaergen@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.14.13-r3.ebuild,
- ati-drivers-8.14.13-r4.ebuild, ati-drivers-8.14.13-r5.ebuild,
- ati-drivers-8.16.20.ebuild, ati-drivers-8.16.20-r1.ebuild,
- ati-drivers-8.18.6.ebuild, ati-drivers-8.18.6-r1.ebuild,
- ati-drivers-8.18.8.ebuild, ati-drivers-8.18.8-r1.ebuild,
- ati-drivers-8.18.8-r2.ebuild, ati-drivers-8.19.10.ebuild,
- ati-drivers-8.20.8.ebuild, ati-drivers-8.21.7.ebuild,
- ati-drivers-8.21.7-r1.ebuild, ati-drivers-8.22.5.ebuild,
- ati-drivers-8.23.7.ebuild, ati-drivers-8.24.8.ebuild,
- ati-drivers-8.25.18.ebuild:
- Actually block xorg-server, rather than depending on an older version.
-
- 03 Jun 2006; Joshua Baergen <joshuabaergen@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.14.13-r3.ebuild,
- ati-drivers-8.14.13-r4.ebuild, ati-drivers-8.14.13-r5.ebuild,
- ati-drivers-8.16.20.ebuild, ati-drivers-8.16.20-r1.ebuild,
- ati-drivers-8.18.6.ebuild, ati-drivers-8.18.6-r1.ebuild,
- ati-drivers-8.18.8.ebuild, ati-drivers-8.18.8-r1.ebuild,
- ati-drivers-8.18.8-r2.ebuild, ati-drivers-8.19.10.ebuild,
- ati-drivers-8.20.8.ebuild, ati-drivers-8.21.7.ebuild,
- ati-drivers-8.21.7-r1.ebuild, ati-drivers-8.22.5.ebuild,
- ati-drivers-8.23.7.ebuild, ati-drivers-8.24.8.ebuild,
- ati-drivers-8.25.18.ebuild:
- None of these drivers will work with xorg-server 1.1, so block it.
-
- 27 May 2006; Luca Barbato <lu_zero@gentoo.org> ChangeLog:
- Manifest fix
-
- 26 May 2006; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.25.18.ebuild:
- QA warnings suppression
-
-*ati-drivers-8.25.18 (25 May 2006)
-
- 25 May 2006; Jory A. Pratt <anarchy@gentoo.org>
- +ati-drivers-8.25.18.ebuild:
- revision bump
-
- 07 May 2006; Jory A. Pratt <anarchy@gentoo.org> ati-drivers-8.24.8.ebuild:
- marked 8.24.8 for ~amd64 and ~x86
-
- 02 May 2006; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.24.8.ebuild:
- Preserve LIBGL_DRIVERS_PATH
-
- 02 May 2006; Jory A. Pratt <anarchy@gentoo.org>
- +files/ati-drivers-8.23.7-gcc41.patch, ati-drivers-8.23.7.ebuild,
- ati-drivers-8.24.8.ebuild:
- mem_map fix, 2.6.17 support add
-
- 29 Apr 2006; Marien Zwart <marienz@gentoo.org>
- files/digest-ati-drivers-8.18.8, files/digest-ati-drivers-8.18.8-r1,
- files/digest-ati-drivers-8.18.8-r2, files/digest-ati-drivers-8.19.10,
- files/digest-ati-drivers-8.20.8, files/digest-ati-drivers-8.21.7,
- files/digest-ati-drivers-8.23.7, Manifest:
- Fix SHA256 digests.
-
-*ati-drivers-8.24.8 (17 Apr 2006)
-
- 17 Apr 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.24.8.ebuild:
- New driver
-
- 10 Apr 2006; <chrb@gentoo.org> ati-drivers-8.23.7.ebuild:
- Add warning about UseFastTLS and multi-threaded apps, #126805
-
- 21 Mar 2006; Jory A. Pratt <anarchy@gentoo.org>
- +files/ati-drivers-8.23.7-noiommu.patch, ati-drivers-8.23.7.ebuild:
- 2.6.16 support wrt bug#122335
-
- 21 Mar 2006; Jory A. Pratt <anarchy@gentoo.org> ati-drivers-8.23.7.ebuild:
- fixed patch for 2.6.16 wrt #126151
-
-*ati-drivers-8.23.7 (13 Mar 2006)
-
- 13 Mar 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.23.7.ebuild:
- New drivers
-
- 08 Mar 2006; Michele Noberasco <s4t4n@gentoo.org> ati-drivers-8.21.7-r1.ebuild:
- Stable for x86. See bug #124215.
-
-*ati-drivers-8.21.7-r1 (08 Mar 2006)
-
- 08 Mar 2006; <anarchy@gentoo.org> +ati-drivers-8.21.7-r1.ebuild:
- revision for opengl-update on 8.21.7
-
- 23 Feb 2006; <anarchy@gentoo.org>
- +files/ati-drivers-8.22.5-intermodule.patch, ati-drivers-8.22.5.ebuild:
- intermodule fix for kernel 2.6.16 wrt bug#123643
-
- 22 Feb 2006; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild, ati-drivers-8.14.13-r5.ebuild,
- ati-drivers-8.16.20-r1.ebuild, ati-drivers-8.18.6.ebuild,
- ati-drivers-8.18.6-r1.ebuild, ati-drivers-8.18.8.ebuild,
- ati-drivers-8.18.8-r1.ebuild, ati-drivers-8.18.8-r2.ebuild,
- ati-drivers-8.19.10.ebuild, ati-drivers-8.20.8.ebuild,
- ati-drivers-8.21.7.ebuild, ati-drivers-8.22.5.ebuild:
- Fix for postrm, thanks to TGL <degrenier@easyconnect.fr> for spotting the
- issue and providing the fix for it in bug #123664
-
-*ati-drivers-8.22.5 (10 Feb 2006)
-
- 10 Feb 2006; <anarchy@gentoo.org> +ati-drivers-8.22.5.ebuild:
- revision bump, full support for 2.6.15
-
- 04 Feb 2006; Marien Zwart <marienz@gentoo.org> ati-drivers-8.21.7.ebuild:
- Do not doexe the same file twice (previous commit "fixed" something a second
- time...). Spotted by Anarchy.
-
- 03 Feb 2006; Marien Zwart <marienz@gentoo.org> ati-drivers-8.21.7.ebuild:
- Install in the correct location when modular xorg-server is installed but
- the xorg-x11 meta is not. Add RESTRICT=stricter.
-
- 21 Jan 2006; <anarchy@gentoo.org>
- +files/ati-drivers-8.21.7-linux-2.6.15.patch, ati-drivers-8.21.7.ebuild:
- 2.6.15 patch added, small fix for libfglrxdrm.so
-
-*ati-drivers-8.21.7 (21 Jan 2006)
-
- 21 Jan 2006; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.21.7.ebuild:
- New version
-
- 21 Jan 2006; <anarchy@gentoo.org> ati-drivers-8.20.8.ebuild:
- corrected missing file for modular X
-
- 11 Jan 2006; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.20.8.ebuild:
- Fixed bug #113872
-
- 03 Jan 2006; Jory A. Pratt <anarchy@gentoo.org>
- +files/ati-drivers-8.20.8-linux-2.6.15.patch, ati-drivers-8.20.8.ebuild:
- patched 8.20.8 for kernel-2.6.15
-
- 19 Dec 2005; Jory A. Pratt <anarchy@gentoo.org> ati-drivers-8.20.8.ebuild:
- fixed for modular X
-
-*ati-drivers-8.20.8 (11 Dec 2005)
-
- 11 Dec 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.20.8.ebuild:
- New release
-
- 06 Dec 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.19.10.ebuild:
- Minor fixes
-
-*ati-drivers-8.18.8-r2 (03 Dec 2005)
-
- 03 Dec 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.18.8-r2.ebuild, ati-drivers-8.19.10.ebuild:
- Backport to opengl-update
-
- 16 Nov 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.19.10.ebuild:
- Fixed the 2.6.14 support and minor changes leading to better modular X support
-
- 15 Nov 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.19.10.ebuild:
- Patch removed
-
- 15 Nov 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.19.10.ebuild:
- Extended LIBGL_DRIVERS_PATH support
-
- 14 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild:
- removed amd64 patch
-
- 14 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild:
- Yet another backport port
-
- 13 Nov 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.19.10.ebuild:
- Wrong fowardport fixed.
-
- 13 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.19.10.ebuild:
- Backport fixes for 2.6.14
-
-*ati-drivers-8.19.10 (12 Nov 2005)
-
- 12 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- -.#ati-drivers-8.14.13.ebuild.1.1, -.#ati-drivers-8.16.20.ebuild.1.2,
- +ati-drivers-8.19.10.ebuild:
- new release and cleanup
-
- 12 Nov 2005; Luca Barbato <lu_zero@gentoo.org> +files/09ati,
- +files/fglrx-2.6.12-inter_module_get.patch,
- +files/fglrx-2.6.14-access_ok.patch, +files/8.8.25-smp.patch,
- +files/p1.patch, +files/fglrx-2.6.12-pci_name.patch,
- +files/fglrx-2.6.14-compat_ioctl.patch, +.#ati-drivers-8.14.13.ebuild.1.1,
- +files/8.8.25-via-amd64.patch, +files/fglrx-8.14.13-alt-2.6.12-agp.patch,
- +.#ati-drivers-8.16.20.ebuild.1.2, +files/ioctl32.patch, +metadata.xml,
- +ati-drivers-8.14.13-r2.ebuild, +ati-drivers-8.14.13-r3.ebuild,
- +ati-drivers-8.14.13-r4.ebuild, +ati-drivers-8.14.13-r5.ebuild,
- +ati-drivers-8.16.20.ebuild, +ati-drivers-8.16.20-r1.ebuild,
- +ati-drivers-8.18.6.ebuild, +ati-drivers-8.18.6-r1.ebuild,
- +ati-drivers-8.18.8.ebuild, +ati-drivers-8.18.8-r1.ebuild:
- Moved from media-video/ati-drivers to x11-drivers/ati-drivers.
-
- 06 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.18.8-r1.ebuild:
- Minor fix for modular X
-
- 05 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.18.8-r1.ebuild:
- compat_ioctl should apply just on amd64 for now, I'll properly fix later
-
-*ati-drivers-8.18.8-r1 (04 Nov 2005)
-
- 04 Nov 2005; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-2.6.14-access_ok.patch,
- +files/fglrx-2.6.14-compat_ioctl.patch, +ati-drivers-8.18.8-r1.ebuild:
- New ebuild with linux 2.6.14 and modular X support, thanks to Mike Auty
- <m.auty@softhome.net> and George L. Emigh <george@georgelemigh.com>, kernel
- patches from ati unofficial bugzilla
-
-*ati-drivers-8.18.8 (28 Oct 2005)
-
- 28 Oct 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.18.8.ebuild:
- New version
-
-*ati-drivers-8.18.6-r1 (27 Oct 2005)
-
- 27 Oct 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.18.6-r1.ebuild:
- New version with improved xorg and gcc support, thanks to Robert Führicht
- <the_master_of_disaster@gmx.at>
-
- 22 Oct 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.18.6.ebuild:
- Minor changes
-
- 19 Oct 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.18.6.ebuild:
- Fix the verify_area/access_ok symbol, as reported in bug #109493 (thank you
- Alex Giouzenis <agios@computer.org>), fixed the bug #109689 ( thank you Jakub
- Argasiñski <argasek@tekla.art.pl>)
-
- 16 Oct 2005; Luca Barbato <lu_zero@gentoo.org>
- files/digest-ati-drivers-8.18.6, Manifest:
- digest fix
-
-*ati-drivers-8.18.6 (15 Oct 2005)
-
- 15 Oct 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.18.6.ebuild:
- New version
-
- 08 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild, ati-drivers-8.14.13-r5.ebuild:
- close quotes
-
- 08 Oct 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild, ati-drivers-8.14.13-r5.ebuild:
- Backported linux-mod fix.
-
- 02 Oct 2005; Chris Bainbridge <chrb@gentoo.org>
- ati-drivers-8.16.20-r1.ebuild:
- Fix linux-mod_src_install call so it actually installs fglrx.
-
- 27 Sep 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r3.ebuild, ati-drivers-8.14.13-r5.ebuild,
- ati-drivers-8.16.20-r1.ebuild:
- Fixed bug #104216
-
- 15 Sep 2005; Luca Barbato <lu_zero@gentoo.org>
- files/digest-ati-drivers-8.14.13-r5, Manifest:
- Fix digest
-
-*ati-drivers-8.16.20-r1 (13 Sep 2005)
-*ati-drivers-8.14.13-r5 (13 Sep 2005)
-
- 13 Sep 2005; Herbie Hopkins <herbs@gentoo.org>
- +ati-drivers-8.14.13-r5.ebuild, +ati-drivers-8.16.20-r1.ebuild:
- Fix 32bit dri support on amd64, bug 101539.
-
- 10 Sep 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.14.13-r3.ebuild,
- ati-drivers-8.14.13-r4.ebuild, ati-drivers-8.16.20.ebuild:
- Make it depend on libstdc++ 5
-
- 04 Sep 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.14.13-r2.ebuild:
- Recovered the latest stable ebuild
-
-*ati-drivers-8.14.13-r4 (03 Sep 2005)
-
- 03 Sep 2005; Jeremy Huddleston <eradicator@gentoo.org>
- -files/3.2.5-linux-2.6.0-test6-mm.patch,
- -files/fglrx-2.6.10-pci_get_class.patch, -files/8.08-kernel-2.6.10.patch,
- -files/fglrx-2.6-amd-adv-spec-fix.patch, -files/fglrx-2.6-get-page.patch,
- -files/fglrx-2.6-makefile.patch, -files/8.14.13-amd64.patch,
- -files/fglrx-2.6-fix-deprecated.patch, -files/fglrx-2.6-iminor.patch,
- -files/fglrx-2.6-pagetable.patch, -files/fglrx-2.6-vmalloc-vmaddr.patch,
- -ati-drivers-8.8.25-r3.ebuild, -ati-drivers-8.10.19.ebuild,
- -ati-drivers-8.12.10.ebuild, -ati-drivers-8.13.3.ebuild,
- -ati-drivers-8.13.4.ebuild, -ati-drivers-8.14.13.ebuild,
- -ati-drivers-8.14.13-r1.ebuild, -ati-drivers-8.14.13-r2.ebuild,
- ati-drivers-8.14.13-r3.ebuild, +ati-drivers-8.14.13-r4.ebuild,
- ati-drivers-8.16.20.ebuild:
- Clean outold cruft. Revbump to transition to eselect over opengl-update.
-
- 23 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.16.20.ebuild:
- BSD support
-
- 19 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.14.13-r2.ebuild, ati-drivers-8.16.20.ebuild:
- 8.16.20 seems to have too many issues.
- 8.14.13-r2 marked stable on x86 and amd64
-
- 18 Aug 2005; Luca Barbato <lu_zero@gentoo.org> ChangeLog:
- Readded ioctl32.patch for amd64
-
-*ati-drivers-8.16.20 (17 Aug 2005)
-
- 17 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.16.20.ebuild:
- New release, should support both onboard chips and standard ones
-
- 04 Aug 2005; Luca Barbato <lu_zero@gentoo.org> files/p1.patch:
- Fix a wrong patch, solves bug #101078
-
-*ati-drivers-8.14.13-r3 (04 Aug 2005)
-
- 04 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.14.13-r3.ebuild:
- dlloader support, thanks to Wolfgang Kroworsch <wolfgang@kroworsch.de> for
- the updated ebuild
-
-*ati-drivers-8.14.13-r2 (29 Jul 2005)
-
- 29 Jul 2005; Chris Bainbridge <chrb@gentoo.org> +files/ioctl32.patch,
- +files/fglrx-8.14.13-alt-2.6.12-agp.patch, +files/p1.patch,
- +ati-drivers-8.14.13-r2.ebuild:
- Remove 8.14.13-amd64.patch. Add fglrx-8.14.13-alt-2.6.12-agp.patch,
- ioctl32.patch, p1.patch. Bug #88767.
-
-*ati-drivers-8.13.4 (25 Jun 2005)
-
- 25 Jun 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.13.4.ebuild:
- New Xpress 200 driver, p.masked as usual since I cannot test it
-
- 25 Jun 2005; Luca Barbato <lu_zero@gentoo.org> +files/8.14.13-amd64.patch,
- ati-drivers-8.14.13.ebuild, ati-drivers-8.14.13-r1.ebuild:
- fix for bug #96740, thanks to Marcin Deranekl <gringo@slonko.net> for
- reporting and providing the patch
-
- 19 Jun 2005; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-2.6.12-inter_module_get.patch,
- files/fglrx-2.6.12-pci_name.patch, ati-drivers-8.14.13.ebuild,
- ati-drivers-8.14.13-r1.ebuild:
- Final fix for 2.6.12 support
-
- 19 Jun 2005; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-2.6.12-pci_name.patch, ati-drivers-8.14.13.ebuild,
- ati-drivers-8.14.13-r1.ebuild:
- Fix for linux 2.6.12
-
- 13 Jun 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.14.13.ebuild,
- ati-drivers-8.14.13-r1.ebuild:
- Fix for the latest driver, thanks to Robinson Sathaseevan
- <robysath@hotmail.com> for pointing out the issue
-
- 11 Jun 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.14.13.ebuild:
- Fixed wrong URL
-
- 10 Jun 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.14.13.ebuild,
- ati-drivers-8.14.13-r1.ebuild:
- Cosmetic change
-
-*ati-drivers-8.14.13-r1 (09 Jun 2005)
-*ati-drivers-8.14.13 (09 Jun 2005)
-
- 09 Jun 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.14.13.ebuild, +ati-drivers-8.14.13-r1.ebuild:
- New version
-
-*ati-drivers-8.13.3 (21 May 2005)
-
- 21 May 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.13.3.ebuild:
- New version, thanks to Erdroh Moshan <ErDroh@gmx.de> as usual for the notice
-
- 07 May 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.12.10.ebuild:
- Marked stable
-
- 04 May 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.12.10.ebuild:
- fix a bogus code in the ebuild, many thanks to Christoph Nodes
- <cnodes@gmail.com> for pointing the issue and making me fix it
-
- 26 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
- ati-drivers-8.12.10.ebuild:
- Make sure we have a valid opengl implementation when uninstalling. Closes
- bug #55142.
-
- 25 Apr 2005; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
- Update herd to x11-drivers.
-
- 18 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
- ati-drivers-8.8.25-r3.ebuild:
- Stable x86.
-
- 17 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
- -ati-drivers-8.8.25.ebuild:
- Removing version incompatible with remaining xorg-x11 and opengl-update
- versions.
-
- 11 Apr 2005; Luca Barbato <lu_zero@gentoo.org> +files/8.8.25-smp.patch,
- ati-drivers-8.12.10.ebuild:
- Fix smp issues (bug #72311) and gcc version issues (bug #84834, bug #83897),
- thanks to every people listed in the bugs for reporting and providing
- solutions
-
- 10 Apr 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.12.10.ebuild:
- Marked ~amd64
-
- 10 Apr 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.12.10.ebuild:
- Added kernel features check, warns if fails, in future it will block the ebuild
-
-*ati-drivers-8.12.10 (08 Apr 2005)
-
- 08 Apr 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.10.19.ebuild,
- +ati-drivers-8.12.10.ebuild:
- New version and minor fix, amd64 requires an updated patch.
-
- 07 Apr 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.10.19.ebuild:
- opengl useflag added
-
- 21 Mar 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.10.19.ebuild:
- Marked x86
-
- 18 Mar 2005; Luca Barbato <lu_zero@gentoo.org>
- -files/fglrx-3.2.8-fix-amd-adv-spec.patch,
- -files/fglrx-3.9.0-allocation.patch, -files/fglrx-3.9.0-regparm.patch,
- -ati-drivers-3.9.0.ebuild, -ati-drivers-3.9.0-r1.ebuild,
- -ati-drivers-3.11.1.ebuild, -ati-drivers-3.12.0.ebuild,
- -ati-drivers-3.14.1.ebuild, -ati-drivers-3.14.6.ebuild:
- Cleanup
-
- 24 Feb 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.10.19.ebuild:
- Minor fix, thanks to Karl Tomlinson <tomlinso+gentoo@esu1.auckland.ac.nz>
-
- 18 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
- files/fglrx-2.6-pagetable.patch:
- Another typo fixed, thanks to Mark S <mszilveszter@gmail.com> for reporting it
-
- 17 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
- files/fglrx-2.6-pagetable.patch:
- Fix a typo on the pagetable patch, thanks to Marcelo Penna Guerra
- <eu@marcelopenna.org> for pointing out
-
-*ati-drivers-8.10.19 (16 Feb 2005)
-
- 16 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.10.19.ebuild:
- New version
-
- 06 Feb 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.8.25.ebuild:
- Marked x86
-
- 05 Feb 2005; Dylan Carlson <absinthe@gentoo.org>
- +files/fglrx-2.6-pagetable.patch, ati-drivers-8.8.25-r3.ebuild:
- 4-level page table patch for 2.6.11 kernels (should be ok with =< 2.6.10 too).
-
- 01 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
- +files/8.8.25-via-amd64.patch, ati-drivers-8.8.25-r3.ebuild,
- ati-drivers-8.8.25.ebuild:
- Minor changes
-
-*ati-drivers-8.8.25 (01 Feb 2005)
-
- 01 Feb 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.8.25-r3.ebuild, +ati-drivers-8.8.25.ebuild:
- Added back an x86 only ebuild, made the custom header install in the X11_DIR
- instead of /usr/X11R6
-
- 27 Jan 2005; Luca Barbato <lu_zero@gentoo.org> :
- Fix for bug #78870
-
- 24 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
- ati-drivers-8.8.25-r3.ebuild:
- Adding >=x11-base/opengl-update-2.1_pre1 as an RDEPEND for MesaGL relatedness.
-
-*ati-drivers-8.8.25-r3 (24 Jan 2005)
-
- 24 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
- -ati-drivers-8.8.25-r1.ebuild, -ati-drivers-8.8.25-r2.ebuild,
- +ati-drivers-8.8.25-r3.ebuild, -ati-drivers-8.8.25.ebuild:
- Don't install libMesaGL (bug #47598). Set proper libdir in .la.
-
-*ati-drivers-8.8.25-r2 (23 Jan 2005)
-
- 23 Jan 2005; Luca Barbato <lu_zero@gentoo.org>
- +ati-drivers-8.8.25-r2.ebuild:
- Fixed the libGL.la, solves bug #78937
-
- 21 Jan 2005; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-8.8.25-r1.ebuild:
- Added back the libGL.la symlink
-
-*ati-drivers-8.8.25-r1 (20 Jan 2005)
-
- 20 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
- +ati-drivers-8.8.25-r1.ebuild:
- Multilib cleanups.
-
- 19 Jan 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.8.25.ebuild:
- typo in the multilib support section, fixed thanks Robert Führicht
- <the_master_of_disaster@gmx.at>
-
- 19 Jan 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.8.25.ebuild:
- Revert back the include symlink removal
-
- 19 Jan 2005; Luca Barbato <lu_zero@gentoo.org> :
- fixed amd64 digests
-
- 18 Jan 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.8.25.ebuild:
- Added support for amd64, multilib support should work, converted to the
- linux-mod eclass.
-
- 18 Jan 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.8.25.ebuild:
- minor change
-
- 18 Jan 2005; Luca Barbato <lu_zero@gentoo.org>
- -files/fglrx-3.7.0-fix-fglrx_panel-includes.patch,
- -ati-drivers-2.9.12.ebuild, -ati-drivers-2.9.13-r1.ebuild,
- -ati-drivers-2.9.13.ebuild, -ati-drivers-3.2.0.ebuild,
- -ati-drivers-3.2.4.ebuild, -ati-drivers-3.2.5-r1.ebuild,
- -ati-drivers-3.2.5.ebuild, -ati-drivers-3.2.8-r1.ebuild,
- -ati-drivers-3.2.8-r2.ebuild, -ati-drivers-3.2.8.ebuild,
- -ati-drivers-3.7.0.ebuild, -ati-drivers-3.7.6-r1.ebuild,
- -ati-drivers-3.7.6.ebuild:
- Cleanup
-
-*ati-drivers-8.8.25 (18 Jan 2005)
-
- 18 Jan 2005; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-8.8.25.ebuild:
- New version, the amd64 support will come later
-
- 08 Jan 2005; Luca Barbato <lu_zero@gentoo.org>
- +files/8.08-kernel-2.6.10.patch:
- Adding the official patch
-
- 27 Dec 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.14.6.ebuild:
- Marked x86
-
- 12 Nov 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.14.6.ebuild:
- Marked ~x86
-
-*ati-drivers-3.14.6 (11 Nov 2004)
-
- 11 Nov 2004; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-2.6.10-pci_get_class.patch, +ati-drivers-3.14.6.ebuild:
- New version, linux-2.6.10-rc1 partial support added
-
- 08 Oct 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.14.1.ebuild:
- Marked stable
-
- 02 Oct 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.14.1.ebuild:
- Cleanup + remove a stray patch
-
-*ati-drivers-3.14.1 (02 Oct 2004)
-
- 02 Oct 2004; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-3.14.1.ebuild:
- New version, it still doesn't work with the latest xorg
-
- 24 Sep 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.12.0.ebuild:
- Minor fix
-
- 23 Sep 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.12.0.ebuild:
- Pinning the deps, should be a better way to handle the issue
-
-*ati-drivers-3.12.0 (11 Sep 2004)
-
- 11 Sep 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.11.1.ebuild,
- +ati-drivers-3.12.0.ebuild:
- New version and added a check for xorg.
-
- 30 Aug 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.11.1.ebuild:
- Minor cleanup
-
-*ati-drivers-3.11.1 (09 Aug 2004)
-
- 09 Aug 2004; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-3.11.1.ebuild:
- New version
-
- 26 Jul 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-2.9.13-r1.ebuild, ati-drivers-3.2.0.ebuild,
- ati-drivers-3.2.4.ebuild, ati-drivers-3.2.5-r1.ebuild,
- ati-drivers-3.2.5.ebuild, ati-drivers-3.2.8-r1.ebuild,
- ati-drivers-3.2.8-r2.ebuild, ati-drivers-3.2.8.ebuild,
- ati-drivers-3.7.0.ebuild, ati-drivers-3.7.6-r1.ebuild,
- ati-drivers-3.7.6.ebuild, ati-drivers-3.9.0-r1.ebuild,
- ati-drivers-3.9.0.ebuild:
- /usr/src/linux needs ${ROOT}.
-
- 19 Jun 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.9.0-r1.ebuild:
- Marked stable
-
- 09 Jun 2004; Aron Griffis <agriffis@gentoo.org> ati-drivers-2.9.12.ebuild,
- ati-drivers-2.9.13-r1.ebuild, ati-drivers-2.9.13.ebuild,
- ati-drivers-3.2.0.ebuild, ati-drivers-3.2.4.ebuild,
- ati-drivers-3.2.5-r1.ebuild, ati-drivers-3.2.5.ebuild,
- ati-drivers-3.2.8-r1.ebuild, ati-drivers-3.2.8-r2.ebuild,
- ati-drivers-3.2.8.ebuild, ati-drivers-3.7.0.ebuild,
- ati-drivers-3.7.6-r1.ebuild, ati-drivers-3.7.6.ebuild,
- ati-drivers-3.9.0.ebuild:
- Fix use invocation
-
- 03 Jun 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.9.0-r1.ebuild:
- Reverted the memory allocation patch, added some instructions how to solve
- that, thanks again Aric Cyr <acyr76@yahoo.ca> for the notice.
-
-*ati-drivers-3.9.0-r1 (02 Jun 2004)
-
- 02 Jun 2004; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-3.9.0-allocation.patch, +files/fglrx-3.9.0-regparm.patch,
- +ati-drivers-3.9.0-r1.ebuild:
- Various patches to solve different issues, thanks to Tarmo Tanav
- <sn4ip3r@estprog.ee> for the regparm patch and Aric Cyr <acyr76@yahoo.ca> for
- the memory allocation fix.
-
-*ati-drivers-3.2.8-r2 (28 May 2004)
-
- 28 May 2004; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-3.2.8-r2.ebuild:
- Backport from 3.9.0, thanks to Edward Kaplan <theymight.begiants@verizon.net>
- for asking it and posting an ebuild.
-
-*ati-drivers-3.9.0 (27 May 2004)
-
- 27 May 2004; Luca Barbato <lu_zero@gentoo.org> +ati-drivers-3.9.0.ebuild:
- New version
-
- 27 May 2004; Luca Barbato <lu_zero@gentoo.org>
- +files/fglrx-2.6-get-page.patch, ati-drivers-3.7.6-r1.ebuild:
- Fix for 2.6.7 kernel
-
- 02 May 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-3.7.6-r1.ebuild:
- Remove needless call to portageq.
-
- 25 Apr 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-3.7.6-r1.ebuild:
- Provide virtual/opengl (#30107).
-
- 09 Apr 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-3.7.6-r1.ebuild:
- Fix X11_IMPLEM. Fix from merkaba@quantumfish.com (#47282).
-
-*ati-drivers-3.7.6-r1 (08 Apr 2004)
-
- 08 Apr 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-3.7.6-r1.ebuild:
- Update for xorg-x11 compatibility.
-
- 01 Apr 2004; Donnie Berkholz <dberkholz@gentoo.org>;
- ati-drivers-2.5.1-r1.ebuild, ati-drivers-2.5.1.ebuild, files/ati-2.5.1.diff:
- These only work with xfree 4.2 or lower. Since that's not around anymore,
- these shouldn't be either. Reported by Michael Sterrett
- <mr_bones_@gentoo.org>.
-
- 11 Mar 2004; Luca Barbato <lu_zero@gentoo.org> :
- Fixed executable perms
-
-*ati-drivers-3.7.6 (10 Mar 2004)
-
- 10 Mar 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.7.6.ebuild:
- New version, nwn players beware
-
-*ati-drivers-3.2.8-r1 (24 Feb 2004)
-
- 24 Feb 2004; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.8-r1.ebuild:
- driver only ebuild, optional stuff in ati-drivers-extra
-
- 30 Dec 2003; Martin Schlemmer <azarah@gentoo.org> ati-drivers-3.7.0.ebuild:
- Fix path to ATI control panel in .desktop files.
-
-*ati-drivers-3.7.0 (30 Dec 2003)
-
- 30 Dec 2003; Martin Schlemmer <azarah@gentoo.org> ati-drivers-3.7.0.ebuild,
- files/fglrx-3.7.0-fix-fglrx_panel-includes.patch:
- Update version. This closes bug #36743, with thanks for ebuild and patch
- to Alex Plank <aplank@notsohotmail.com>. Further did a major overhaul of
- the ebuild - lots of cleanups and form fixes.
-
- 28 Oct 2003; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.8.ebuild:
- Marked x86.
-
- 12 Oct 2003; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.8.ebuild:
- Small fix: bug #30975, thanks to Wedge_ <wedge__@fastmail.fm> for the
- suggestion
-
-*ati-drivers-3.2.8 (08 Oct 2003)
-
- 08 Oct 2003; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.8.ebuild:
- New version
-
- 07 Oct 2003; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.5-r1.ebuild,
- ati-drivers-3.2.5-r1.ebuild:
- Removed a patch not required anymore for the latest mm sources.
-
- 02 Oct 2003; Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.5-r1.ebuild,
- ati-drivers-3.2.5.ebuild:
- Make direct use of the provided Makefile
-
-*ati-drivers-3.2.5-r1 (30 Sep 2003)
-
- 30 Sep 2003; Brandon Low <lostlogic@gentoo.org> ati-drivers-3.2.5-r1.ebuild:
- Add support for most recent -mm kernels (1 line patch) and make ebuild a bit
- neater
-
- 08 Sep 2003 Luca Barbato <lu_zero@gentoo.org> :
- Removed old 2.9.8 and 2.9.6 ebuilds
-
-*ati-drivers-3.2.5 (05 Sep 2003)
-
- 05 Sep 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.5.ebuild:
- Some typos fixed
-
- 05 Sep 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.5.ebuild:
- New Version
-
- 05 Sep 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.4.ebuild,
- files/fglrx-2.6-vmalloc-vmaddr.patch:
- Added a workaround for mm-sources, cleaned a bit the ebuild.
- thanks to wedge_ for the patch, solves bug #27912
-
-*ati-drivers-3.2.4 (12 Aug 2003)
-
-*ati-drivers-3.2.0 (12 Aug 2003)
-
- 12 Aug 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-3.2.0.ebuild,
- ati-drivers-3.2.4.ebuild, files/fglrx-2.6-amd-adv-spec-fix.patch,
- files/fglrx-2.6-fix-deprecated.patch, files/fglrx-2.6-makefile.patch:
- New versions, thanks to Wedge_ for the work.
-
- 22 Jul 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.13-r1.ebuild,
- ChangeLog: Added experimental support for 2.6 kernels.
-
-*ati-drivers-2.9.13 (03 Jul 2003)
-
- 03 Jul 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.13.ebuild,
- ChangeLog: Version bump, support for later board.
-
-*ati-drivers-2.9.12 (19 May 2003)
-
- 19 May 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.12.ebuild,
- ChangeLog: Updated, thanks to Koen Geeraerts <ir007252@worldonline.be>
- for the notice.
-
- 11 May 2003; Luca Barbato <lu_zero@gentoo.org>
- ati-drivers-2.5.1-r1.ebuild, ati-2.5.1.diff: Added a patch to solve
- bug #20104, backported drobbins' tweaks.
-
- 01 May 2003; Daniel Robbins <drobbins@gentoo.org>
- ati-drivers-2.9.8.ebuild: Tweaked compile process to work even with NVIDIA
- headers (defined USE_GLU,) moved unpack stuff to src_unpack, and removed
- automatic calls to "opengl-update" (messed up gamecd.) Also unmasking for
- x86. And no longer installs app sources. And now auto-downloads and unpacks
- everthing. And dep fixes :)
-
-*ati-drivers-2.9.8 (26 Apr 2003)
-
- 26 Feb 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.8.ebuild,
- ChangeLog: New update, should had support to the 9800 serie.
-
- 23 Apr 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.6.ebuild,
- ati-drivers-2.5.1-r1,ChangeLog : Fix some stuff
-
-*ati-drivers-2.9.6 (3 Apr 2003)
- 3 Apr 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.9.6.ebuild,
- ChangeLog :
- As requested I update the ebuild, I do not suggest the use of those
- drivers
-
- 1 Mar 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.5.1-r1.ebuild,
- ChangeLog:
- make sure that the opengl is set to xfree while compiling and after
- unmerge.
-
-*ati-drivers-2.5.1-r1 (3 Feb 2003)
- 3 Feb 2003 Luca Barbato <lu_zero@gentoo.org> ati-drivers-2.5.1-r1.ebuild,
- ChangeLog, files/digest-ati-drivers-2.5.1-r1:
- add the xfree dependency to avoid the xfree 4.2.99 incompatibility.
- removed the previous ebuild.
-
-*ati-drivers-2.5.1 (26 Dec 2002)
-
- 26 Dec 2002;Brad Cowan <bcowan@gentoo.org> ati-drivers-2.5.1.ebuild,
- ChangeLog, files/digest-ati-drivers-2.5.1: Initial import.
-
- 29 Nov 2002; Luca Barbato <lu_zero@psxfanatics.com> ati-drivers-2.5.1.ebuild,
- ChangeLog, files/digest-ati-drivers-2.5.1:
- Initial ebuild for the ati precompiled drivers.
- The idea of using cpio is from the icc ebuilds, the rest is from the nvidia-*
- ebuilds.
-
diff --git a/x11-drivers/ati-drivers/Manifest b/x11-drivers/ati-drivers/Manifest
deleted file mode 100644
index be9b765..0000000
--- a/x11-drivers/ati-drivers/Manifest
+++ /dev/null
@@ -1,11 +0,0 @@
-AUX 09ati 75 RMD160 f4b42cfdc7deaa6fe7618e3506860a06a75de435 SHA1 01cac55ba02710dbd7d71737dd64dbec2cc081fd SHA256 5daa70f3e4c19f2b006bc7b2b22abde5404c3b498485b9ffac428eb458c32134
-AUX ati-drivers-xen.patch 1994 RMD160 45fe1a96bfaec597214c2b058c720c5f71797085 SHA1 4fd6da4c726c67feed8a6484af484ea525f3a112 SHA256 514dad9629fc689ec0344875a29d713f9d8de7ccbb0a22a2b80ede11bbbc6c58
-AUX ati-powermode-opt-path-2.patch 1634 RMD160 a9c4ecc90a748f94282521a555ad7b64db242249 SHA1 3f61d804710bd88ee45cd3a9e3672b356359dd73 SHA256 e7749e04a3aa24132b13d0c694563a45c0d38e238f7412a75bd89aa9f9e9ead1
-AUX ati-powermode.sh.patch 1142 RMD160 b81cdd4d2a49c2f7b04f7e00e4391b4e0ad67a40 SHA1 eef7f658474ca8e9e66ee1955a851782eba4dd0e SHA256 050602d5e0656961c0b16a75b470a7327a9e8b16f7d0ae3228341b3a8dcc9289
-AUX atieventsd.init 533 RMD160 b9b95a8a3f32dcafba3e5fa08d6d1053e831291a SHA1 982ffdb8064785c8b96fb0213ad7892ac918b5d7 SHA256 20010ebc5cb286149f3c4c9c099b6470463ccdb8fd47cea054b783dc2ad1fff3
-AUX atieventsd.rc6 590 RMD160 fbf8aba7ada36aed666d506d6b0f7146e1b2f4ad SHA1 b2b457a4122f0a3a5db785df46880351d795fb25 SHA256 a00aa241e53b21872218bd247bfdb6292a075d9ef641f36198d8f4e399cc025e
-AUX libGL.la.in 749 RMD160 b2eb11cd123cb0e789adb1e22dffdbfc03542f69 SHA1 be41cc2eb1754a44134a95475be5f0cb894e24bc SHA256 a7b4b58b1311f8e1caf83222cb020dfbc48e2881a8deef21eddefa23b3992f13
-DIST ati-driver-installer-9-3-x86.x86_64.run 84841550 RMD160 76d4aa6ec575403190b8feadce99000b69d64d14 SHA1 ceefdfd2f8ecee4998a4ce4b7b87a45f1851e8d0 SHA256 5efec58f92f2fbb90b0d9a9059eb27c9cfffcea0a4ba64f3c8f24fc5dbf8053e
-EBUILD ati-drivers-8.593.ebuild 15028 RMD160 74229bfef1370374688a3ba9cce19081370de95f SHA1 34c0961db446ef1d2e6e22108c4bc8df0f5d3b7e SHA256 9c743bb6c323d8d9628c2982ff09fb0336ede3c4d9cbc3ac3675bc9d0cfce1d0
-MISC ChangeLog 50367 RMD160 245cd2f63bb454de49af3692299504875745e919 SHA1 754ff9216e5555b1a5fd5f363d29761186255539 SHA256 06fd322ae15ea4bbeda75f9194beccaf30fd317cc0e3c75a6d2912063a2faad1
-MISC metadata.xml 294 RMD160 ce6129af48ca9c259fa89b297249a558c58657a2 SHA1 f17731063fe83ac4b733ec2127b2dcf1017a7095 SHA256 5db182fb2524bf0627a165b0fc4fbdb17b9e1668a49428ec68c9c6ac13a02eea
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.593.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.593.ebuild
deleted file mode 100644
index 2477a05..0000000
--- a/x11-drivers/ati-drivers/ati-drivers-8.593.ebuild
+++ /dev/null
@@ -1,448 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-8.582.ebuild,v 1.3 2009/03/14 23:28:20 mr_bones_ Exp $
-
-IUSE="acpi debug"
-
-inherit eutils multilib linux-mod toolchain-funcs versionator
-
-DESCRIPTION="Ati precompiled drivers for recent chipsets"
-HOMEPAGE="http://www.ati.com"
-ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
-SRC_URI="${ATI_URL}/ati-driver-installer-9-3-x86.x86_64.run"
-
-LICENSE="AMD GPL-2 QPL-1.0 as-is"
-KEYWORDS="~amd64 ~x86"
-
-# The portage dep is for COLON_SEPARATED support in env-update.
-# The eselect dep (>=1.0.9) is for COLON_SEPARATED in eselect env update.
-RDEPEND=">=x11-base/xorg-server-1.5
- !x11-apps/ati-drivers-extra
- >=app-admin/eselect-1.0.9
- app-admin/eselect-opengl
- sys-libs/libstdc++-v3
- amd64? ( app-emulation/emul-linux-x86-xlibs )
- acpi? (
- x11-apps/xauth
- sys-power/acpid
- )
- x11-libs/libXrandr
- >=sys-apps/portage-2.1.1-r1"
-
-DEPEND="${RDEPEND}
- x11-proto/xf86miscproto
- x11-proto/xf86vidmodeproto
- x11-proto/inputproto
- !<x11-drivers/ati-drivers-8.552-r1"
-
-EMULTILIB_PKG="true"
-
-S="${WORKDIR}"
-
-pkg_setup() {
-
- # Define module dir.
- MODULE_DIR="${S}/common/lib/modules/fglrx/build_mod"
-
- #check kernel and sets up KV_OBJ
- MODULE_NAMES="fglrx(video:${S}/common/lib/modules/fglrx/build_mod/2.6.x)"
- BUILD_TARGETS="kmod_build"
- linux-mod_pkg_setup
- BUILD_PARAMS="GCC_VER_MAJ=$(gcc-major-version) KVER=${KV_FULL} KDIR=${KV_DIR}"
-
- if kernel_is ge 2 6 29; then
- die "${P} is not yet compatible with 2.6.29 kernels. See bug #264021."
- fi
-
- if ! kernel_is 2 6; then
- eerror "Need a 2.6 kernel to compile against!"
- die "Need a 2.6 kernel to compile against!"
- fi
-
- if kernel_is ge 2 6 25 && linux_chkconfig_present PREEMPT_RCU; then
- die "${P} is not compatible with RCU Preemption (bug #223281), please disable it"
- fi
-
- if kernel_is ge 2 6 26 && ! linux_chkconfig_present UNUSED_SYMBOLS; then
- ewarn "You have to Enable unused/obsolete exported symbols in Kernel hacking section of kernel config for fglrx to load"
- fi
-
- if kernel_is ge 2 6 24 && ! linux_chkconfig_present PCI_LEGACY; then
- eerror "${P} requires support for pci_find_slot."
- die "${P} requires support for pci_find_slot."
- fi
-
- if ! linux_chkconfig_present MTRR; then
- ewarn "You don't have MTRR support enabled, the direct rendering will not work."
- fi
-
- if linux_chkconfig_builtin DRM; then
- ewarn "You have DRM support enabled builtin, the direct rendering will not work."
- fi
-
- if ! linux_chkconfig_present AGP && \
- ! linux_chkconfig_present PCIEPORTBUS; then
- ewarn "You need AGP and/or PCI Express support for direct rendering to work."
- fi
-
- if linux_chkconfig_present PARAVIRT; then
- eerror "The current ati-drivers don't compile when having"
- eerror "paravirtualization active due to GPL symbol export"
- eerror "restrictions."
- eerror "Please disable it:"
- eerror " CONFIG_PARAVIRT=n"
- eerror "in /usr/src/linux/.config or"
- eerror " Processor type and features -->"
- eerror " [ ] Paravirtualization support (EXPERIMENTAL)"
- eerror "in 'menuconfig'"
- die "CONFIG_PARAVIRT enabled"
- fi
-
- if ! linux_chkconfig_present MAGIC_SYSRQ; then
- eerror "You need MAGIC_SYSRQ enabled in order to build ati-drivers"
- die "CONFIG_MAGIC_SYSRQ disabled"
- fi
-
- # Only support xorg-server >=1.5
- BASE_DIR="${S}/x740"
-
- if ! linux_chkconfig_present PCI_MSI; then
- eerror "You need PCI_MSI enabled in order to build ati-drivers"
- die "CONFIG_PCI_MSI disabled"
- fi
-
- # This is used like $(get_libdir) for paths in ati's package.
- if use amd64 ; then
- MY_BASE_DIR="${BASE_DIR}_64a"
- PKG_LIBDIR=lib64
- ARCH_DIR="${S}/arch/x86_64"
- else
- MY_BASE_DIR="${BASE_DIR}"
- PKG_LIBDIR=lib
- ARCH_DIR="${S}/arch/x86"
- fi
-}
-
-src_unpack() {
- #Switching to a standard way to extract the files since otherwise no signature file
- #would be created
- local src="${DISTDIR}/${A}"
- sh "${src}" --extract "${S}" 2&>1 /dev/null
- cd "${S}"
- epatch "${FILESDIR}"/ati-drivers-xen.patch || die "epatch failed"
-
- # These are the userspace utilities that we also have source for.
- # We rebuild these later.
- rm \
- "${ARCH_DIR}"/usr/X11R6/bin/{fgl_glxgears,fglrx_xgamma} \
- "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR}/libfglrx_gamma* \
- || die "bin rm failed"
-
- if use debug; then
- # Enable debug mode in the Source Code.
- sed -i '/^#define DRM_DEBUG_CODE/s/0/1/' \
- "${MODULE_DIR}/firegl_public.c" \
- || die "Failed to enable debug output."
- fi
-
- if kernel_is ge 2 6 29; then
- pwd && epatch "${FILESDIR}"/ati-drivers-2.6.19.patch
- fi
-
- if use acpi; then
- sed -i \
- -e "s:/var/lib/xdm/authdir/authfiles/:/var/run/xauth/:" \
- -e "s:/var/lib/gdm/:/var/gdm/:" \
- "${S}/common/etc/ati/authatieventsd.sh" \
- || die "sed failed."
-
- # Since "who" is in coreutils, we're using that one instead of "finger".
- sed -i -e 's:finger:who:' \
- "${S}/common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh" \
- || die "Replacing 'finger' with 'who' failed."
- # Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/ and
- # add function to detect default state.
- epatch "${FILESDIR}"/ati-powermode-opt-path-2.patch || die "Failed to epatch powermode-opt-path-2.patch"
- fi
-
- pushd ${MODULE_DIR} >/dev/null
- ln -s "${ARCH_DIR}"/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC$(gcc-major-version) \
- || die "symlinking precompiled core failed"
-
- convert_to_m 2.6.x/Makefile || die "convert_to_m failed"
-
- # When built with ati's make.sh it defines a bunch of macros if
- # certain .config values are set, falling back to less reliable
- # detection methods if linux/autoconf.h is not available. We
- # simply use the linux/autoconf.h settings directly, bypassing the
- # detection script.
- sed -i -e 's/__SMP__/CONFIG_SMP/' *.c *h || die "SMP sed failed"
- sed -i -e 's/ifdef MODVERSIONS/ifdef CONFIG_MODVERSIONS/' *.c *.h \
- || die "MODVERSIONS sed failed"
- popd >/dev/null
-
- mkdir extra || die "mkdir failed"
- cd extra
- unpack ./../common/usr/src/ati/fglrx_sample_source.tgz
- sed -i -e 's:include/extensions/extutil.h:X11/extensions/extutil.h:' \
- lib/fglrx_gamma/fglrx_gamma.c || die "include fixup failed"
- # Add a category.
- mv programs/fglrx_gamma/fglrx_xgamma.{man,1} || die "man mv failed"
- cd ..
-}
-
-src_compile() {
- linux-mod_src_compile
-
- einfo "Building fgl_glxgears"
- cd "${S}"/extra/fgl_glxgears
- # These extra libs/utils either have an Imakefile that does not
- # work very well without tweaking or a Makefile ignoring CFLAGS
- # and the like. We bypass those.
-
- # The -DUSE_GLU is needed to compile using nvidia headers
- # according to a comment in ati-drivers-extra-8.33.6.ebuild.
- "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU \
- -I"${S}"/common/usr/include fgl_glxgears.c \
- -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed"
-
- einfo "Building fglrx_gamma lib"
- cd "${S}"/extra/lib/fglrx_gamma
- "$(tc-getCC)" -shared -fpic -o libfglrx_gamma.so.1.0 ${CFLAGS} ${LDFLAGS} \
- -DXF86MISC -Wl,-soname,libfglrx_gamma.so.1.0 fglrx_gamma.c \
- -lXext || die "fglrx_gamma lib build failed"
- ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so || die "ln failed"
- ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1 || die "ln failed"
-
- einfo "Building fglrx_gamma util"
- cd "${S}"/extra/programs/fglrx_gamma
- "$(tc-getCC)" -o fglrx_xgamma ${CFLAGS} ${LDFLAGS} \
- -I../../../common/usr/X11R6/include -L../../lib/fglrx_gamma \
- fglrx_xgamma.c -lm -lfglrx_gamma -lX11 \
- || die "fglrx_gamma util build failed"
-
-}
-
-src_install() {
- linux-mod_src_install
-
- # We can do two things here, and neither of them is very nice.
-
- # For direct rendering libGL has to be able to load one or more
- # dri modules (files ending in _dri.so, like fglrx_dri.so).
- # Gentoo's mesa looks for these files in the location specified by
- # LIBGL_DRIVERS_PATH or LIBGL_DRIVERS_DIR, then in the hardcoded
- # location /usr/$(get_libdir)/dri. Ati's libGL does the same
- # thing, but the hardcoded location is /usr/X11R6/lib/modules/dri
- # on x86 and amd64 32bit, /usr/X11R6/lib64/modules/dri on amd64
- # 64bit. So we can either put the .so files in that (unusual,
- # compared to "normal" mesa libGL) location or set
- # LIBGL_DRIVERS_PATH. We currently do the latter. See also bug
- # 101539.
-
- # The problem with this approach is that LIBGL_DRIVERS_PATH
- # *overrides* the default hardcoded location, it does not extend
- # it. So if ati-drivers is merged but a non-ati libGL is selected
- # and its hardcoded path does not match our LIBGL_DRIVERS_PATH
- # (because it changed in a newer mesa or because it was compiled
- # for a different set of multilib abis than we are) stuff breaks.
-
- # We create one file per ABI to work with "native" multilib, see
- # below.
-
- echo "COLON_SEPARATED=LIBGL_DRIVERS_PATH" > "${T}/03ati-colon-sep"
- doenvd "${T}/03ati-colon-sep"
-
- # All libraries that we have a 32 bit and 64 bit version of on
- # amd64 are installed in src_install-libs. Everything else
- # (including libraries only available in native 64bit on amd64)
- # goes in here.
-
- # There used to be some code here that tried to detect running
- # under a "native multilib" portage ((precursor of)
- # http://dev.gentoo.org/~kanaka/auto-multilib/). I removed that, it
- # should just work (only doing some duplicate work). --marienz
- if has_multilib_profile; then
- local OABI=${ABI}
- for ABI in $(get_install_abis); do
- src_install-libs
- done
- ABI=${OABI}
- unset OABI
- else
- src_install-libs
- fi
-
- # This is sorted by the order the files occur in the source tree.
-
- # X modules.
- exeinto /usr/$(get_libdir)/xorg/modules/drivers
- doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/drivers/fglrx_drv.so
- exeinto /usr/$(get_libdir)/xorg/modules/linux
- doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/linux/libfglrxdrm.so
- exeinto /usr/$(get_libdir)/xorg/modules
- doexe "${MY_BASE_DIR}"/usr/X11R6/${PKG_LIBDIR}/modules/{esut.a,glesx.so,amdxmm.so}
-
- # Arch-specific files.
- # (s)bin.
- into /opt
- if use acpi; then
- dosbin "${ARCH_DIR}"/usr/sbin/atieventsd
- fi
- # We cleaned out the compilable stuff in src_unpack
- dobin "${ARCH_DIR}"/usr/X11R6/bin/*
-
- # lib.
- exeinto /usr/$(get_libdir)
- # Everything except for the libGL.so installed in src_install-libs.
- doexe $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
- -maxdepth 1 -type f -name '*.so*' -not -name 'libGL.so*')
- insinto /usr/$(get_libdir)
- doins $(find "${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR} \
- -maxdepth 1 -type f -not -name '*.so*')
-
- # Common files.
- # etc.
- insinto /etc/ati
- # Everything except for the authatieventsd.sh script.
- doins common/etc/ati/{logo*,control,atiogl.xml,signature,amdpcsdb.default}
- if use acpi; then
- insopts -m0755
- doins common/etc/ati/authatieventsd.sh
- fi
-
- # include.
- insinto /usr
- doins -r common/usr/include
- insinto /usr/include/X11/extensions
- doins common/usr/X11R6/include/X11/extensions/fglrx_gamma.h
-
- # Just the atigetsysteminfo.sh script.
- into /usr
- dosbin common/usr/sbin/*
-
- # data files for the control panel.
- insinto /usr/share
- doins -r common/usr/share/ati
- insinto /usr/share/pixmaps
- doins common/usr/share/icons/ccc_{large,small}.xpm
- make_desktop_entry amdcccle 'ATI Catalyst Control Center' \
- ccc_large System
-
- # doc.
- dohtml -r common/usr/share/doc/fglrx
-
- if use acpi; then
- doman common/usr/share/man/man8/atieventsd.8
-
- pushd common/usr/share/doc/fglrx/examples/etc/acpi >/dev/null
-
- exeinto /etc/acpi
- doexe ati-powermode.sh
- insinto /etc/acpi/events
- doins events/*
-
- popd >/dev/null
- fi
-
- # Done with the "source" tree. Install tools we rebuilt:
- dobin extra/fgl_glxgears/fgl_glxgears
- newdoc extra/fgl_glxgears/README README.fgl_glxgears
-
- dolib extra/lib/fglrx_gamma/*so*
- newdoc extra/lib/fglrx_gamma/README README.libfglrx_gamma
-
- dobin extra/programs/fglrx_gamma/fglrx_xgamma
- doman extra/programs/fglrx_gamma/fglrx_xgamma.1
- newdoc extra/programs/fglrx_gamma/README README.fglrx_gamma
-
- # Gentoo-specific stuff:
- if use acpi; then
- newinitd "${FILESDIR}"/atieventsd.init atieventsd \
- || die "Failed to install atieventsd.init.d"
- echo 'ATIEVENTSDOPTS=""' > "${T}"/atieventsd.conf
- newconfd "${T}"/atieventsd.conf atieventsd
- fi
-}
-
-src_install-libs() {
- if [[ "${ABI}" == "amd64" ]]; then
- local EX_BASE_DIR="${BASE_DIR}_64a"
- local pkglibdir=lib64
- local MY_ARCH_DIR="${S}/arch/x86_64"
- else
- local EX_BASE_DIR="${BASE_DIR}"
- local pkglibdir=lib
- local MY_ARCH_DIR="${S}/arch/x86"
- fi
- einfo "ati tree '${pkglibdir}' -> '$(get_libdir)' on system"
-
- local ATI_ROOT=/usr/$(get_libdir)/opengl/ati
- # To make sure we do not miss a spot when these change.
- local libmajor=1 libminor=2
- local libver=${libmajor}.${libminor}
-
- # The GLX libraries
- # (yes, this really is "lib" even on amd64/multilib --marienz)
- exeinto ${ATI_ROOT}/lib
- doexe "${MY_ARCH_DIR}"/usr/X11R6/${pkglibdir}/libGL.so.${libver}
- dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so.${libmajor}
- dosym libGL.so.${libver} ${ATI_ROOT}/lib/libGL.so
-
- exeinto ${ATI_ROOT}/extensions
- doexe "${EX_BASE_DIR}"/usr/X11R6/${pkglibdir}/modules/extensions/*
-
- # DRI modules, installed into the path used by recent versions of mesa.
- exeinto /usr/$(get_libdir)/dri
- doexe "${MY_ARCH_DIR}"/usr/X11R6/${pkglibdir}/modules/dri/fglrx_dri.so
-
- # AMD Cal libraries
- exeinto /usr/$(get_libdir)
- doexe "${MY_ARCH_DIR}"/usr/${pkglibdir}/*.so
-
- # Make up a libGL.la. Ati does not provide one, but mesa does. If
- # a (libtool-based) libfoo is built with libGL.la present a
- # reference to it is put into libfoo.la, and compiling
- # (libtool-based) things that link too libfoo.la will complain if
- # libGL.la disappears. So if we do not make up a libGL.la
- # switching between mesa and ati becomes painful.
- local revision=$(printf '%d%02d%02d' $(get_version_components))
- sed -e "s:\${libmajor}:${libmajor}:g" \
- -e "s:\${libminor}:${libminor}:g" \
- -e "s:\${libdir}:$(get_libdir):g" \
- -e "s:\${revision}:${revision}:g" \
- "${FILESDIR}"/libGL.la.in > "${D}"/${ATI_ROOT}/lib/libGL.la \
- || die "sed failed to make libGL.la"
-
- local envname="${T}"/04ati-dri-path
- if [[ -n ${ABI} ]]; then
- envname="${envname}-${ABI}"
- fi
- echo "LIBGL_DRIVERS_PATH=/usr/$(get_libdir)/dri" > "${envname}"
- doenvd "${envname}"
-}
-
-pkg_postinst() {
- /usr/bin/eselect opengl set --use-old ati
-
- elog "To switch to ATI OpenGL, run \"eselect opengl set ati\""
- elog "To change your xorg.conf you can use the bundled \"aticonfig\""
- elog
- elog "If you experience unexplained segmentation faults and kernel crashes"
- elog "with this driver and multi-threaded applications such as wine,"
- elog "set UseFastTLS in xorg.conf to either 0 or 1, but not 2."
- elog
- elog "You will have to source /etc/profile (or logout and back in) for dri"
- elog "to work, unless you previously had ati-drivers installed."
-
- # Workaroud screen corruption
- ewarn "If you experience screen corruption with this driver, try putting"
- ewarn ' Option "XAANoOffscreenPixmaps" "true"'
- ewarn "in the Device Section of /etc/X11/xorg.conf."
-
- linux-mod_pkg_postinst
-}
-
-pkg_prerm() {
- /usr/bin/eselect opengl set xorg-x11
-}
diff --git a/x11-drivers/ati-drivers/files/09ati b/x11-drivers/ati-drivers/files/09ati
deleted file mode 100644
index 27180e0..0000000
--- a/x11-drivers/ati-drivers/files/09ati
+++ /dev/null
@@ -1,3 +0,0 @@
-PATH=/opt/ati/bin
-ROOTPATH=/opt/ati/bin:/opt/ati/sbin
-MANPATH=/opt/ati/man
diff --git a/x11-drivers/ati-drivers/files/ati-drivers-xen.patch b/x11-drivers/ati-drivers/files/ati-drivers-xen.patch
deleted file mode 100644
index a1b88df..0000000
--- a/x11-drivers/ati-drivers/files/ati-drivers-xen.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- common/lib/modules/fglrx/build_mod/firegl_public.c 2008-12-09 15:17:27.000000000 +0000
-+++ common/lib/modules/fglrx/build_mod/firegl_public.c 2008-12-09 15:12:34.000000000 +0000
-@@ -31,6 +31,9 @@
- #include <linux/autoconf.h>
-
- #if !defined(CONFIG_X86_PC)
-+#if !defined(CONFIG_X86_PC_XEN)
-+#if !defined(CONFIG_X86_XEN)
-+#if !defined(CONFIG_X86_64_XEN)
- #if !defined(CONFIG_X86_64)
- #if !defined(CONFIG_X86_VOYAGER)
- #if !defined(CONFIG_X86_NUMAQ)
-@@ -47,6 +50,9 @@
- #endif
- #endif
- #endif
-+#endif
-+#endif
-+#endif
-
- /* The dirty-page-tracking patch included in NLD 9 SMP kernels defines
- * a static inline function that uses a GPL-only symbol in a header
---- common/lib/modules/fglrx/build_mod/firegl_public.h 2008-12-09 15:17:27.000000000 +0000
-+++ common/lib/modules/fglrx/build_mod/firegl_public.h 2008-12-09 15:15:45.000000000 +0000
-@@ -30,9 +30,13 @@
- #endif
-
- #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,9)
--
-+#ifdef CONFIG_XEN
-+#define REMAP_PAGE_RANGE_FN io_remap_pfn_range
-+#define REMAP_PAGE_RANGE_STR "io_remap_pfn_range"
-+#else
- #define REMAP_PAGE_RANGE_FN remap_pfn_range
- #define REMAP_PAGE_RANGE_STR "remap_pfn_range"
-+#endif
- #define REMAP_PAGE_RANGE_OFF(offset) ((offset) >> PAGE_SHIFT)
-
- #else /* LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,9) */
-@@ -43,13 +47,21 @@
-
- #endif /* LINUX_VERSION_CODE > KERNEL_VERSION(2,6,9) */
-
-+#ifdef CONFIG_XEN
-+#define REMAP_PAGE_RANGE(vma,offset) \
-+ REMAP_PAGE_RANGE_FN((vma), \
-+ (vma)->vm_start, \
-+ REMAP_PAGE_RANGE_OFF(offset), \
-+ (vma)->vm_end - (vma)->vm_start, \
-+ (vma)->vm_page_prot)
-+#else
- #define REMAP_PAGE_RANGE(vma,offset) \
- REMAP_PAGE_RANGE_FN(FGL_VMA_API_PASS \
- (vma)->vm_start, \
- REMAP_PAGE_RANGE_OFF(offset), \
- (vma)->vm_end - (vma)->vm_start, \
- (vma)->vm_page_prot)
--
-+#endif
-
- /* Page table macros */
-
diff --git a/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch b/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch
deleted file mode 100644
index f5a35a3..0000000
--- a/x11-drivers/ati-drivers/files/ati-powermode-opt-path-2.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
---- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
-+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
-@@ -4,6 +4,8 @@
- # Control script for ACPI lid state and AC adapter state
- #
-
-+aticonfig='/opt/bin/aticonfig'
-+
- getXuser() {
- user=`finger| grep -m1 ":$displaynum " | awk '{print $1}'`
- if [ x"$user" = x"" ]; then
-@@ -47,7 +49,7 @@
- done
-
- #If PPLIB is enabled
--su $user -c '/usr/bin/aticonfig --pplib-cmd="get version"' | grep PPLIB
-+su $user -c '$aticonfig --pplib-cmd="get version"' | grep PPLIB
- if [ $? = 0 ]; then
- echo "Has PPLIB"
- has_pplib=1
-@@ -61,15 +63,15 @@
- if [ ${lid_closed} -eq 1 -o ${on_dc} -eq 1 ]; then
- echo "Low power"
- if [ ${has_pplib} -eq 1 ]; then
-- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc dc"'
-+ su $user -c '$aticonfig --pplib-cmd="notify psrc dc"'
- else
-- su $user -c "/usr/bin/aticonfig --set-powerstate=1 --effective=now"
-+ su $user -c "$aticonfig --set-powerstate=1"
- fi
- else
- echo "high power"
- if [ ${has_pplib} -eq 1 ]; then
-- su $user -c '/usr/bin/aticonfig --pplib-cmd="notify psrc ac"'
-+ su $user -c '$aticonfig --pplib-cmd="notify psrc ac"'
- else
-- su $user -c "/usr/bin/aticonfig --set-powerstate=3 --effective=now"
-+ su $user -c "$aticonfig --set-powerstate=$($aticonfig --lsp | grep 'default state' | cut -c 3)"
- fi
- fi
-
diff --git a/x11-drivers/ati-drivers/files/ati-powermode.sh.patch b/x11-drivers/ati-drivers/files/ati-powermode.sh.patch
deleted file mode 100644
index cd776e0..0000000
--- a/x11-drivers/ati-drivers/files/ati-powermode.sh.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ur common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
---- common.orig/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-07-28 04:22:36.000000000 +0100
-+++ common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh 2006-08-04 12:19:42.000000000 +0100
-@@ -17,6 +17,10 @@
- fi
- }
-
-+aticonfig='/opt/ati/bin/aticonfig'
-+
-+# default high power state
-+default_state=`$aticonfig --lsp | grep 'default state' | cut -c 3`
-
- grep -q closed /proc/acpi/button/lid/*/state
- if [ $? = 0 ]; then
-@@ -46,7 +50,7 @@
- getXuser;
- if [ x"$XAUTHORITY" != x"" ]; then
- export DISPLAY=":$displaynum"
-- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=1 --effective=now"
-+ su $user -c "$aticonfig --set-powerstate=1 --effective=now"
- fi
- done
- else
-@@ -56,7 +60,7 @@
- getXuser;
- if [ x"$XAUTHORITY" != x"" ]; then
- export DISPLAY=":$displaynum"
-- su $user -c "/usr/X11R6/bin/aticonfig --set-powerstate=3 --effective=now"
-+ su $user -c "$aticonfig --set-powerstate=$default_state --effective=now"
- fi
- done
- fi
diff --git a/x11-drivers/ati-drivers/files/atieventsd.init b/x11-drivers/ati-drivers/files/atieventsd.init
deleted file mode 100644
index 73139ce..0000000
--- a/x11-drivers/ati-drivers/files/atieventsd.init
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/files/atieventsd.init,v 1.3 2007/05/18 23:58:01 marienz Exp $
-
-depend() {
- need acpid
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec /opt/sbin/atieventsd -- ${ATIEVENTSDOPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet --exec /opt/sbin/atieventsd
- eend $?
-} \ No newline at end of file
diff --git a/x11-drivers/ati-drivers/files/atieventsd.rc6 b/x11-drivers/ati-drivers/files/atieventsd.rc6
deleted file mode 100644
index 2180e0e..0000000
--- a/x11-drivers/ati-drivers/files/atieventsd.rc6
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/files/atieventsd.rc6,v 1.2 2006/08/04 12:20:19 chrb Exp $
-
-depend() {
- need acpid
-}
-
-start() {
- start-stop-daemon --start --pidfile /var/run/atieventsd.pid \
- --exec /opt/ati/sbin/atieventsd -- ${ATIEVENTSDOPTS}
- local pid=`pidof atieventsd`
- echo $pid > /var/run/atieventsd.pid
- eend $?
-}
-
-stop() {
- start-stop-daemon --stop --quiet --pidfile /var/run/atieventsd.pid
- eend $?
-}
-
diff --git a/x11-drivers/ati-drivers/files/libGL.la.in b/x11-drivers/ati-drivers/files/libGL.la.in
deleted file mode 100644
index 7fdc409..0000000
--- a/x11-drivers/ati-drivers/files/libGL.la.in
+++ /dev/null
@@ -1,32 +0,0 @@
-# libGL.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname='libGL.so.1'
-
-# Names of this library.
-library_names='libGL.so.${libmajor}.${libminor} libGL.so.${libmajor} libGL.so'
-
-# The name of the static archive.
-old_library=''
-
-# Libraries that this one depends upon.
-dependency_libs='-L/usr/${libdir} -lX11 -lXext -ldl'
-
-# Version information for libGL.
-current=1
-age=0
-revision=${revision}
-
-# Is this an already installed library?
-installed=yes
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='/usr/${libdir}'
diff --git a/x11-drivers/ati-drivers/metadata.xml b/x11-drivers/ati-drivers/metadata.xml
deleted file mode 100644
index 9717d2b..0000000
--- a/x11-drivers/ati-drivers/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>x11-drivers</herd>
- <maintainer>
- <email>lu_zero@gentoo.org</email>
- </maintainer>
- <maintainer>
- <email>je_fro@gentoo.org</email>
- </maintainer>
-</pkgmetadata>