summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
index 3a549dc..34fdf6e 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.8.ebuild
@@ -216,9 +216,9 @@ src_configure() {
# Arches without JIT support also need this to really disable it in all places
use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
- if use webgl; then
- use rpi && append-cppflags $(pkg-config --cflags egl glesv2)
- use rpi && append-ldflags $(pkg-config --libs egl glesv2)
+ if use rpi; then
+ (use egl || use gles2) && append-cppflags $(pkg-config --cflags egl glesv2)
+ (use egl || use gles2) && append-ldflags $(pkg-config --libs egl glesv2)
fi
# It doesn't compile on alpha without this in LDFLAGS, bug #???