summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-06-14 18:47:39 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-06-14 18:47:39 +0000
commitb008da972b929c18b2637e9acb7a5ae32ced6f35 (patch)
treee3d7a3feae818e741e2dc2851e3e3906863ad0d2 /sys-libs
parentCleanup, thanks to vapier for the input (diff)
downloadlu_zero-b008da972b929c18b2637e9acb7a5ae32ced6f35.tar.gz
lu_zero-b008da972b929c18b2637e9acb7a5ae32ced6f35.tar.bz2
lu_zero-b008da972b929c18b2637e9acb7a5ae32ced6f35.zip
Other retouches
svn path=/; revision=8
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/newlib-1.14.0.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/sys-libs/newlib/newlib-1.14.0.ebuild b/sys-libs/newlib/newlib-1.14.0.ebuild
index 30e8af9..98e8e0c 100644
--- a/sys-libs/newlib/newlib-1.14.0.ebuild
+++ b/sys-libs/newlib/newlib-1.14.0.ebuild
@@ -12,7 +12,7 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-# Handle the case where we want uclibc on glibc ...
+# Handle the case where we want newlib on glibc ...
if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
export CTARGET=${CHOST%%-*}-pc-linux-newlib
fi
@@ -71,10 +71,8 @@ src_unpack() {
src_compile() {
local myconf=""
#hardwired to avoid breakages
- case ${CTARGET} in
- *-softfloat-*) myconf="--disable-newlib-hw-fp"
- ;;
- esac
+ [[ ${CTARGET} == *-softfloat-* ]] && myconf="--disable-newlib-hw-fp"
+ [[ ${CTARGET} == *-softfloat-* ]] || myconf="--enable-newlib-hw-fp"
#to the user discretion
myconf="${myconf} `use_enable unicode newlib-mb`"
@@ -98,9 +96,6 @@ src_compile() {
src_install() {
cd ${NEWLIBBUILD}
emake -j1 DESTDIR=${D} install
-}
-
-src_strip() {
-env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
}