summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/xen-sources/xen-sources-2.6.16.49.ebuild')
-rw-r--r--sys-kernel/xen-sources/xen-sources-2.6.16.49.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/xen-sources/xen-sources-2.6.16.49.ebuild b/sys-kernel/xen-sources/xen-sources-2.6.16.49.ebuild
new file mode 100644
index 0000000..8f405d1
--- /dev/null
+++ b/sys-kernel/xen-sources/xen-sources-2.6.16.49.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+UNIPATCH_STRICTORDER="1"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for a dom0/domU Linux kernel to run under Xen"
+HOMEPAGE="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html"
+
+XEN_VERSION="3.0.4_1"
+XEN_BASE_KV="2.6.16.33"
+XEN_PATCH="patch-${XEN_BASE_KV}_to_xen-${XEN_VERSION}.bz2"
+# Change to gentoo mirror when pushed into portage:
+PATCH_URI="http://dev.gentoo.org/~marineam/files/xen/${XEN_PATCH}"
+SRC_URI="${KERNEL_URI} ${PATCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${XEN_PATCH}"
+
+KEYWORDS="~x86 ~amd64"
+
+pkg_postinst() {
+ postinst_sources
+
+ elog "This kernel uses the linux patches released with Xen 3.0.4"
+ elog "It claims to have a 3.0.2 compatibility option but it may not work."
+}