summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2011-02-06 17:26:39 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2011-02-06 17:26:39 +0900
commitaa11d1644928e6e2a02fdca9b7fd9a09f0ea3db6 (patch)
tree1c166a1ab6075d3f5f54bd71f45f45c9f2185e52
parentsys-block/flashcache: Initial import. (diff)
downloadmatsuu-aa11d1644928e6e2a02fdca9b7fd9a09f0ea3db6.tar.gz
matsuu-aa11d1644928e6e2a02fdca9b7fd9a09f0ea3db6.tar.bz2
matsuu-aa11d1644928e6e2a02fdca9b7fd9a09f0ea3db6.zip
app-text/groonga: Version bumped. Added some USE flags.
-rw-r--r--app-text/groonga/Manifest5
-rw-r--r--app-text/groonga/files/groonga.confd8
-rw-r--r--app-text/groonga/files/groonga.initd26
-rw-r--r--app-text/groonga/groonga-1.0.8.ebuild69
-rw-r--r--app-text/groonga/metadata.xml9
5 files changed, 117 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index de2e599..a7f8712 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,2 +1,7 @@
+AUX groonga.confd 188 RMD160 c3e3c2ca122ce45ce819d3b0d104b42269fbe843 SHA1 b5d37152600ada20d56e7299ed924661c32b48cd SHA256 6d174e486acffd1dbb9241328824163ec2a9a1001b8c234133e13b2c5518140f
+AUX groonga.initd 524 RMD160 4e1d30c09afcd6fa3372749281ee39e9c0d20baa SHA1 c48420b8d95183ec0af8019f1e891b1050afbf34 SHA256 6bcf58f77008ef7127b6b561662719c000f9b6b5d49896bce06c9afbfec9b311
DIST groonga-1.0.2.tar.gz 1605491 RMD160 551fd06e6d5a03eddcc21603f2eaca9e51202ea2 SHA1 5a6f081d79fd56d55a42de9275656040875c8baf SHA256 d6a97e491e2076d8ea3411586ab99afc9cc73074cbf223e53617559ec2be3568
+DIST groonga-1.0.8.tar.gz 1755654 RMD160 1d1e2814b154cbd9512a9f88d3c1739039e09c0a SHA1 2e21222f1b0627fad4800531351b7f63e421ca46 SHA256 a0bad7a82489fa11bd1afd3ef248035a3ed25e412ac2fd8a19d1106020662bfe
EBUILD groonga-1.0.2.ebuild 1126 RMD160 7f115651989526379025c4da4891fbcd244f7c26 SHA1 2dfecc0d9049a88bdd4758ceae94ae0899142b12 SHA256 859d2392e4bcb7730a9c044afaf5608983c64fde6327fc827d2182ba674ae374
+EBUILD groonga-1.0.8.ebuild 1832 RMD160 41f0961fba5eac330654801e992aee1c2bcca5ef SHA1 5acd7cbc820ead6c5b9d914cca6c75ec172c862b SHA256 738eb713d8c014dd7075ec6d6faa46738577f62892e9a1633cc345b6d769b448
+MISC metadata.xml 221 RMD160 ca5e46f2e947fcae430e49859acaa4b25ab9d4b4 SHA1 b7f58eb04a9aceeb67104c0b81719e6e97da97f4 SHA256 138123f5d6199cbcc391346419b7b81d3ae9153c17670b18c540ff75a2287371
diff --git a/app-text/groonga/files/groonga.confd b/app-text/groonga/files/groonga.confd
new file mode 100644
index 0000000..7e7ef93
--- /dev/null
+++ b/app-text/groonga/files/groonga.confd
@@ -0,0 +1,8 @@
+# Default
+#USER=groonga
+#GROUP=groonga
+#ADDRESS=127.0.0.1
+#DATABASE=/var/lib/groonga/db/db
+#LOG_PATH=/var/log/groonga/groonga.log
+#QUERY_LOG_PATH=/var/log/groonga/query.log
+#PROTOCOL=gqtp
diff --git a/app-text/groonga/files/groonga.initd b/app-text/groonga/files/groonga.initd
new file mode 100644
index 0000000..87a97bb
--- /dev/null
+++ b/app-text/groonga/files/groonga.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting groonga"
+
+ if [ ! -e /var/run/groonga ] ; then
+ mkdir -p /var/run/groonga
+ chown groonga:groonga /var/run/groonga
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/sbin/groonga -- ${GROONGA_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping groonga"
+ start-stop-daemon --stop --quiet --pidfile /var/spool/groonga/groonga.pid
+ eend $?
+}
diff --git a/app-text/groonga/groonga-1.0.8.ebuild b/app-text/groonga/groonga-1.0.8.ebuild
new file mode 100644
index 0000000..defe92c
--- /dev/null
+++ b/app-text/groonga/groonga-1.0.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://groonga.org/files/groonga/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="abort aio benchmark debug dynamic-malloc-change +exact-alloc-count fmalloc futex libedit libevent lzo mecab msgpack +nfkc ruby sphinx static-libs uyield zeromq zlib"
+
+RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ ruby? ( dev-lang/ruby )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ sphinx? ( dev-python/sphinx )"
+
+pkg_setup() {
+ enewuser groonga || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable abort) \
+ $(use_enable aio) \
+ $(use_enable benchmark) \
+ $(use_enable debug memory-debug) \
+ $(use_enable dynamic-malloc-change) \
+ $(use_enable exact-alloc-count) \
+ $(use_enable fmalloc) \
+ $(use_enable futex) \
+ $(use_enable libedit) \
+ $(use_with libevent) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ $(use_with msgpack message-pack) \
+ $(use_enable nfkc) \
+ $(use_with ruby) \
+ $(use_with sphinx sphinx-build) \
+ $(use_enable static-libs static) \
+ $(use_enable uyield) \
+ $(use_enable zeromq) \
+ $(use_with zlib) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+
+ keepdir /var/{log,spool}/${PN} || die
+ fowners groonga:groonga /var/{log,spool}/${PN} || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
diff --git a/app-text/groonga/metadata.xml b/app-text/groonga/metadata.xml
new file mode 100644
index 0000000..5b14597
--- /dev/null
+++ b/app-text/groonga/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+