summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xscripts/qa.sh26
1 files changed, 15 insertions, 11 deletions
diff --git a/scripts/qa.sh b/scripts/qa.sh
index 6dc23ac..84e048d 100755
--- a/scripts/qa.sh
+++ b/scripts/qa.sh
@@ -22,7 +22,7 @@
# sys-apps/portage
# >=sys-apps/paludis-0.24.6 (with the "qa" USE flag set)
# dev-util/pkgcore-checks
-# www-client/pybugz
+# www-client/pybugz-0.7.0 (0.7.1 is broken, bug 197874)
# app-crypt/gnupg
# dev-util/cvs
@@ -64,8 +64,8 @@ rm -f Manifest
for x in $(find . -type f -name "*.ebuild"); do
echo "Fetching distfiles for $x..."
USE=$(grep -h "IUSE=" *.ebuild | cut -d "=" -f 2 | tr ' ' '\n' | sed "s/[\n\"]//g" | sed "s/\+//g" | sort -u | tr '\n' ' ')
- export USE="${USE} linguas_af linguas_ar linguas_bg linguas_br linguas_bs linguas_ca linguas_cs linguas_cy linguas_da linguas_de linguas_el linguas_en_GB linguas_eo linguas_es linguas_et linguas_eu linguas_fi linguas_fr linguas_ga linguas_he linguas_hi linguas_hu linguas_is linguas_it linguas_ja linguas_ko linguas_lt linguas_lv linguas_mk linguas_ms linguas_nb linguas_nl linguas_nn linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_se linguas_sk linguas_sl linguas_sr linguas_sr@Latn linguas_sv linguas_ta linguas_tg linguas_th linguas_tr linguas_uk linguas_uz linguas_zh_CN linguas_zh_TW"
- RESTRICT="mirror" ebuild $x fetch >/dev/null 2>&1
+ export USE="${USE} $(cat ${GENTOO_PORTAGE_TREE}/profiles/desc/linguas.desc | grep -v '^#' | cut -d ' ' -f1 | sed '/./,$!d' | sed -e 's:^:linguas_:' | sort -u | tr '\n' ' ')"
+ RESTRICT="mirror" ebuild $x fetch >/dev/null 2>&1
# Make sure we *really* got all :-)
RESTRICT="mirror" emerge --nodeps --fetch-all-uri $x >/dev/null 2>&1
/usr/bin/ebuild $x manifest
@@ -74,11 +74,7 @@ unset USE
# Show the KEYWORDS matrix
echo
-if [[ "$2" == ${GENTOO_PORTAGE_TREE} ]] ; then
- adjutrix -k --log-level warning
-else
- echo "adjutrix doesn't work in overlays."
-fi
+adjutrix -k --log-level silent
# I wanted use reprehendo but it requires >=paludis-0.25.0 or paludis-scm and the latter sucks
# reprehendo --sign --key-id ${GPG_KEY}
@@ -89,10 +85,15 @@ cp Manifest.asc Manifest
rm -f Manifest.asc
# See what Qualudis has to say about it...
-if [[ "$2" != ${GENTOO_PORTAGE_TREE} ]] ; then
- qualudis --log-level warning --master-repository-dir ${GENTOO_PORTAGE_TREE}
-else
+#QA_DIR=$(pwd | sed -e "s:$2/::")
+#cd "$2"
+
+if [[ ${2: -10} = ${GENTOO_PORTAGE_TREE: -10} ]] ; then
+# qualudis --log-level warning ${QA_DIR}
qualudis --log-level warning
+elif [[ $2 != ${GENTOO_PORTAGE_TREE} ]] ; then
+# qualudis --log-level warning --master-repository-dir ${GENTOO_PORTAGE_TREE} ${QA_DIR}
+ qualudis --log-level warning --master-repository-dir ${GENTOO_PORTAGE_TREE}
fi
echo
@@ -103,6 +104,9 @@ if [[ $(find "${TMP_DIR}" -type f -amin +1440 -name "glsa_update") != "" ]] ; th
cvs update -d -P >/dev/null 2>&1
fi
+# The following GLSA is broken.
+rm -f "${GLSA_DIR}"/glsa-200710-22.xml
+
# Change back to the original directory we were in.
popd >/dev/null