summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gift/gift-0.1.15b.ebuild')
-rw-r--r--media-gfx/gift/gift-0.1.15b.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/gift/gift-0.1.15b.ebuild b/media-gfx/gift/gift-0.1.15b.ebuild
new file mode 100644
index 0000000..2372fce
--- /dev/null
+++ b/media-gfx/gift/gift-0.1.15b.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION="The GNU Image-Finding Tool"
+HOMEPAGE="http://www.gnu.org/software/gift/"
+SRC_URI="http://alpha.gnu.org/gnu/gift/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-gfx/imagemagick
+ dev-perl/XML-DOM
+ dev-perl/XML-XQL
+ dev-perl/Text-Iconv"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+GIFT_USER="gift"
+GIFT_HOME="/home/${GIFT_USER}/"
+GIFT_INIT="gnu-gift"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use doc || epatch ${FILESDIR}/${PN}-0.1.14-noDoc.patch
+ epatch ${FILESDIR}/${PN}-0.1.14-ps_params.patch
+# epatch ${FILESDIR}/${PN}-0.1.14-patch-tid.patch
+ epatch ${FILESDIR}/${PN}-0.1.14-extra_qualif.patch
+}
+
+src_compile() {
+
+ eautoreconf
+
+# econf --enable-multithreading \
+# --enable-bayesian \
+# --datadir=/usr/share/${PN} \
+# --includedir=/usr/include/${PN} || die "econf failed"
+
+ econf --enable-multi-threading \
+ --enable-bayesian || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc README NEWS AUTHORS
+
+ newconfd ${FILESDIR}/${PN}.confd ${GIFT_INIT}
+ newinitd ${FILESDIR}/${PN}.initd ${GIFT_INIT}
+
+ enewuser ${GIFT_USER} -1 /bin/bash ${GIFT_HOME} users
+}