summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 19:40:30 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 19:40:30 +0000
commit0e991e34acdd92cc6a7ab20a2921d63b2265f16d (patch)
treeef8ef3291e0f82f31924bb48f92e033c7dd22e18 /hardened
parentWorkaround for now, solving compile issues on AMD64/hardened. (diff)
downloadphreak-0e991e34acdd92cc6a7ab20a2921d63b2265f16d.tar.gz
phreak-0e991e34acdd92cc6a7ab20a2921d63b2265f16d.tar.bz2
phreak-0e991e34acdd92cc6a7ab20a2921d63b2265f16d.zip
Final touchups for AMD64/hardened.
svn path=/; revision=323
Diffstat (limited to 'hardened')
-rw-r--r--hardened/dev-lang/ocaml/Manifest8
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild9
2 files changed, 9 insertions, 8 deletions
diff --git a/hardened/dev-lang/ocaml/Manifest b/hardened/dev-lang/ocaml/Manifest
index a03d760..5b0aa6f 100644
--- a/hardened/dev-lang/ocaml/Manifest
+++ b/hardened/dev-lang/ocaml/Manifest
@@ -19,10 +19,10 @@ MD5 bcc5109143faee7e7b8f7f76bd4726a7 files/ocaml-rebuild.sh 1361
RMD160 a9c452fbea18de3b38d8240f887f8595e529643e files/ocaml-rebuild.sh 1361
SHA256 a8004cd4bca96ab3fc595fcfd7dbe88903833f9e430149c3d04c9fda84362b64 files/ocaml-rebuild.sh 1361
DIST ocaml-3.09.3.tar.bz2 2038617 RMD160 fdc124218c556c62c897ee6720970279e2d5426b SHA1 5d63c6e0d13463f85c0d5147d641d2bceef87d6b SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f
-EBUILD ocaml-3.09.3-r1.ebuild 4515 RMD160 7bdd9c69ee9601e8ef74dab79f27a32010afa5f8 SHA1 57ad3eead0f40ce0c4d1c9128291d0d826e9d89b SHA256 52ee773b6983b52be8c0db7a6ce48f48efb226e1941c435b124ad503b254d326
-MD5 db9ba7c43a5adc4fd82a7bdb37585a5e ocaml-3.09.3-r1.ebuild 4515
-RMD160 7bdd9c69ee9601e8ef74dab79f27a32010afa5f8 ocaml-3.09.3-r1.ebuild 4515
-SHA256 52ee773b6983b52be8c0db7a6ce48f48efb226e1941c435b124ad503b254d326 ocaml-3.09.3-r1.ebuild 4515
+EBUILD ocaml-3.09.3-r1.ebuild 4609 RMD160 bd5e978b9ab20d7c445787115494f41c07bccad1 SHA1 2645d14bb03fcec5f2fdc90faf88d16ad35eecc3 SHA256 2ff3b317570a532cf372b858e12fd38777a3bc8dd0cdec7cf3f46fc5ef5c0864
+MD5 88f3a6875bd3e46653f4d6f1cff410a0 ocaml-3.09.3-r1.ebuild 4609
+RMD160 bd5e978b9ab20d7c445787115494f41c07bccad1 ocaml-3.09.3-r1.ebuild 4609
+SHA256 2ff3b317570a532cf372b858e12fd38777a3bc8dd0cdec7cf3f46fc5ef5c0864 ocaml-3.09.3-r1.ebuild 4609
MD5 71f3dc5bc2ee57a403689b56bc1a85c1 files/digest-ocaml-3.09.3-r1 244
RMD160 e7f0898889b94faae3b1481555bac42e9298b370 files/digest-ocaml-3.09.3-r1 244
SHA256 19708f759185ed39623e03921462ba20fb6f3533268673d2bcd7dd07cef57350 files/digest-ocaml-3.09.3-r1 244
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index a71e735..a14a779 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -25,9 +25,9 @@ pkg_setup() {
# dev-lang/ocaml fails with -fPIC errors due to a "relocation R_X86_64_32S" on AMD64/hardened
if use amd64 && gcc-specs-pie ; then
echo
- eerror "${PN} is currently broken on this platform with specfiles injecting -PIE."
- eerror "Please switch to your ${CHOST}-$(gcc-fullversion)-hardenednopie specfile via gcc-config!"
- die "Current gcc spec not supported by ${PF}!"
+ eerror "${CAT}/${PF} is currently broken on this platform with specfiles injecting -PIE."
+ eerror "Please switch to your \"${CHOST}-$(gcc-fullversion)-hardenednopie\" specfile via gcc-config!"
+ die "Current specfile (${CHOST}-$(gcc-fullversion)) not supported by ${PF}!"
fi
}
@@ -124,7 +124,8 @@ src_install() {
pkg_postinst() {
if use amd64 && gcc-specs-ssp ; then
echo
- ewarn "Make sure, you switch back to the default specfile!"
+ ewarn "Make sure, you switch back to the default specfile"
+ ewarn "${CHOST}-$(gcc-fullversion) via gcc-config!"
echo
fi