summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/kernel-check/kernel-check-0.3.17.ebuild')
-rw-r--r--app-admin/kernel-check/kernel-check-0.3.17.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/kernel-check/kernel-check-0.3.17.ebuild b/app-admin/kernel-check/kernel-check-0.3.17.ebuild
new file mode 100644
index 0000000..b87a4b7
--- /dev/null
+++ b/app-admin/kernel-check/kernel-check-0.3.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Gentoo Kernel Security"
+HOMEPAGE="http://dev.gentoo.org/~asym/guide.xml"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/kernel-check.git"
+ inherit git
+ KEYWORDS=""
+else
+ SRC_URI="http://dev.gentoo.org/~asym/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="extras"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="TODO"
+
+src_unpack() {
+ unpack ${A}
+ if use extras; then
+ epatch "${FILESDIR}/${PN}-extras.patch"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+}