summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/kernel-check/kernel-check-0.3.17.ebuild')
-rw-r--r--app-admin/kernel-check/kernel-check-0.3.17.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-admin/kernel-check/kernel-check-0.3.17.ebuild b/app-admin/kernel-check/kernel-check-0.3.17.ebuild
index b87a4b7..711b056 100644
--- a/app-admin/kernel-check/kernel-check-0.3.17.ebuild
+++ b/app-admin/kernel-check/kernel-check-0.3.17.ebuild
@@ -2,18 +2,20 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit distutils
DESCRIPTION="Gentoo Kernel Security"
HOMEPAGE="http://dev.gentoo.org/~asym/guide.xml"
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/kernel-check.git"
inherit git
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/kernel-check.git"
KEYWORDS=""
else
SRC_URI="http://dev.gentoo.org/~asym/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 x86"
fi
LICENSE="LGPL-2.1"
@@ -26,7 +28,14 @@ RDEPEND=""
DOCS="TODO"
src_unpack() {
- unpack ${A}
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
if use extras; then
epatch "${FILESDIR}/${PN}-extras.patch"
fi