summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-10-28 10:10:14 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-10-28 10:10:14 +0000
commit1e3895065d1342d27aadd9d1f31f4957f262ba58 (patch)
tree3e9f26a7e37a40d6aac7f5ca4df864c0ce96a13e
parentAdd libcanberra (diff)
downloadsuka-1e3895065d1342d27aadd9d1f31f4957f262ba58.tar.gz
suka-1e3895065d1342d27aadd9d1f31f4957f262ba58.tar.bz2
suka-1e3895065d1342d27aadd9d1f31f4957f262ba58.zip
add gnome-desktop-3, needed for gnome-shell
svn path=/; revision=286
-rw-r--r--gnome-base/gnome-desktop/Manifest2
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-2.91.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/gnome-desktop/Manifest b/gnome-base/gnome-desktop/Manifest
new file mode 100644
index 0000000..2781a88
--- /dev/null
+++ b/gnome-base/gnome-desktop/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-desktop-2.91.0.tar.bz2 1375768 RMD160 061f68670c7611358a863f1c172c73a921a99a6b SHA1 67dfad07430bcc88994af7016c7598a326695cb0 SHA256 e98d9469f0dec12952b392852a461643036cda4c5a831f1c89c0d5a0aaac0070
+EBUILD gnome-desktop-2.91.0.ebuild 1677 RMD160 35cc2150afe29736fc0b27ad442e898d6a100beb SHA1 4d73827d03780ae44563b010a90233c0178ea642 SHA256 883ddcd105e54124c6423842cafcc7eb53e70547b872cdcaac6c7e9ef13072ec
diff --git a/gnome-base/gnome-desktop/gnome-desktop-2.91.0.ebuild b/gnome-base/gnome-desktop/gnome-desktop-2.91.0.ebuild
new file mode 100644
index 0000000..8645d26
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-2.91.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit gnome2 autotools eutils
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+# TODO: Add RDEPEND on pciutils (requires support for reading gzipped pnp.ids)
+RDEPEND=">=x11-libs/gtk+-2.91.0:3
+ >=dev-libs/glib-2.19.1
+ >=x11-libs/libXrandr-1.2
+ >=gnome-base/gconf-2
+ >=x11-libs/gdk-pixbuf-2.21.3
+ >=x11-libs/startup-notification-0.5
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-proto/xproto
+ >=x11-proto/randrproto-1.2"
+# Temporarily require the 2.31 version to ensure the proper pixmaps, gnome-about,
+# etc. are installed. Switch to doing things the other way around once
+# gnome-about no longer uses pygtk 2
+PDEPEND=">=gnome-base/gnome-desktop-2.31:0"
+
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
+# Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
+# eventually libXrandr shouldn't RDEPEND on randrproto)
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gnome-distributor=Gentoo
+ --disable-scrollkeeper
+ --disable-static
+ --disable-gnome-about
+ --disable-desktop-docs
+ --with-pnp-ids-path=/usr/share/libgnome-desktop/pnp.ids"
+}
+