summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-10-28 11:41:05 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-10-28 11:41:05 +0000
commit620318dcd6cbb6876228cb77f2efd7908ebc0069 (patch)
tree37314b0c46664792f35caaf82ffd37a534f79330
parentmask another live ebuild (diff)
downloadsuka-620318dcd6cbb6876228cb77f2efd7908ebc0069.tar.gz
suka-620318dcd6cbb6876228cb77f2efd7908ebc0069.tar.bz2
suka-620318dcd6cbb6876228cb77f2efd7908ebc0069.zip
clutter
svn path=/; revision=294
-rw-r--r--media-libs/clutter/Manifest2
-rw-r--r--media-libs/clutter/clutter-1.5.4.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
new file mode 100644
index 0000000..2410673
--- /dev/null
+++ b/media-libs/clutter/Manifest
@@ -0,0 +1,2 @@
+DIST clutter-1.5.4.tar.bz2 4520746 RMD160 6b64a4dcddc4aad74dd701259689b6a08e7f87e6 SHA1 0c8ddb1af666caff5b8d0f40e216250f26e89b11 SHA256 6134d534184724648ee7aa5eba5ea7b35994185eee579bf136460a88e341bd02
+EBUILD clutter-1.5.4.ebuild 1985 RMD160 554a7a7df1879844a95d7f82e0254386d6efaecb SHA1 66d158178e49aaa73f6c3c9cd7387c3e16f094c6 SHA256 ee6faf5357fdf71e95401b2dc55c35c2e09b1e82916d8e51d1db9863df159366
diff --git a/media-libs/clutter/clutter-1.5.4.ebuild b/media-libs/clutter/clutter-1.5.4.ebuild
new file mode 100644
index 0000000..793c0e0
--- /dev/null
+++ b/media-libs/clutter/clutter-1.5.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit clutter
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug doc +gtk +introspection"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/cairo-1.4
+ >=x11-libs/pango-1.20[introspection?]
+ >=dev-libs/json-glib-0.10[introspection?]
+ >=dev-libs/atk-1.7
+
+ virtual/opengl
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-libs/libXi
+ x11-proto/inputproto
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXcomposite-0.4
+
+ gtk? ( || (
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-2.0 ) )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/gtk-doc-am-1.13
+ doc? (
+ >=dev-util/gtk-doc-1.13
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+"
+
+src_configure() {
+ # We only need conformance tests, the rest are useless for us
+# sed -e 's/^\(SUBDIRS =\).*/\1/g' \
+# -i tests/Makefile.{am,in} || die "tests sed failed"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What do we do about eglx/eglnative/opengl-egl-xlib/osx/etc flavours?
+ local myconf="
+ --enable-debug=minimum
+ --enable-cogl-debug=minimum
+ --enable-conformance=no
+ --disable-gcov
+ --enable-profile=no
+ --enable-maintainer-flags=no
+ --enable-xinput
+ --with-flavour=glx
+ --with-imagebackend=gdk-pixbuf
+ $(use_enable introspection)
+ $(use_enable doc docs)"
+
+ if ! use gtk; then
+ myconf="${myconf} --with-imagebackend=internal"
+ # Internal image backend is experimental
+ ewarn "You have selected the experimental internal image backend"
+ fi
+
+ if use debug; then
+ myconf="${myconf}
+ --enable-debug=yes
+ --enable-cogl-debug=yes"
+ fi
+
+ touch ${S}/TODO
+
+ econf ${myconf}
+}