summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2007-07-23 12:14:36 +0000
committerAndreas Proschofsky <suka@gentoo.org>2007-07-23 12:14:36 +0000
commit7eab3b3fb4d82cf2fa107c61325034a9ccdf2168 (patch)
tree4c931b7dc5c7babc98cc3abe6bdebf4facff34e4
parentInitial commit, starting with my own giver ebuilds (diff)
downloadsuka-7eab3b3fb4d82cf2fa107c61325034a9ccdf2168.tar.gz
suka-7eab3b3fb4d82cf2fa107c61325034a9ccdf2168.tar.bz2
suka-7eab3b3fb4d82cf2fa107c61325034a9ccdf2168.zip
Add conduit and evolution-python (for more dataproviders)
svn path=/; revision=2
-rw-r--r--app-admin/conduit/conduit-0.3.2.ebuild41
-rw-r--r--dev-python/evolution-python/evolution-python-0.0.2.ebuild36
2 files changed, 77 insertions, 0 deletions
diff --git a/app-admin/conduit/conduit-0.3.2.ebuild b/app-admin/conduit/conduit-0.3.2.ebuild
new file mode 100644
index 0000000..f6906c5
--- /dev/null
+++ b/app-admin/conduit/conduit-0.3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2 python multilib
+
+DESCRIPTION="A Desktop Synchronization Solution for GNOME"
+HOMEPAGE="http://www.conduit-project.org/"
+SRC_URI="http://files.conduit-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND=">=virtual/python-2.4
+ >=x11-libs/gtk+-2.10
+ >=sys-apps/dbus-0.93
+ >=dev-python/pygtk-2.10
+ dev-python/pyxml
+ dev-python/vobject
+ dev-python/dbus-python
+ dev-python/pygoocanvas
+ dev-python/gnome-python
+ dev-python/python-dateutil
+ dev-python/elementtree
+ python? ( dev-python/evolution-python )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/conduit
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
diff --git a/dev-python/evolution-python/evolution-python-0.0.2.ebuild b/dev-python/evolution-python/evolution-python-0.0.2.ebuild
new file mode 100644
index 0000000..d0a5810
--- /dev/null
+++ b/dev-python/evolution-python/evolution-python-0.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="Evolution-python is a library to add python support to evolution-data-server"
+HOMEPAGE="http://pygtk.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+SRC_URI="http://files.conduit-project.org/releases/${P}.tar.gz"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.4
+ >=dev-python/pygobject-2.6
+ >=x11-libs/gtk+-2.6.0
+ x11-libs/pango
+ >=gnome-extra/evolution-data-server-1.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}