summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2007-08-05 14:34:57 +0000
committerAndreas Proschofsky <suka@gentoo.org>2007-08-05 14:34:57 +0000
commit25244420aeedbda737d502354f0c35f2da148029 (patch)
tree3d0ca93cb073e9ce45a24f9b571b715faa04f332 /app-misc/giver/giver-0.1.8.ebuild
parentAdd Tomboy 0.7.3, as this adds the synchronization stuff, which allows easy n... (diff)
downloadsuka-25244420aeedbda737d502354f0c35f2da148029.tar.gz
suka-25244420aeedbda737d502354f0c35f2da148029.tar.bz2
suka-25244420aeedbda737d502354f0c35f2da148029.zip
Bump to newer giver release
svn path=/; revision=13
Diffstat (limited to 'app-misc/giver/giver-0.1.8.ebuild')
-rw-r--r--app-misc/giver/giver-0.1.8.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/giver/giver-0.1.8.ebuild b/app-misc/giver/giver-0.1.8.ebuild
new file mode 100644
index 0000000..bc57ea7
--- /dev/null
+++ b/app-misc/giver/giver-0.1.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2000-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils gnome2 mono
+
+DESCRIPTION="Makes giving files to others very simple"
+HOMEPAGE="http://code.google.com/p/giver"
+SRC_URI="http://giver.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/gnome-sharp-2
+ >=dev-dotnet/notify-sharp-0.4.0
+ >=net-dns/avahi-0.6.10"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+
+ if ! built_with_use net-dns/avahi mono; then
+ eerror "We need avahi-sharp"
+ eerror "Please recompile net-dns/avahi with USE=\"mono\""
+ die
+ fi
+
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${PN}-username_face2.patch
+
+ gnome2_omf_fix
+}
+
+pkg_postinst() {
+
+ elog " To get this working avahi must be started, do this by issueing:"
+ elog
+ elog " $ /etc/init.d/avahi-daemon start"
+ elog
+ elog " Or you might just add it to the default runlevel for constant use:"
+ elog
+ elog " $ rc-update add avahi-daemon default"
+
+}
+