summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-02-28 11:29:26 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-02-28 11:29:26 +0000
commitef34c06320a1f24c9f5a54704ed36ebc95e3f556 (patch)
tree186adf4dd22df5f5c7e2072f96e779a9a7a2bf2d /app-misc/gourmet/gourmet-0.13.4-r2.ebuild
parentAdd an initial ebuild for tasky, simple task management for the GNOME desktop (diff)
downloadsuka-ef34c06320a1f24c9f5a54704ed36ebc95e3f556.tar.gz
suka-ef34c06320a1f24c9f5a54704ed36ebc95e3f556.tar.bz2
suka-ef34c06320a1f24c9f5a54704ed36ebc95e3f556.zip
Add gourmet-recipe-manager
svn path=/; revision=57
Diffstat (limited to 'app-misc/gourmet/gourmet-0.13.4-r2.ebuild')
-rw-r--r--app-misc/gourmet/gourmet-0.13.4-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/gourmet/gourmet-0.13.4-r2.ebuild b/app-misc/gourmet/gourmet-0.13.4-r2.ebuild
new file mode 100644
index 0000000..e585216
--- /dev/null
+++ b/app-misc/gourmet/gourmet-0.13.4-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils distutils
+
+DESCRIPTION="Simple but powerful recipe-managing application"
+HOMEPAGE="http://grecipe-manager.sourceforge.net/"
+MY_P="${P}-2"
+SRC_URI="mirror://sourceforge/grecipe-manager/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/python-2.3
+ >=dev-python/pygtk-2.3.93
+ =dev-python/gnome-python-2*
+ =gnome-base/libglade-2*
+ >=dev-python/pysqlite-2.0
+ dev-python/imaging
+ dev-python/gnome-python-extras
+ dev-python/pyrtf
+ dev-python/reportlab
+ dev-db/metakit"
+
+DOCS="README TODO PKG-INFO CHANGES"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+pkg_setup() {
+ if ! built_with_use 'dev-db/metakit' python ; then
+ eerror "You need to install metakit with python support. Try:"
+ eerror "USE='python' emerge metakit"
+ die "python support missing from metakit"
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to be compiled."
+}
+
+src_install() {
+ distutils_src_install --disable-modules-check
+
+ for doc in ${DOCS}; do
+ [ -s "$doc" ] && dodoc $doc
+ done
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/dosage
+ einfo "Please consult the README file included."
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
+