summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-08-04 20:04:08 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-08-04 20:04:08 +0000
commitefb07819331a6c9dfc0f8e83b1efdb1a91996e6a (patch)
tree82d2420a5332991fae69631c0fefeb9bd774e49a /app-text/pdfmod/pdfmod-0.4.ebuild
parentAdding fpm2, nice (and maintained) GTK+ password manager with few (diff)
downloadsuka-efb07819331a6c9dfc0f8e83b1efdb1a91996e6a.tar.gz
suka-efb07819331a6c9dfc0f8e83b1efdb1a91996e6a.tar.bz2
suka-efb07819331a6c9dfc0f8e83b1efdb1a91996e6a.zip
Add pdfmod, nice little tool to manipulate PDFs
svn path=/; revision=135
Diffstat (limited to 'app-text/pdfmod/pdfmod-0.4.ebuild')
-rw-r--r--app-text/pdfmod/pdfmod-0.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pdfmod/pdfmod-0.4.ebuild b/app-text/pdfmod/pdfmod-0.4.ebuild
new file mode 100644
index 0000000..077f9ba
--- /dev/null
+++ b/app-text/pdfmod/pdfmod-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit gnome2 mono
+
+DESCRIPTION="A simple tool for modifying PDF documents"
+HOMEPAGE="http://live.gnome.org/PdfMod"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2
+ >=dev-dotnet/gtk-sharp-2.0
+ >=dev-dotnet/gnome-sharp-2.0
+ app-text/gnome-doc-utils
+ >=virtual/poppler-0.8.0"
+
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+
+ # icon-theme-installer missing in the tarball
+ cp -f "${FILESDIR}/icon-theme-installer" "${S}" || die
+ chmod +rx "${S}/icon-theme-installer"
+
+ # Fails with more than one process
+ MAKEOPTS="-j1"
+
+}
+