summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-06-06 08:32:13 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-06-06 08:32:13 +0000
commit5eb48a196886c7312289bf720beb7874ffe8389e (patch)
tree9c802174fb14ad4498d5c13663892f027eec9198 /gnome-base/gnome-session
parentFirst bunch of GNOME 3.5.2 stuff (diff)
downloadsuka-5eb48a196886c7312289bf720beb7874ffe8389e.tar.gz
suka-5eb48a196886c7312289bf720beb7874ffe8389e.tar.bz2
suka-5eb48a196886c7312289bf720beb7874ffe8389e.zip
Another bunch of GNOME 3.5.2 updates
svn path=/; revision=338
Diffstat (limited to 'gnome-base/gnome-session')
-rw-r--r--gnome-base/gnome-session/Manifest6
-rwxr-xr-xgnome-base/gnome-session/files/10-user-dirs-update-gnome-r110
-rw-r--r--gnome-base/gnome-session/files/15-xdg-data-gnome-r19
-rw-r--r--gnome-base/gnome-session/files/Gnome109
-rw-r--r--gnome-base/gnome-session/files/defaults.list336
-rw-r--r--gnome-base/gnome-session/gnome-session-3.5.2.ebuild103
6 files changed, 573 insertions, 0 deletions
diff --git a/gnome-base/gnome-session/Manifest b/gnome-base/gnome-session/Manifest
new file mode 100644
index 0000000..aae1902
--- /dev/null
+++ b/gnome-base/gnome-session/Manifest
@@ -0,0 +1,6 @@
+AUX 10-user-dirs-update-gnome-r1 299 RMD160 c76707fdce421431884beeabd60d5f0ce7716d26 SHA1 6adf982b43d2eeaa86622ecfd6b5f70eb772a9c2 SHA256 4baf3771a18f87db323580d868f232bf33830f72dcc54b4b3aa3d9bc9cce05e5
+AUX 15-xdg-data-gnome-r1 262 RMD160 6305f879183ecafae77d4cfd7bf035d44d801924 SHA1 99c5eb8187a608ab0b8cffe68eedb10e73dc1968 SHA256 860767c9ee4fc9e0d29c20cd8143311db7d0981ed4f590069d0d9edf46ec0b24
+AUX Gnome 2391 RMD160 dee0875327352ae70f71b73257deb8ccc5bbc3ba SHA1 9d6f5c7c4f7aee36ea64b30c57b9cb9818664c42 SHA256 ffc912945278c88ef854c8988b0042675ffa78525592f34580ee76c1f25309d3
+AUX defaults.list 14665 RMD160 4911cb92c2b4fb6a2cf0df760a6b8b69edb7633d SHA1 1954df452a625450cb3059f86774da83f02f40e7 SHA256 34af159eee20aa4f169fa0e368be33117d828b2db6daab7dc4826d9330719b21
+DIST gnome-session-3.5.2.tar.xz 717776 RMD160 758394e93aedfa41d5c1e05666d4bdbaadf4fbc0 SHA1 337051ba10dc8f21ca31aa97e4590dbdcd4895d2 SHA256 a6444668c9f6772232fcf31ba4bc18b8f2f37b80924b77bd486fb0630ff0184f
+EBUILD gnome-session-3.5.2.ebuild 3064 RMD160 7e0887ce12021240a89a60540be2240e85a315fb SHA1 7c22cdc9cab3a85be2ae9738ad8848255c199ed8 SHA256 c4abe9f9cd9505f24cae85cda70825042730b2637d8e270388b2233888ad2554
diff --git a/gnome-base/gnome-session/files/10-user-dirs-update-gnome-r1 b/gnome-base/gnome-session/files/10-user-dirs-update-gnome-r1
new file mode 100755
index 0000000..61fd08c
--- /dev/null
+++ b/gnome-base/gnome-session/files/10-user-dirs-update-gnome-r1
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# Create various XDG directories, and write ~/.config/user-dirs.dirs, etc.
+# That file is read by glib to get XDG_PICTURES_DIR, etc
+
+if [ "$DESKTOP_SESSION" = "gnome" -o "$DESKTOP_SESSION" = "cinnamon" ]; then
+ if type xdg-user-dirs-update &>/dev/null; then
+ xdg-user-dirs-update
+ fi
+fi
diff --git a/gnome-base/gnome-session/files/15-xdg-data-gnome-r1 b/gnome-base/gnome-session/files/15-xdg-data-gnome-r1
new file mode 100644
index 0000000..5eaa698
--- /dev/null
+++ b/gnome-base/gnome-session/files/15-xdg-data-gnome-r1
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$DESKTOP_SESSION" = "gnome" -o "$DESKTOP_SESSION" = "cinnamon" ]; then
+ if [ -z "$XDG_DATA_DIRS" ]; then
+ export XDG_DATA_DIRS=/usr/share/gnome:/usr/local/share/:/usr/share/
+ else
+ export XDG_DATA_DIRS=/usr/share/gnome:"$XDG_DATA_DIRS"
+ fi
+fi
diff --git a/gnome-base/gnome-session/files/Gnome b/gnome-base/gnome-session/files/Gnome
new file mode 100644
index 0000000..55d39b6
--- /dev/null
+++ b/gnome-base/gnome-session/files/Gnome
@@ -0,0 +1,109 @@
+#!/bin/sh
+#
+# This file has bitrotted badly. Someone needs to clean this up.
+#
+
+if [ -f /etc/xdg/menus/gnome-applications.menu ] ; then
+ export XDG_MENU_PREFIX=gnome-
+fi
+
+for errfile in "$HOME/.gnomerc-errors" "${TMPDIR-/tmp}/gnomerc-$USER" "/tmp/gnomerc-$USER"
+do
+ if ( cp /dev/null "$errfile" 2> /dev/null )
+ then
+ chmod 600 "$errfile"
+ exec > "$errfile" 2>&1
+ break
+ fi
+done
+#
+# Distributors:
+# You should modify the paths here to fit your distro
+# If you need to do so, send me (jirka@5z.com) a patch
+# and I'll try to make the script detect the distro stuff
+#
+
+userresources=$HOME/.Xresources
+usermodmap=$HOME/.Xmodmap
+userxkbmap=$HOME/.Xkbmap
+
+sysresources=/etc/X11/Xresources
+sysmodmap=/etc/X11/Xmodmap
+sysxkbmap=/etc/X11/Xkbmap
+
+rh6sysresources=/etc/X11/xinit/Xresources
+rh6sysmodmap=/etc/X11/xinit/Xmodmap
+
+if [ -x "$HOME/.gnomerc" ]; then
+ command="$HOME/.gnomerc"
+elif [ -x /etc/X11/gdm/gnomerc ]; then
+ command="/etc/X11/gdm/gnomerc"
+else
+ # as fallback in case the config is screwed
+ command=`which gnome-session`
+fi
+
+# merge in defaults
+if [ -f "$rh6sysresources" ]; then
+ xrdb -merge "$rh6sysresources"
+fi
+
+if [ -f "$sysresources" ]; then
+ xrdb -merge "$sysresources"
+fi
+
+if [ -f "$userresources" ]; then
+ xrdb -merge "$userresources"
+fi
+
+# merge in keymaps
+if [ -f "$sysxkbmap" ]; then
+ setxkbmap `cat "$sysxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+if [ -f "$userxkbmap" ]; then
+ setxkbmap `cat "$userxkbmap"`
+ XKB_IN_USE=yes
+fi
+
+#
+# Eeek, this seems like too much magic here
+#
+if [ -z "$XKB_IN_USE" ] && [ ! -L /etc/X11/X ]; then
+ if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
+ xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
+ if [ -n "$xkbsymbols" ]; then
+ setxkbmap -symbols "$xkbsymbols"
+ XKB_IN_USE=yes
+ fi
+ fi
+fi
+
+# xkb and xmodmap don't play nice together
+if [ -z "$XKB_IN_USE" ]; then
+ if [ -f "$rh6sysmodmap" ]; then
+ xmodmap "$rh6sysmodmap"
+ fi
+
+ if [ -f "$sysmodmap" ]; then
+ xmodmap "$sysmodmap"
+ fi
+
+ if [ -f "$usermodmap" ]; then
+ xmodmap "$usermodmap"
+ fi
+fi
+
+unset XKB_IN_USE
+
+# run all system xinitrc shell scripts.
+if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ for i in /etc/X11/xinit/xinitrc.d/* ; do
+ if [ -x "$i" ]; then
+ . "$i"
+ fi
+ done
+fi
+
+exec $command
diff --git a/gnome-base/gnome-session/files/defaults.list b/gnome-base/gnome-session/files/defaults.list
new file mode 100644
index 0000000..bac841c
--- /dev/null
+++ b/gnome-base/gnome-session/files/defaults.list
@@ -0,0 +1,336 @@
+[Default Applications]
+application/rtf=abiword.desktop
+application/x-abiword=abiword.desktop
+text/abiword=abiword.desktop
+text/richtext=abiword.desktop
+text/rtf=abiword.desktop
+text/x-abiword=abiword.desktop
+text/x-xml-abiword=abiword.desktop
+x-content/blank-bd=brasero-nautilus.desktop
+x-content/blank-dvd=brasero-nautilus.desktop
+x-content/blank-cd=brasero-nautilus.desktop
+x-content/blank-hddvd=brasero-nautilus.desktop
+application/x-dia-diagram=dia.desktop
+image/bmp=eog.desktop
+image/gif=eog.desktop
+image/jpeg=eog.desktop
+image/jpg=eog.desktop
+image/pjpeg=eog.desktop
+image/png=eog.desktop
+image/svg+xml=eog.desktop
+image/svg+xml-compressed=eog.desktop
+image/x-bmp=eog.desktop
+image/x-gray=eog.desktop
+image/x-icb=eog.desktop
+image/x-ico=eog.desktop
+image/x-pcx=eog.desktop
+image/x-png=eog.desktop
+image/x-portable-anymap=eog.desktop
+image/x-portable-bitmap=eog.desktop
+image/x-portable-graymap=eog.desktop
+image/x-portable-pixmap=eog.desktop
+image/x-xbitmap=eog.desktop
+image/x-xpixmap=eog.desktop
+image/vnd.wap.wbmp=eog.desktop
+image/g3fax=gimp.desktop
+image/x-compressed-xcf=gimp.desktop
+image/x-fits=gimp.desktop
+image/x-icon=gimp.desktop
+image/x-psd=gimp.desktop
+image/x-sgi=gimp.desktop
+image/x-sun-raster=gimp.desktop
+image/x-tga=gimp.desktop
+image/x-xcf=gimp.desktop
+image/x-xwindowdump=gimp.desktop
+application/xhtml+xml=firefox.desktop;firefox-3.6.desktop;epiphany.desktop
+text/html=firefox.desktop;firefox-3.6.desktop;epiphany.desktop
+application/pdf=evince.desktop
+application/x-bzpdf=evince.desktop
+application/x-gzpdf=evince.desktop
+application/postscript=evince.desktop
+application/x-bzpostscript=evince.desktop
+application/x-gzpostscript=evince.desktop
+image/x-eps=evince.desktop
+image/x-bzeps=evince.desktop
+image/x-gzeps=evince.desktop
+application/x-dvi=evince.desktop
+application/x-bzdvi=evince.desktop
+application/x-gzdvi=evince.desktop
+image/vnd.djvu=evince.desktop
+image/tiff=evince.desktop
+application/x-cbr=evince.desktop
+application/x-cbz=evince.desktop
+application/x-cb7=evince.desktop
+application/x-7z-compressed=file-roller.desktop
+application/x-7z-compressed-tar=file-roller.desktop
+application/x-ace=file-roller.desktop
+application/x-alz=file-roller.desktop
+application/x-ar=file-roller.desktop
+application/x-arj=file-roller.desktop
+application/x-bzip=file-roller.desktop
+application/x-bzip-compressed-tar=file-roller.desktop
+application/x-bzip1=file-roller.desktop
+application/x-bzip1-compressed-tar=file-roller.desktop
+application/x-cabinet=file-roller.desktop
+application/x-cd-image=file-roller.desktop
+application/x-compress=file-roller.desktop
+application/x-compressed-tar=file-roller.desktop
+application/x-cpio=file-roller.desktop
+application/x-deb=file-roller.desktop
+application/x-ear=file-roller.desktop
+application/x-gtar=file-roller.desktop
+application/x-gzip=file-roller.desktop
+application/x-java-archive=file-roller.desktop
+application/x-lha=file-roller.desktop
+application/x-lhz=file-roller.desktop
+application/x-lzip=file-roller.desktop
+application/x-lzip-compressed-tar=file-roller.desktop
+application/x-lzma=file-roller.desktop
+application/x-lzma-compressed-tar=file-roller.desktop
+application/x-lzop=file-roller.desktop
+application/x-lzop-compressed-tar=file-roller.desktop
+application/x-rar=file-roller.desktop
+application/x-rar-compressed=file-roller.desktop
+application/x-rpm=file-roller.desktop
+application/x-rzip=file-roller.desktop
+application/x-tar=file-roller.desktop
+application/x-tarz=file-roller.desktop
+application/x-stuffit=file-roller.desktop
+application/x-war=file-roller.desktop
+application/x-xz=file-roller.desktop
+application/x-xz-compressed-tar=file-roller.desktop
+application/x-zip=file-roller.desktop
+application/x-zip-compressed=file-roller.desktop
+application/x-zoo=file-roller.desktop
+application/zip=file-roller.desktop
+multipart/x-zip=file-roller.desktop
+text/plain=gedit.desktop
+text/css=gedit.desktop
+text/javascript=gedit.desktop
+text/mathml=gedit.desktop
+text/x-csrc=gedit.desktop
+text/x-chdr=gedit.desktop
+text/x-dtd=gedit.desktop
+text/x-java=gedit.desktop
+text/x-javascript=gedit.desktop
+text/x-patch=gedit.desktop
+text/x-perl=gedit.destkop
+text/x-php=gedit.destkop
+text/x-python=gedit.destkop
+text/x-sql=gedit.desktop
+text/xml=gedit.desktop
+application/javascript=gedit.destkop
+application/x-cgi=gedit.desktop
+application/x-javascript=gedit.desktop
+application/x-perl=gedit.desktop
+application/x-php=gedit.desktop
+application/x-python=gedit.desktop
+application/xml=gedit.desktop
+application/xml-dtd=gedit.desktop
+application/x-font-ttf=gnome-font-viewer.desktop
+application/x-font-pcf=gnome-font-viewer.desktop
+application/x-font-type1=gnome-font-viewer.desktop
+application/x-font-otf=gnome-font-viewer.desktop
+application/csv=gnumeric.desktop
+application/excel=gnumeric.desktop
+application/msexcel=gnumeric.desktop
+application/tab-separated-values=gnumeric.desktop
+application/vnd.lotus-1-2-3=gnumeric.desktop
+application/vnd.ms-excel=gnumeric.desktop
+application/x-123=gnumeric.desktop
+application/x-applix-spreadsheet=gnumeric.desktop
+application/x-dbase=gnumeric.desktop
+application/x-dbf=gnumeric.desktop
+application/x-dos_ms_excel=gnumeric.desktop
+application/x-excel=gnumeric.desktop
+application/x-gnumeric=gnumeric.desktop
+application/x-mps=gnumeric.desktop
+application/x-ms-excel=gnumeric.desktop
+application/x-msexcel=gnumeric.desktop
+application/x-oleo=gnumeric.desktop
+application/x-planperfect=gnumeric.desktop
+application/x-quattropro=gnumeric.desktop
+application/x-sc=gnumeric.desktop
+application/x-sylk=gnumeric.desktop
+application/x-xbase=gnumeric.desktop
+application/x-xls=gnumeric.desktop
+application/xls=gnumeric.desktop
+text/comma-separated-values=gnumeric.desktop
+text/csv=gnumeric.desktop
+text/spreadsheet=gnumeric.desktop
+text/tab-separated-values=gnumeric.desktop
+text/x-comma-separated-values=gnumeric.desktop
+text/x-csv=gnumeric.desktop
+zz-application/zz-winassoc-xls=gnumeric.desktop
+x-content/software=nautilus-autorun-software.desktop
+x-directory/gnome-default-handler=nautilus-folder-handler.desktop
+x-directory/normal=nautilus-folder-handler.desktop
+inode/directory=nautilus-folder-handler.desktop
+application/x-gnome-saved-search=nautilus-folder-handler.desktop
+application/vnd.oasis.opendocument.spreadsheet=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.oasis.opendocument.spreadsheet-template=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.sun.xml.calc=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.sun.xml.calc.template=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.stardivision.calc=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.stardivision.chart=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.openxmlformats-officedocument.spreadsheetml.sheet=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.ms-excel.sheet.macroenabled.12=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.openxmlformats-officedocument.spreadsheetml.template=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.ms-excel.template.macroenabled.12=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.ms-excel.sheet.binary.macroenabled.12=libreoffice-calc.desktop;openoffice.org-calc.desktop
+application/vnd.oasis.opendocument.graphics=libreoffice-draw.desktop;openoffice.org-draw.desktop
+application/vnd.oasis.opendocument.graphics-template=libreoffice-draw.desktop;openoffice.org-draw.desktop
+application/vnd.sun.xml.draw=libreoffice-draw.desktop;openoffice.org-draw.desktop
+application/vnd.sun.xml.draw.template=libreoffice-draw.desktop;openoffice.org-draw.desktop
+application/vnd.stardivision.draw=libreoffice-draw.desktop;openoffice.org-draw.desktop
+application/vnd.oasis.opendocument.presentation=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.oasis.opendocument.presentation-template=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.sun.xml.impress=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.sun.xml.impress.template=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.stardivision.impress=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/mspowerpoint=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.ms-powerpoint=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.openxmlformats-officedocument.presentationml.presentation=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.ms-powerpoint.presentation.macroenabled.12=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.openxmlformats-officedocument.presentationml.template=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.ms-powerpoint.template.macroenabled.12=libreoffice-impress.desktop;openoffice.org-impress.desktop
+application/vnd.oasis.opendocument.formula=libreoffice-math.desktop;openoffice.org-math.desktop
+application/vnd.sun.xml.math=libreoffice-math.desktop;openoffice.org-math.desktop
+application/vnd.stardivision.math=libreoffice-math.desktop;openoffice.org-math.desktop
+application/vnd.oasis.opendocument.text=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.oasis.opendocument.text-template=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.oasis.opendocument.text-web=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.oasis.opendocument.text-master=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.sun.xml.writer=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.sun.xml.writer.template=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.sun.xml.writer.global=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.stardivision.writer=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/msword=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.ms-word=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/x-doc=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.wordperfect=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/wordperfect=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.openxmlformats-officedocument.wordprocessingml.document=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.ms-word.document.macroenabled.12=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.openxmlformats-officedocument.wordprocessingml.template=libreoffice-writer.desktop;openoffice.org-writer.desktop
+application/vnd.ms-word.template.macroenabled.12=libreoffice-writer.desktop;openoffice.org-writer.desktop
+x-content/audio-player=rhythmbox.desktop
+x-content/audio-cdda=sound-juicer.desktop
+application/x-shockwave-flash=swfdec-player.desktop
+application/futuresplash=swfdec-player.desktop
+application/mxf=totem.desktop
+application/ogg=totem.desktop
+application/ram=totem.desktop
+application/sdp=totem.desktop
+application/smil=totem.desktop
+application/smil+xml=totem.desktop
+application/vnd.ms-wpl=totem.desktop
+application/vnd.rn-realmedia=totem.desktop
+application/x-extension-m4a=totem.desktop
+application/x-extension-mp4=totem.desktop
+application/x-flac=totem.desktop
+application/x-flash-video=totem.desktop
+application/x-lyx=lyx.desktop
+application/x-matroska=totem.desktop
+application/x-netshow-channel=totem.desktop
+application/x-ogg=totem.desktop
+application/x-quicktime-media-link=totem.desktop
+application/x-quicktimeplayer=totem.desktop
+application/x-shorten=totem.desktop
+application/x-smil=totem.desktop
+application/xspf+xml=totem.desktop
+audio/3gpp=totem.desktop
+audio/ac3=totem.desktop
+audio/AMR=totem.desktop
+audio/AMR-WB=totem.desktop
+audio/basic=totem.desktop
+audio/midi=totem.desktop
+audio/mp4=totem.desktop
+audio/mpeg=totem.desktop
+audio/mpegurl=totem.desktop
+audio/ogg=totem.desktop
+audio/prs.sid=totem.desktop
+audio/vnd.rn-realaudio=totem.desktop
+audio/x-ape=totem.desktop
+audio/x-flac=totem.desktop
+audio/x-gsm=totem.desktop
+audio/x-it=totem.desktop
+audio/x-m4a=totem.desktop
+audio/x-matroska=totem.desktop
+audio/x-mod=totem.desktop
+audio/x-mp3=totem.desktop
+audio/x-mpeg=totem.desktop
+audio/x-mpegurl=totem.desktop
+audio/x-ms-asf=totem.desktop
+audio/x-ms-asx=totem.desktop
+audio/x-ms-wax=totem.desktop
+audio/x-ms-wma=totem.desktop
+audio/x-musepack=totem.desktop
+audio/x-pn-aiff=totem.desktop
+audio/x-pn-au=totem.desktop
+audio/x-pn-realaudio=totem.desktop
+audio/x-pn-realaudio-plugin=totem.desktop
+audio/x-pn-wav=totem.desktop
+audio/x-pn-windows-acm=totem.desktop
+audio/x-realaudio=totem.desktop
+audio/x-real-audio=totem.desktop
+audio/x-sbc=totem.desktop
+audio/x-scpls=totem.desktop
+audio/x-speex=totem.desktop
+audio/x-tta=totem.desktop
+audio/x-vorbis=totem.desktop
+audio/x-vorbis+ogg=totem.desktop
+audio/x-wav=totem.desktop
+audio/x-wavpack=totem.desktop
+audio/x-xm=totem.desktop
+image/vnd.rn-realpix=totem.desktop
+image/x-pict=totem.desktop
+misc/ultravox=totem.desktop
+text/google-video-pointer=totem.desktop
+text/x-google-video-pointer=totem.desktop
+video/3gpp=totem.desktop
+video/dv=totem.desktop
+video/fli=totem.desktop
+video/flv=totem.desktop
+video/mp2t=totem.desktop
+video/mp4=totem.desktop
+video/mp4v-es=totem.desktop
+video/mpeg=totem.desktop
+video/msvideo=totem.desktop
+video/ogg=totem.desktop
+video/quicktime=totem.desktop
+video/vivo=totem.desktop
+video/vnd.divx=totem.desktop
+video/vnd.rn-realvideo=totem.desktop
+video/vnd.vivo=totem.desktop
+video/webm=totem.desktop
+video/x-anim=totem.desktop
+video/x-avi=totem.desktop
+video/x-flc=totem.desktop
+video/x-fli=totem.desktop
+video/x-flic=totem.desktop
+video/x-flv=totem.desktop
+video/x-m4v=totem.desktop
+video/x-matroska=totem.desktop
+video/x-mpeg=totem.desktop
+video/x-ms-asf=totem.desktop
+video/x-ms-asx=totem.desktop
+video/x-msvideo=totem.desktop
+video/x-ms-wm=totem.desktop
+video/x-ms-wmv=totem.desktop
+video/x-ms-wmx=totem.desktop
+video/x-ms-wvx=totem.desktop
+video/x-nsv=totem.desktop
+video/x-ogm+ogg=totem.desktop
+video/x-theora+ogg=totem.desktop
+video/x-totem-stream=totem.desktop
+x-content/video-dvd=totem.desktop
+x-content/video-vcd=totem.desktop
+x-content/video-svcd=totem.desktop
+x-scheme-handler/ghelp=yelp.desktop;
+x-scheme-handler/help=yelp.desktop;
+x-scheme-handler/http=firefox.desktop;epiphany.desktop
+x-scheme-handler/https=firefox.desktop;epiphany.desktop
+x-scheme-handler/mailto=evolution.desktop
+application/x-bittorrent=transmission-gtk.desktop;deluge.desktop
+x-scheme-handler/magnet=transmission-gtk.desktop;deluge.desktop
diff --git a/gnome-base/gnome-session/gnome-session-3.5.2.ebuild b/gnome-base/gnome-session/gnome-session-3.5.2.ebuild
new file mode 100644
index 0000000..fb9a129
--- /dev/null
+++ b/gnome-base/gnome-session/gnome-session-3.5.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-session/gnome-session-3.4.2.1.ebuild,v 1.1 2012/05/24 05:18:25 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc elibc_FreeBSD ipv6 systemd"
+
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# gdk-pixbuf used in the inhibit dialog
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.90.7:3
+ >=dev-libs/json-glib-0.10
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2:2
+ >=sys-power/upower-0.9.0
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+
+ virtual/opengl
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-user-dirs-gtk
+ x11-apps/xdpyinfo"
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell
+# gnome-themes-standard is needed for the failwhale dialog themeing
+# sys-apps/dbus[X] is needed for session management
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gnome-settings-daemon
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ >=x11-themes/gnome-themes-standard-2.91.92
+ sys-apps/dbus[X]
+ systemd? ( >=sys-apps/systemd-38 )
+ !systemd? ( sys-auth/consolekit )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=sys-devel/gettext-0.10.40
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ !<gnome-base/gdm-2.20.4
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt )"
+# gnome-common needed for eautoreconf
+# gnome-base/gdm does not provide gnome.desktop anymore
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation-flags
+ --disable-schemas-compile
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable doc docbook-docs)
+ $(use_enable ipv6)
+ $(use_enable systemd)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_install() {
+ gnome2_src_install
+
+ dodir /etc/X11/Sessions
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/Gnome"
+
+ dodir /usr/share/gnome/applications/
+ insinto /usr/share/gnome/applications/
+ doins "${FILESDIR}/defaults.list"
+
+ dodir /etc/X11/xinit/xinitrc.d/
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome
+
+ # This should be done here as discussed in bug #270852
+ newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version gnome-base/gdm && ! has_version kde-base/kdm; then
+ ewarn "If you use a custom .xinitrc for your X session,"
+ ewarn "make sure that the commands in the xinitrc.d scripts are run."
+ fi
+}