summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-05-27 17:10:31 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-05-27 17:10:31 +0000
commitbc7a1b736356f658954780dfa14e270513d1eff7 (patch)
tree0fa6cff9bcdaad1d34a192a81e529dee24b899ff /gnome-base/gnome-settings-daemon
parentdev-buil of gnome-document, plus a patch to increase search speed in the gnom... (diff)
downloadsuka-bc7a1b736356f658954780dfa14e270513d1eff7.tar.gz
suka-bc7a1b736356f658954780dfa14e270513d1eff7.tar.bz2
suka-bc7a1b736356f658954780dfa14e270513d1eff7.zip
Add actually working live ebuilds for gnome-settings-daemon / gnome-control-center 3.5 (including one new dependency)
svn path=/; revision=334
Diffstat (limited to 'gnome-base/gnome-settings-daemon')
-rw-r--r--gnome-base/gnome-settings-daemon/Manifest2
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch110
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild123
3 files changed, 235 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/Manifest b/gnome-base/gnome-settings-daemon/Manifest
new file mode 100644
index 0000000..862e8f0
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/Manifest
@@ -0,0 +1,2 @@
+AUX gnome-settings-daemon-3.5.1-optional-color-wacom.patch 4125 RMD160 93deeffb9033393077d407ac1407320437c53260 SHA1 8ff8535509e5b4e4dac5609ccffff3c993b28a38 SHA256 8c58ff638e33a93cb10b00e0dcf1b3c4729ff1ac055f183d81956acee34a58c5
+EBUILD gnome-settings-daemon-9999.ebuild 3213 RMD160 0d86accfb337f4e5c2a03e211a41d6ad75e67d3f SHA1 30872c69749b45030b1486130d1bc70d2a443847 SHA256 185571b326e49a38a4dfc53e4d410cbc379fce0b279b9f4962457075d32b8c2f
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch
new file mode 100644
index 0000000..4df1193
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.5.1-optional-color-wacom.patch
@@ -0,0 +1,110 @@
+diff -Naur gnome-settings-daemon-3.3.92//configure.ac gnome-settings-daemon-3.3.92.new//configure.ac
+--- gnome-settings-daemon-3.3.92//configure.ac 2012-03-19 14:23:38.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//configure.ac 2012-03-25 11:36:35.833356226 +0530
+@@ -194,30 +194,39 @@
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [with_color=$enableval],
++ [with_color=yes]) dnl Default value
++
++if test x$with_color = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if wacom plugin is enabled])
++fi
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
++
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom (disabled for s390/s390x and non Linux platforms)
+ dnl ---------------------------------------------------------------------------
+
+-case $host_os in
+- linux*)
+- if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+- have_wacom=no
+- else
+- if test x$enable_gudev != xno; then
+- PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
+- else
+- AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+- fi
+- have_wacom=yes
+- fi
+- ;;
+- *)
+- have_wacom=no
+- ;;
+-esac
+-AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
++AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [have_wacom=$enableval],
++ [have_wacom=no]) dnl Default value
++
++if test x$with_wacom = xyes; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst $GUDEV_PKG gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
++ AC_DEFINE(HAVE_WACOM, 1, [Define if wacom plugin is enabled])
++fi
++AM_CONDITIONAL(HAVE_WACOM, test "x$with_wacom" = "xyes")
++
++AC_SUBST(WACOM_CFLAGS)
++AC_SUBST(WACOM_LIBS)
+
+ dnl ==============================================
+ dnl PackageKit section
+diff -Naur gnome-settings-daemon-3.3.92//data/Makefile.am gnome-settings-daemon-3.3.92.new//data/Makefile.am
+--- gnome-settings-daemon-3.3.92//data/Makefile.am 2012-03-16 22:59:35.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//data/Makefile.am 2012-03-25 11:39:24.548364338 +0530
+@@ -11,7 +11,6 @@
+ org.gnome.settings-daemon.plugins.gschema.xml \
+ org.gnome.settings-daemon.plugins.keyboard.gschema.xml \
+ org.gnome.settings-daemon.plugins.power.gschema.xml \
+- org.gnome.settings-daemon.plugins.color.gschema.xml \
+ org.gnome.settings-daemon.plugins.media-keys.gschema.xml \
+ org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
+ org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
+@@ -30,6 +29,12 @@
+ gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.orientation.gschema.xml
+ else
+ all_schemas += org.gnome.settings-daemon.plugins.orientation.gschema.xml
++endif
++
++if WITH_COLOR
++gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.color.gschema.xml
++else
++all_schemas += org.gnome.settings-daemon.plugins.color.gschema.xml
+ endif
+
+ if HAVE_WACOM
+diff -Naur gnome-settings-daemon-3.3.92//plugins/Makefile.am gnome-settings-daemon-3.3.92.new//plugins/Makefile.am
+--- gnome-settings-daemon-3.3.92//plugins/Makefile.am 2012-03-16 22:59:35.000000000 +0530
++++ gnome-settings-daemon-3.3.92.new//plugins/Makefile.am 2012-03-25 11:37:47.296359651 +0530
+@@ -6,7 +6,6 @@
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ power \
+@@ -39,6 +38,12 @@
+ disabled_plugins += orientation
+ endif
+
++if WITH_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if HAVE_WACOM
+ enabled_plugins += wacom
+ else
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
new file mode 100644
index 0000000..aa2d22b
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-9999.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.2-r1.ebuild,v 1.2 2012/01/12 03:32:00 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+fi
+IUSE="+colord +cups debug packagekit policykit smartcard systemd +udev wacom"
+
+# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gtk+-3.3.4:3
+ >=gnome-base/libgnomekbd-2.91.1
+ >=gnome-base/gnome-desktop-3.3.92:3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-0.9.16
+ >=sys-power/upower-0.9.11
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7.3
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.0
+ >=media-sound/pulseaudio-0.9.16
+
+ colord? ( >=x11-misc/colord-0.1.13 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ packagekit? (
+ sys-fs/udev[gudev]
+ >=app-admin/packagekit-base-0.6.12 )
+ smartcard? (
+ sys-fs/udev[gudev]
+ >=dev-libs/nss-3.11.2 )
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( sys-fs/udev[gudev] )
+ wacom? ( >=dev-libs/libwacom-0.3
+ x11-drivers/xf86-input-wacom )"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15"
+
+pkg_setup() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable debug)
+ $(use_enable debug more-warnings)
+ $(use_enable packagekit)
+ $(use_enable smartcard smartcard-support)
+ $(use_enable systemd)
+ $(use_enable udev gudev)
+ $(use_enable wacom)"
+}
+
+src_prepare() {
+
+ # Make colord and wacom optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.5.1-optional-color-wacom.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51gsettings-dconf
+ doenvd 51gsettings-dconf
+}