summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-09-28 19:22:41 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-09-28 19:22:41 +0000
commit78c4e96102cf294195e87dc84b4ea33b55277c91 (patch)
tree34970060df4a98cd286dfe4f8c0ee21a99610201 /gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch
parentRemove, in GNOME overlay now (diff)
downloadsuka-78c4e96102cf294195e87dc84b4ea33b55277c91.tar.gz
suka-78c4e96102cf294195e87dc84b4ea33b55277c91.tar.bz2
suka-78c4e96102cf294195e87dc84b4ea33b55277c91.zip
More cleanup work, use GNOME overlay instead
svn path=/; revision=350
Diffstat (limited to 'gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch')
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch b/gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch
deleted file mode 100644
index ae23a6c..0000000
--- a/gnome-base/gnome-shell/files/gnome-shell-3.2.1-automagic-gnome-bluetooth.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 84568fa9454f279ff519a2a11174e112786e46db Mon Sep 17 00:00:00 2001
-From: root <admin@catmur.co.uk>
-Date: Sun, 8 Jan 2012 13:55:05 +0000
-Subject: [PATCH] Fix automagic gnome-bluetooth dependency
-
-https://bugs.gentoo.org/show_bug.cgi?id=398145
-
-Ed Catmur 2012-01-08 13:46:22 UTC
-libgnome-bluetooth-applet is a private library so they shouldn't be linking
-against it anyway. I tried to work out how to tell libtool to add it to rpath
-but got totally lost.
-
-I'll see if I can work out how to fix the automagic gnome-bluetooth dependency
-so I can at least merge USE=-bluetooth.
----
- configure.ac | 5 +++++
- 1 files changed, 5 insertions(+), 0 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1c64122..a699838 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -127,6 +127,8 @@ PKG_CHECK_MODULES(GVC, libpulse libpulse-mainloop-glib gobject-2.0)
- PKG_CHECK_MODULES(DESKTOP_SCHEMAS, gsettings-desktop-schemas >= 0.1.7)
-
- AC_MSG_CHECKING([for bluetooth support])
-+AC_ARG_WITH([bluetooth], AS_HELP_STRING([--without-bluetooth], [Build without gnome-bluetooth library (default: auto)]))
-+AS_IF([test "x$with_bluetooth" != "xno"], [
- PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
- [BLUETOOTH_DIR=`$PKG_CONFIG --variable=applet_libdir gnome-bluetooth-1.0`
- BLUETOOTH_LIBS=`$PKG_CONFIG --variable=applet_libs gnome-bluetooth-1.0`
-@@ -138,6 +140,9 @@ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
- [AC_DEFINE([HAVE_BLUETOOTH],[0])
- AC_SUBST([HAVE_BLUETOOTH],[0])
- AC_MSG_RESULT([no])])
-+], [AC_DEFINE([HAVE_BLUETOOTH],[0])
-+ AC_SUBST([HAVE_BLUETOOTH],[0])
-+ AC_MSG_RESULT([no])])
-
- PKG_CHECK_MODULES(CALENDAR_SERVER, libecal-1.2 >= $LIBECAL_MIN_VERSION libedataserver-1.2 >= $LIBEDATASERVER_MIN_VERSION libedataserverui-3.0 >= $LIBEDATASERVERUI_MIN_VERSION gio-2.0)
- AC_SUBST(CALENDAR_SERVER_CFLAGS)
---
-1.7.8.2
-