summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-10-16 23:08:10 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-10-16 23:08:10 +0000
commite32da6148fd3ff601b3b2b903ecf3290e2709352 (patch)
tree6cf3831beb0058121875eebf965b8e2f0a82ba11 /gnome-base/gnome-shell/gnome-shell-9999.ebuild
parentfix keywords (diff)
downloadsuka-e32da6148fd3ff601b3b2b903ecf3290e2709352.tar.gz
suka-e32da6148fd3ff601b3b2b903ecf3290e2709352.tar.bz2
suka-e32da6148fd3ff601b3b2b903ecf3290e2709352.zip
Update gnome-shell live ebuilds, still not working, missing deps, but getting there...
svn path=/; revision=282
Diffstat (limited to 'gnome-base/gnome-shell/gnome-shell-9999.ebuild')
-rw-r--r--gnome-base/gnome-shell/gnome-shell-9999.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnome-base/gnome-shell/gnome-shell-9999.ebuild b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
index 6d58363..3c5e47f 100644
--- a/gnome-base/gnome-shell/gnome-shell-9999.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
@@ -5,10 +5,10 @@
EAPI="2"
GCONF_DEBUG="no"
-inherit autotools gnome2 git
-
EGIT_REPO_URI="git://git.gnome.org/gnome-shell"
+inherit autotools gnome2 git
+
DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
HOMEPAGE="http://live.gnome.org/GnomeShell"
SRC_URI=""
@@ -18,38 +18,39 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-libs/glib-2.20
- >=x11-libs/gtk+-2.16
+RDEPEND=">=dev-libs/glib-2.25.9
+ >=x11-libs/gtk+-2.91.0:3[introspection]
>=media-libs/gstreamer-0.10.16
>=media-libs/gst-plugins-base-0.10.16
- >=gnome-base/gnome-desktop-2.26
- >=dev-libs/gobject-introspection-0.6.9
+ >=gnome-base/gnome-desktop-2.91.0:3
+ >=dev-libs/gobject-introspection-0.9.5
dev-libs/dbus-glib
- >=dev-libs/gjs-0.6
- >=media-libs/clutter-1.2.0[opengl,introspection]
+ >=dev-libs/gjs-0.7
+ x11-libs/pango[introspection]
+ >=media-libs/clutter-1.4.0[introspection]
dev-libs/libcroco:0.6
- gnome-base/gconf
+ gnome-base/gconf[introspection]
gnome-base/gnome-menus
x11-libs/startup-notification
x11-libs/libXfixes
- >=x11-wm/mutter-2.29.1[introspection]
+ >=x11-wm/mutter-2.91.0[gtk3,introspection]
x11-apps/mesa-progs
+ dev-python/dbus-python
"
DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6
>=dev-lang/python-2.5
sys-devel/gettext
- >=dev-util/pkgconfig-0.9
+ >=dev-util/pkgconfig-0.22
>=dev-util/intltool-0.26
gnome-base/gnome-common
"
-DOCS="AUTHORS ChangeLog NEWS README"
+DOCS="AUTHORS README"
-src_unpack() {
- git_src_unpack
+src_prepare() {
- cd ${S}
mkdir m4
intltoolize --force --copy --automake || die
eautoreconf