summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-08-12 08:20:58 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-08-12 08:20:58 +0000
commit12dc8cdcf9c567fcb0ab94955a56e22a76f60e28 (patch)
treee68dcfe42a4eb5ea8f80306130dcd11f817f5b76 /gnome-base/gnome-shell
parentadd missing dependencies (diff)
downloadsuka-12dc8cdcf9c567fcb0ab94955a56e22a76f60e28.tar.gz
suka-12dc8cdcf9c567fcb0ab94955a56e22a76f60e28.tar.bz2
suka-12dc8cdcf9c567fcb0ab94955a56e22a76f60e28.zip
Live ebuilds for some GNOME Shell components (masked by default)
svn path=/; revision=141
Diffstat (limited to 'gnome-base/gnome-shell')
-rw-r--r--gnome-base/gnome-shell/Manifest1
-rw-r--r--gnome-base/gnome-shell/gnome-shell-9999.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 1bafe90..d31b7fb 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-2.27.0.tar.bz2 437202 RMD160 9d13cb841472b0cdc9a6bbfc7da48be95429ca09 SHA1 9bf1f96e4d70505101730579d396cd32e2488bce SHA256 df59d50e7653abfcf05d7d94f0aaefe8f05329e47d5c43510418622a40e84fb0
EBUILD gnome-shell-2.27.0.ebuild 1281 RMD160 ca90b8ffeeacb4d5efccea9926034b7d8ab73715 SHA1 2cba05e09c64143e61554608acb6eb39fd0c63fd SHA256 93bf2a1f99693a52f5d531cb64d9fd61a58c5752f9de4031ed54b43dba0ce8d9
+EBUILD gnome-shell-9999.ebuild 1401 RMD160 8b9f726902f14dfc2073f5187a8c0741941420f9 SHA1 22100836051633149ec10f1c69e517847b2f625f SHA256 6dbf1ce7ab8e4192df9515a8c8d8841510aa1ba49045ab03aba71d52523926bd
diff --git a/gnome-base/gnome-shell/gnome-shell-9999.ebuild b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
new file mode 100644
index 0000000..799d891
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.26.3.ebuild,v 1.1 2009/07/09 21:14:07 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/gnome-shell"
+
+DESCRIPTION="The GNOME Shell for GNOME 3.0"
+HOMEPAGE="http://live.gnome.org/GnomeShell"
+SRC_URI=""
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=gnome-base/gnome-desktop-2.26.0
+ >=x11-libs/pango-1.15.4
+ >=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.15.1
+ >=x11-wm/mutter-2.27.2
+ dev-libs/gjs
+ >=dev-libs/gobject-introspection-0.6.3
+ >=dev-libs/gir-repository-0.6.3[pango]
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/gnome-menus-2.11.1
+ gnome-base/librsvg
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-1.1.2
+ x11-libs/libXau"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ gnome-base/gnome-common
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/gtk-doc-am-1"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+
+ MAKEOPTS="-j1"
+
+}
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ eautoreconf
+}
+
+pkg_postinst() {
+
+ elog " Start with 'gnome-shell --replace' "
+ elog " or add gnome-shell.desktop to ~/.config/autostart/ "
+
+}