summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2007-07-23 19:25:55 +0000
committerAndreas Proschofsky <suka@gentoo.org>2007-07-23 19:25:55 +0000
commit7a6792bdb28cd27b2de2b3f1c27e498dfe4ccb37 (patch)
treead7f70f476e3f79e5ad36082d565b9232f068770 /gnome-extra
parentAdd intlclock-patch to gnome-panel. This provides an alternate clock applet w... (diff)
downloadsuka-7a6792bdb28cd27b2de2b3f1c27e498dfe4ccb37.tar.gz
suka-7a6792bdb28cd27b2de2b3f1c27e498dfe4ccb37.tar.bz2
suka-7a6792bdb28cd27b2de2b3f1c27e498dfe4ccb37.zip
Add tracker and beagle use-flags (and patches) to gnome-main-menu, taken from Gentoo bug #140027
svn path=/; revision=6
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-main-menu/files/03-tracker-search.patch13
-rw-r--r--gnome-extra/gnome-main-menu/files/04-disable-search.patch13
-rw-r--r--gnome-extra/gnome-main-menu/gnome-main-menu-9999.ebuild19
3 files changed, 39 insertions, 6 deletions
diff --git a/gnome-extra/gnome-main-menu/files/03-tracker-search.patch b/gnome-extra/gnome-main-menu/files/03-tracker-search.patch
new file mode 100644
index 0000000..172f782
--- /dev/null
+++ b/gnome-extra/gnome-main-menu/files/03-tracker-search.patch
@@ -0,0 +1,13 @@
+Index: main-menu/etc/slab.schemas.in.in
+===================================================================
+--- main-menu/etc/slab.schemas.in.in (revision 278)
++++ main-menu/etc/slab.schemas.in.in (working copy)
+@@ -77,7 +77,7 @@
+ <applyto>/desktop/gnome/applications/main-menu/search_command</applyto>
+ <owner>gnome-main-menu</owner>
+ <type>string</type>
+- <default>beagle-search SEARCH_STRING</default>
++ <default>tracker-search-tool SEARCH_STRING</default>
+ <locale name="C">
+ <short>This is the command to execute when the search entry is used.</short>
+ <long>This is the command to execute when the search entry is used. SEARCH_STRING is replaced with the entered search text.</long>
diff --git a/gnome-extra/gnome-main-menu/files/04-disable-search.patch b/gnome-extra/gnome-main-menu/files/04-disable-search.patch
new file mode 100644
index 0000000..d5c3ce7
--- /dev/null
+++ b/gnome-extra/gnome-main-menu/files/04-disable-search.patch
@@ -0,0 +1,13 @@
+Index: main-menu/etc/slab.schemas.in.in
+===================================================================
+--- main-menu/etc/slab.schemas.in.in (revision 278)
++++ main-menu/etc/slab.schemas.in.in (working copy)
+@@ -186,7 +186,7 @@
+ <applyto>/desktop/gnome/applications/main-menu/lock-down/search_area_visible</applyto>
+ <owner>gnome-main-menu</owner>
+ <type>bool</type>
+- <default>true</default>
++ <default>false</default>
+ <locale name="C">
+ <short>lock-down status for the search area</short>
+ <long>set to true if the search area should be visible and active.</long>
diff --git a/gnome-extra/gnome-main-menu/gnome-main-menu-9999.ebuild b/gnome-extra/gnome-main-menu/gnome-main-menu-9999.ebuild
index 56a7d94..9f976d1 100644
--- a/gnome-extra/gnome-main-menu/gnome-main-menu-9999.ebuild
+++ b/gnome-extra/gnome-main-menu/gnome-main-menu-9999.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${PN}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
-IUSE="doc libssui nautilus"
+IUSE="beagle doc libssui nautilus tracker"
RDEPEND=">=dev-libs/glib-2.8.0
>=x11-libs/gtk+-2
@@ -34,7 +34,8 @@ RDEPEND=">=dev-libs/glib-2.8.0
sys-apps/hal
x11-libs/cairo
x11-libs/pango
- libssui? ( >=gnome-extra/libssui-0.5.6 )"
+ libssui? ( >=gnome-extra/libssui-0.5.6 )
+ tracker? ( app-misc/tracker )"
DEPEND="${RDEPEND}
doc? (
@@ -49,11 +50,12 @@ src_unpack() {
epatch "${FILESDIR}"/gnome-main-menu-gentooifications.patch
use libssui && epatch "${FILESDIR}"/gnome-main-menu-libssui.patch
-
- if ! use doc ; then
- epatch "${FILESDIR}"/03-configure.in-remove-gtk-doc.patch
+ use doc || epatch "${FILESDIR}"/03-configure.in-remove-gtk-doc.patch
+ if use tracker && ! use beagle ; then
+ epatch ${FILESDIR}/03-tracker-search.patch
+ elif ! use tracker && ! use beagle ; then
+ epatch ${FILESDIR}/04-disable-search.patch
fi
-
}
src_compile() {
@@ -70,4 +72,9 @@ pkg_postinst() {
elog " also use the patched gnome-panel and gnome-desktop packages from this "
elog " overlay "
elog
+ if use tracker && use beagle ; then
+ ewarn " You have both beagle and tracker set in your USE flags. "
+ ewarn " Beagle will be used by default. If you would like to use "
+ ewarn " tracker, emerge this package with the beagle USE flag unset. "
+ fi
}