summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-07-29 19:05:45 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-07-29 19:05:45 +0000
commit68fa74b9e83581b718e01be6f3edfc726a8975ff (patch)
treea3bb10d38235d6126a4083d3a8db92887168ff03 /net-misc
parentmanifest... (diff)
downloadsuka-68fa74b9e83581b718e01be6f3edfc726a8975ff.tar.gz
suka-68fa74b9e83581b718e01be6f3edfc726a8975ff.tar.bz2
suka-68fa74b9e83581b718e01be6f3edfc726a8975ff.zip
Add live ebuild for gwibber, the twitter, identi.ca and Jaiku client
svn path=/; revision=85
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gwibber/Manifest1
-rw-r--r--net-misc/gwibber/gwibber-9999.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/gwibber/Manifest b/net-misc/gwibber/Manifest
new file mode 100644
index 0000000..8e56290
--- /dev/null
+++ b/net-misc/gwibber/Manifest
@@ -0,0 +1 @@
+EBUILD gwibber-9999.ebuild 892 RMD160 2128f31ddb05351f670b3a713498cce954c636ce SHA1 aad134b301d246bf9c17fbb034b823e76033d371 SHA256 b4222b4bd951f5085e884ed04269c4e550504c9716a18cd1626b2d24ba4b60f5
diff --git a/net-misc/gwibber/gwibber-9999.ebuild b/net-misc/gwibber/gwibber-9999.ebuild
new file mode 100644
index 0000000..2b77ef8
--- /dev/null
+++ b/net-misc/gwibber/gwibber-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EBZR_BRANCH="webkitui"
+EBZR_REPO_URI="https://code.launchpad.net/~segphault/gwibber/"
+inherit gnome2 bzr python
+
+DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed with Python and GTK. It supports Twitter, Jaiku, Identi.ca, Facebook, and Digg."
+HOMEPAGE="https://launchpad.net/gwibber"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-python/dbus-python-0.80.2
+ >=dev-python/gnome-python-2.18.0
+ >=dev-python/pygtk-2.10.4
+ >=dev-python/notify-python-0.1.1
+ net-libs/webkit-gtk"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"
+ python setup.py config
+ python setup.py build || die "setup.py build failed"
+}
+
+src_install () {
+ python setup.py install --prefix=/usr --root="${D}"
+ assert "setup.py install failed"
+}
+