summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-03-16 11:09:40 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-03-16 11:09:40 +0000
commit76b60840e0dd1c0edc9459ceb959f9eaab3f46e3 (patch)
tree957168d2c44c77662fc28c9093a43887ebd0062c /net-misc
parentBump to clutter 1.2.2 (diff)
downloadsuka-76b60840e0dd1c0edc9459ceb959f9eaab3f46e3.tar.gz
suka-76b60840e0dd1c0edc9459ceb959f9eaab3f46e3.tar.bz2
suka-76b60840e0dd1c0edc9459ceb959f9eaab3f46e3.zip
Sync gwibber live ebuild to portage, remove local desktopcouch and oauth
svn path=/; revision=219
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gwibber/Manifest2
-rw-r--r--net-misc/gwibber/gwibber-9999.ebuild42
2 files changed, 25 insertions, 19 deletions
diff --git a/net-misc/gwibber/Manifest b/net-misc/gwibber/Manifest
index 5222d5b..e21b704 100644
--- a/net-misc/gwibber/Manifest
+++ b/net-misc/gwibber/Manifest
@@ -1 +1 @@
-EBUILD gwibber-9999.ebuild 1027 RMD160 820ca88fd8beb4692489da7df75b3ab870060294 SHA1 f2004da9a50ae61a8c44b2d178680a748f68b04a SHA256 cbfd0f89f6005f6d786c0d58bc4b60c8138d3df1c1ae9e9b9e57f0a176db92e7
+EBUILD gwibber-9999.ebuild 1201 RMD160 89e0284bff5198e2ff1cc819b4b0c51564f68abb SHA1 421cf01c89fa23a2ff9eb7593a30f2973517fa89 SHA256 a42f2860ac25642cd73923e861ee8cdafeb7e72977d524800ad05bb082a343f7
diff --git a/net-misc/gwibber/gwibber-9999.ebuild b/net-misc/gwibber/gwibber-9999.ebuild
index 66c143d..d793f9f 100644
--- a/net-misc/gwibber/gwibber-9999.ebuild
+++ b/net-misc/gwibber/gwibber-9999.ebuild
@@ -2,38 +2,44 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+PYTHON_DEPEND="2"
+
EBZR_REPO_URI="https://code.launchpad.net/~gwibber-committers/gwibber/trunk"
-inherit bzr
-DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed with Python and GTK."
+inherit bzr eutils distutils
+
+DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed
+with Python and GTK."
HOMEPAGE="https://launchpad.net/gwibber"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-python/dbus-python-0.80.2
+RDEPEND=">=dev-python/dbus-python-0.80.2
>=dev-python/gconf-python-2.18.0
- >=dev-python/pygtk-2.10.4
+ >=dev-python/imaging-1.1.6
>=dev-python/notify-python-0.1.1
- dev-python/libwnck-python
- >=dev-python/mako-0.2.2
+ >=dev-python/pywebkitgtk-1.0.1
+ >=dev-python/simplejson-1.9.1
>=dev-python/egenix-mx-base-3.0.0
+ >=dev-python/python-distutils-extra-2.15
+ >=dev-python/pycurl-7.19.0
+ >=dev-python/libwnck-python-2.26.0
>=dev-python/feedparser-4.1
- dev-python/pycurl
- >=dev-python/simplejson-1.9.1
- >=dev-python/python-distutils-extra-1.91
- net-libs/webkit-gtk
- >=dev-python/pywebkitgtk-1.0.2
>=dev-python/pyxdg-0.15
- >=dev-python/imaging-1.1.6
- gnome-extra/desktopcouch"
+ >=dev-python/mako-0.2.4
+ >=dev-db/desktopcouch-0.4.6
+ >=dev-python/pygtk-2.16
+ >=gnome-base/librsvg-2.22.2"
-RDEPEND="${DEPEND}"
+src_install() {
+ distutils_src_install
-src_install () {
- python setup.py install --prefix=/usr --root="${D}"
- assert "setup.py install failed"
+ insinto /usr/share/dbus-1/services
+ doins com.Gwibber{.Service,Client}.service || die "Installing services failed."
+ doman gwibber{,-poster}.1 || die "Man page couldn't be installed."
}