summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/oauth/Manifest2
-rw-r--r--dev-python/oauth/oauth-1.0.1.ebuild15
-rw-r--r--gnome-extra/desktopcouch/Manifest2
-rw-r--r--gnome-extra/desktopcouch/desktopcouch-0.6.1-r4.ebuild41
-rw-r--r--net-misc/gwibber/Manifest2
-rw-r--r--net-misc/gwibber/gwibber-9999.ebuild22
6 files changed, 70 insertions, 14 deletions
diff --git a/dev-python/oauth/Manifest b/dev-python/oauth/Manifest
new file mode 100644
index 0000000..582cca1
--- /dev/null
+++ b/dev-python/oauth/Manifest
@@ -0,0 +1,2 @@
+DIST oauth-1.0.1.tar.gz 9533 RMD160 3d1dad6117aeb13392e35870716022e3a71897c3 SHA1 b2d7609e4852b33d0d33f0bc6ae5cab8fadca014 SHA256 e769819ff0b0c043d020246ce1defcaadd65b9c21d244468a45a7f06cb88af5d
+EBUILD oauth-1.0.1.ebuild 370 RMD160 9df436448778e0d6a911839db9c8883d8125e613 SHA1 c352a7bb0b698d29580d1896b39dfcac3a0022d6 SHA256 9eb5de724e8c478c92ce5bee71c526017ee6e1616e17c62062366ce1dd68ebf6
diff --git a/dev-python/oauth/oauth-1.0.1.ebuild b/dev-python/oauth/oauth-1.0.1.ebuild
new file mode 100644
index 0000000..6bdf28d
--- /dev/null
+++ b/dev-python/oauth/oauth-1.0.1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Python OAuth module"
+HOMEPAGE="http://pypi.python.org/pypi/oauth/"
+SRC_URI="http://pypi.python.org/packages/source/o/${PN}/${P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/gnome-extra/desktopcouch/Manifest b/gnome-extra/desktopcouch/Manifest
new file mode 100644
index 0000000..9330359
--- /dev/null
+++ b/gnome-extra/desktopcouch/Manifest
@@ -0,0 +1,2 @@
+DIST desktopcouch-0.6.1.tar.gz 96707 RMD160 33e50115e91da1abb3bacca3805bfbd57a0fd967 SHA1 4e5acd3cb19e3f9dafb2a41f16b37b7662c50c7f SHA256 75dbec97475047a02006f0347a4e736188dfc4760136b5d01f9390712113a964
+EBUILD desktopcouch-0.6.1-r4.ebuild 921 RMD160 c733f90d825b46de0e5c6ec6a5158f0d9ac4d6fc SHA1 0f4d9716182de36666021a557527c41586b4f71e SHA256 295ec88302d5889e310c420e3003575a920da7c3e06e0a8ed4444f04254ab8a5
diff --git a/gnome-extra/desktopcouch/desktopcouch-0.6.1-r4.ebuild b/gnome-extra/desktopcouch/desktopcouch-0.6.1-r4.ebuild
new file mode 100644
index 0000000..887cbce
--- /dev/null
+++ b/gnome-extra/desktopcouch/desktopcouch-0.6.1-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="A CouchDB on every desktop, and the code to help it happen."
+HOMEPAGE="https://launchpad.net/desktopcouch"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-db/couchdb
+dev-python/pyxdg
+dev-python/gnome-keyring-python
+dev-python/dbus-python
+dev-python/twisted
+dev-python/pygobject
+dev-python/pygtk
+dev-python/couchdb-python
+dev-python/oauth
+net-dns/avahi[python]
+"
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ distutils_src_install
+ dobin "${FILESDIR}/desktopcouch-restart"
+ elog "Your desktopcouch can be accessed at"
+ elog "/home/YOURUSERNAME/.local/share/desktop-couch/couchdb.html"
+ elog "If things seem to be broken, try running"
+ elog "desktopcouch-restart"
+
+}
diff --git a/net-misc/gwibber/Manifest b/net-misc/gwibber/Manifest
index b8608cd..51dd191 100644
--- a/net-misc/gwibber/Manifest
+++ b/net-misc/gwibber/Manifest
@@ -1 +1 @@
-EBUILD gwibber-9999.ebuild 1073 RMD160 65b4b3a435e125688270789003e11d6fa7895f73 SHA1 2dbbd0faa36e8a18832c2fa18d611f696fb5901d SHA256 e819d8b8f9f70c2138e9b5d0169c6a990ff229ceeb427dcdd7173fb392d5010c
+EBUILD gwibber-9999.ebuild 1000 RMD160 5b2142534955682f973b513bd904cfb03ba07116 SHA1 dea7cb4aba1ffd26e21048cc1e02f47ea08ca356 SHA256 b030e85b0fb82b437a4d6416d95e0f0437db06a16012beefe5ce55170c574036
diff --git a/net-misc/gwibber/gwibber-9999.ebuild b/net-misc/gwibber/gwibber-9999.ebuild
index 256b452..42b9fca 100644
--- a/net-misc/gwibber/gwibber-9999.ebuild
+++ b/net-misc/gwibber/gwibber-9999.ebuild
@@ -5,7 +5,7 @@
EBZR_REPO_URI="https://code.launchpad.net/~gwibber-committers/gwibber/trunk"
inherit bzr
-DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed with Python and GTK. It supports Twitter, Jaiku, Identi.ca, Facebook, and Digg."
+DESCRIPTION="Gwibber is an open source microblogging client for GNOME developed with Python and GTK."
HOMEPAGE="https://launchpad.net/gwibber"
SRC_URI=""
@@ -18,25 +18,21 @@ DEPEND=">=dev-python/dbus-python-0.80.2
>=dev-python/gconf-python-2.18.0
>=dev-python/pygtk-2.10.4
>=dev-python/notify-python-0.1.1
- >=dev-python/mako-0.2
- dev-python/egenix-mx-base
- dev-python/feedparser
+ >=dev-python/mako-0.2.2
+ >=dev-python/egenix-mx-base-3.0.0
+ >=dev-python/feedparser-4.1
dev-python/pycurl
- >=dev-python/simplejson-1.7.3
+ >=dev-python/simplejson-1.9.1
>=dev-python/python-distutils-extra-1.91
net-libs/webkit-gtk
- >=dev-python/pywebkitgtk-1.0.2"
+ >=dev-python/pywebkitgtk-1.0.2
+ >=dev-python/pyxdg-0.15
+ >=dev-python/imaging-1.1.6
+ gnome-extra/desktopcouch"
RDEPEND="${DEPEND}"
-src_compile() {
- cd "${S}"
- python setup.py config
- python setup.py build || die "setup.py build failed"
-}
-
src_install () {
python setup.py install --prefix=/usr --root="${D}"
assert "setup.py install failed"
}
-