summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/conduit/conduit-0.3.4.ebuild')
-rw-r--r--app-admin/conduit/conduit-0.3.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/conduit/conduit-0.3.4.ebuild b/app-admin/conduit/conduit-0.3.4.ebuild
new file mode 100644
index 0000000..33ae574
--- /dev/null
+++ b/app-admin/conduit/conduit-0.3.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2 python multilib
+
+DESCRIPTION="A Desktop Synchronization Solution for GNOME"
+HOMEPAGE="http://www.conduit-project.org/"
+SRC_URI="http://files.conduit-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+
+RDEPEND=">=virtual/python-2.4
+ >=x11-libs/gtk+-2.10
+ >=sys-apps/dbus-0.93
+ >=dev-python/pygtk-2.10
+ dev-python/pyxml
+ dev-python/vobject
+ dev-python/dbus-python
+ dev-python/pygoocanvas
+ dev-python/gnome-python
+ dev-python/python-dateutil
+ dev-python/elementtree
+ python? ( >=dev-python/evolution-python-0.0.3 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/conduit
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}