summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/giver/giver-0.1.8.ebuild')
-rw-r--r--app-misc/giver/giver-0.1.8.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-misc/giver/giver-0.1.8.ebuild b/app-misc/giver/giver-0.1.8.ebuild
index 4f4b291..b8532d8 100644
--- a/app-misc/giver/giver-0.1.8.ebuild
+++ b/app-misc/giver/giver-0.1.8.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils gnome2 mono
+EAPI=2
+
+inherit eutils mono
DESCRIPTION="Makes giving files to others very simple"
HOMEPAGE="http://code.google.com/p/giver"
@@ -14,6 +16,8 @@ KEYWORDS="~x86"
IUSE="doc"
RDEPEND=">=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/glib-sharp-2
+ >=dev-dotnet/pango-sharp-2
>=dev-dotnet/gnome-sharp-2
>=dev-dotnet/notify-sharp-0.4.0_pre20080912
>=net-dns/avahi-0.6.10"
@@ -35,7 +39,9 @@ src_unpack() {
cd ${S}/src
epatch ${FILESDIR}/${PN}-username_face2.patch
- gnome2_omf_fix
+ # Shouldn't depend on gtkdotnet-sharp
+ export GTK_DOTNET_20_LIBS=" " \
+ GTK_DOTNET_20_CFLAGS=" "
}
pkg_postinst() {