summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tasque')
-rw-r--r--app-misc/tasque/Manifest1
-rw-r--r--app-misc/tasque/tasque-9999.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/tasque/Manifest b/app-misc/tasque/Manifest
index d39cd39..bb7c84d 100644
--- a/app-misc/tasque/Manifest
+++ b/app-misc/tasque/Manifest
@@ -1,2 +1,3 @@
DIST tasque-0.1.6.tar.bz2 439854 RMD160 81fe51b22c8d6c8ae20dae42b3c69c6e1605ff11 SHA1 2ae5a6548f7701e0e97afff21e3f6771b0594bc7 SHA256 90c1eb43aa16ab4674462313453fad0554ac0748c9560b8d7737f1441eaf21f1
EBUILD tasque-0.1.6.ebuild 725 RMD160 2d1993c78cc0b7571228cb83bdf3e661b6611c5e SHA1 0de3815bc4cb2fd13df84b1e16e7f96236698e26 SHA256 6e3a8f58249c617ddd31960928ab311bfcb9348e393aa52a404d60bb3759c0fa
+EBUILD tasque-9999.ebuild 1060 RMD160 8ad0a93af2000e732cb75e38f066077b44854437 SHA1 5dbc194b7ec3e1a46dda309f02ec03115b20250a SHA256 8d97be10f5e34db939f01a947429b50567baa30fa2a5b180ee71c07c0e702dd5
diff --git a/app-misc/tasque/tasque-9999.ebuild b/app-misc/tasque/tasque-9999.ebuild
new file mode 100644
index 0000000..d3c4904
--- /dev/null
+++ b/app-misc/tasque/tasque-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2000-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils gnome2 mono subversion
+
+DESCRIPTION="Tasky is a simple task management app (TODO list) for the Linux Desktop"
+HOMEPAGE="http://live.gnome.org/Tasque"
+
+# Have to set SRC_URI blank or gnome2 eclass tries to fetch package
+SRC_URI=""
+
+ESVN_REPO_URI="http://svn.gnome.org/svn/tasque/trunk"
+
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="eds sqlite"
+
+RDEPEND=">=dev-dotnet/gtk-sharp-2
+ >=dev-dotnet/gnome-sharp-2
+ >=dev-dotnet/notify-sharp-0.4.0
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-glib-sharp-0.4
+ eds? ( dev-dotnet/evolution-sharp )
+ sqlite? ( >=dev-db/sqlite-3 )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+
+ G2CONF="${G2CONF} --enable-release --enable-backend-rtm $(use_enable sqlite backend-sqlite) $(use_enable eds backend-eds)"
+
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd ${S}
+
+ gnome2_omf_fix
+
+ intltoolize --force || die "intloolize failed"
+ eautoreconf || die "eautoreconf failed"
+}