summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/librest/librest-0.6.0.ebuild')
-rw-r--r--dev-libs/librest/librest-0.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/librest/librest-0.6.0.ebuild b/dev-libs/librest/librest-0.6.0.ebuild
new file mode 100644
index 0000000..cabe04d
--- /dev/null
+++ b/dev-libs/librest/librest-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Library to access RESTful web-services"
+HOMEPAGE="http://moblin.org/projects/librest"
+SRC_URI="http://moblin.org/sites/all/files/rest-0.6.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=net-libs/libsoup-2.4
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1 )
+ >=dev-libs/libxml2-2"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README"
+
+S="${WORKDIR}/rest-0.6"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with gnome)"
+}