summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/evolution-python/evolution-python-0.0.3.ebuild')
-rw-r--r--dev-python/evolution-python/evolution-python-0.0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/evolution-python/evolution-python-0.0.3.ebuild b/dev-python/evolution-python/evolution-python-0.0.3.ebuild
new file mode 100644
index 0000000..d0a5810
--- /dev/null
+++ b/dev-python/evolution-python/evolution-python-0.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="Evolution-python is a library to add python support to evolution-data-server"
+HOMEPAGE="http://pygtk.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+SRC_URI="http://files.conduit-project.org/releases/${P}.tar.gz"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.4
+ >=dev-python/pygobject-2.6
+ >=x11-libs/gtk+-2.6.0
+ x11-libs/pango
+ >=gnome-extra/evolution-data-server-1.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}