summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups')
-rw-r--r--dev-python/pycups/Manifest4
-rw-r--r--dev-python/pycups/pycups-1.9.45.ebuild23
-rw-r--r--dev-python/pycups/pycups-1.9.46.ebuild45
3 files changed, 47 insertions, 25 deletions
diff --git a/dev-python/pycups/Manifest b/dev-python/pycups/Manifest
index 2a07aac..5778df7 100644
--- a/dev-python/pycups/Manifest
+++ b/dev-python/pycups/Manifest
@@ -1,2 +1,2 @@
-DIST pycups-1.9.45.tar.bz2 39968 RMD160 d03b38080ef7b385689c197b23087491477e4fd7 SHA1 976e84f1a32cbc0fc3fc5c3557fad334048e0573 SHA256 ef6e576e5465da9c338ac8ff9f162825cfb7997359efc52e6a110c295a9f363b
-EBUILD pycups-1.9.45.ebuild 528 RMD160 7eac2980e644ae54a9c888c54696ddc5f4717299 SHA1 db1ae4809a76fa28939300449246d98a4fa0ac2d SHA256 f23e77e3cf5a52ba63d139632c2663f1b1386429c79f3e7e191be89d532d0bb8
+DIST pycups-1.9.46.tar.bz2 41626 RMD160 591d96786d31f3b452aa7484dd933715904bc32b SHA1 3d58a0f7b4a1b6a2880baf9ef5e14eae461d0982 SHA256 74abd1d6b1a5b8a22d2ccf3730000848fcef0b63c6105b178f73ff76e72bc8fe
+EBUILD pycups-1.9.46.ebuild 958 RMD160 6a08a7b701245c01aa1715452ff7d11f3cb4aee1 SHA1 7e40be55cbfa4dbda10c60a1d65042993284e35a SHA256 08e7f4fd5feff7c3f24b68bd37877725b94d8ab526ec2a1f324da97541516535
diff --git a/dev-python/pycups/pycups-1.9.45.ebuild b/dev-python/pycups/pycups-1.9.45.ebuild
deleted file mode 100644
index 29ffd26..0000000
--- a/dev-python/pycups/pycups-1.9.45.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit python
-
-DESCRIPTION="Python bindings for the CUPS API"
-HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
-SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-DEPEND=""
-
-src_compile() {
- python_version
- emake PYTHONVERS="python${PYVER}" || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-python/pycups/pycups-1.9.46.ebuild b/dev-python/pycups/pycups-1.9.46.ebuild
new file mode 100644
index 0000000..522df68
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.46.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.45-r1.ebuild,v 1.2 2009/06/12 14:07:43 scarabeus Exp $
+
+NEED_PYTHON="2.4"
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+
+}