summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild')
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild
new file mode 100644
index 0000000..8dd54bb
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.91.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.30.1.ebuild,v 1.1 2010/06/13 16:47:46 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=sys-apps/dbus-0.92
+ >=dev-libs/dbus-glib-0.34
+ >=x11-libs/gtk+-2.90:3
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ # Only user interaction required graphical tests at the time of 2.22.0 - not useful for us
+ G2CONF="${G2CONF} --disable-tests --disable-static"
+}
+
+src_compile() {
+ # FreeBSD doesn't like -j, upstream? bug #????
+ use x86-fbsd && MAKEOPTS="${MAKEOPTS} -j1"
+ gnome2_src_compile
+}