summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gnome-online-accounts/gnome-online-accounts-3.5.2.ebuild')
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.5.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.2.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.2.ebuild
new file mode 100644
index 0000000..d557378
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.5.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnome-online-accounts/gnome-online-accounts-3.4.1-r1.ebuild,v 1.1 2012/05/06 09:15:10 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gnome +introspection"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+RDEPEND="
+ >=dev-libs/glib-2.30.0:2
+ dev-libs/json-glib
+ gnome-base/libgnome-keyring
+ net-libs/libsoup:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4
+ net-libs/rest:0.7
+ net-libs/webkit-gtk:3
+ >=x11-libs/gtk+-3.5.1:3
+ >=x11-libs/libnotify-0.7
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+pkg_setup() {
+ # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-documentation
+ --enable-exchange
+ --enable-facebook
+ --enable-windows-live"
+ DOCS="NEWS" # README is empty
+}