summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libnotify/libnotify-0.7.0.ebuild')
-rw-r--r--x11-libs/libnotify/libnotify-0.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libnotify/libnotify-0.7.0.ebuild b/x11-libs/libnotify/libnotify-0.7.0.ebuild
new file mode 100644
index 0000000..496e198
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libnotify/libnotify-0.4.5.ebuild,v 1.14 2010/03/26 16:28:15 ssuominen Exp $
+
+EAPI=2
+
+inherit gnome.org
+
+DESCRIPTION="Notifications library"
+HOMEPAGE="http://www.galago-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=x11-libs/gtk+-2.90:3"
+PDEPEND="|| ( x11-misc/notification-daemon
+ xfce-extra/xfce4-notifyd )"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS
+}