summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-themes-standard')
-rw-r--r--x11-themes/gnome-themes-standard/Manifest2
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.5.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/Manifest b/x11-themes/gnome-themes-standard/Manifest
new file mode 100644
index 0000000..ddbbb3b
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-themes-standard-3.5.2.tar.xz 3361704 RMD160 aa4c5caf1ede8529275fb44ebad03abeca8e8f15 SHA1 fb30e2e4bf82948e53582b13a37bf7a4d54fe658 SHA256 70c4d951fd66c6ee67be402b4a6e56c420b86691202f849d13b9457ad2930ce7
+EBUILD gnome-themes-standard-3.5.2.ebuild 1691 RMD160 d500051897316178f6fc5dbb6f3063e4ccc6e793 SHA1 a81ddc1c3ea9861fc2a670ed551967e84e9f6de7 SHA256 3d83117bf2c1c6c5fac8571b27f3ae288ac50bf20c89250bd6b87e1a63411879
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.5.2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.5.2.ebuild
new file mode 100644
index 0000000..5eb74ef
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.5.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.4.2.ebuild,v 1.1 2012/05/19 09:36:05 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Adwaita theme for GNOME Shell"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="gnome-base/librsvg:2
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.3.14:3
+ >=x11-themes/gtk-engines-2.15.3:2"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1"
+
+pkg_setup() {
+ DOCS="ChangeLog NEWS"
+ # The icon cache needs to be generated in pkg_postinst()
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-placeholders
+ GTK_UPDATE_ICON_CACHE=$(type -P true)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ cd "${ED}/usr/share/cursors/xorg-x11" || die
+ ln -sfn Adwaita default || die
+}