summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/capseo/capseo-0.1.0_pre200702191.ebuild')
-rw-r--r--media-libs/capseo/capseo-0.1.0_pre200702191.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-libs/capseo/capseo-0.1.0_pre200702191.ebuild b/media-libs/capseo/capseo-0.1.0_pre200702191.ebuild
deleted file mode 100644
index 9020a56..0000000
--- a/media-libs/capseo/capseo-0.1.0_pre200702191.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit multilib
-
-DESCRIPTION="Capseo Video Codec Library"
-HOMEPAGE="http://battousai.mylair.de/projects/captury/wiki/CapseoCodec"
-SRC_URI="http://battousai.mylair.de/dist/capseo/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-RESTRICT="multilib-pkg-force"
-
-src_compile() {
- if [[ -z ${OABI} ]] && has_multilib_profile; then
- use debug && append-flags -O0 -g3
- use debug || append-flags -DNDEBUG=1
-
- einfo "Building multilib ${PN} for ABIs: $(get_install_abis)"
- OABI=${ABI}
- for ABI in $(get_install_abis); do
- export ABI=${ABI}
- src_compile
- done
- ABI=${OABI}
- return
- fi
-
- cd ${S}
-
- if [[ ! -f configure ]]; then
- ./autogen.sh || die "autogen.sh failed"
- fi
-
- mkdir abi-${ABI}
- cd abi-${ABI}
-
- ../configure \
- --prefix="/usr" \
- --host="$(get_abi_CHOST ${ABI})" \
- --libdir="/usr/$(get_libdir)" \
- || die "./configure for ABI ${ABI} failed"
-
- emake || die "make for ABI ${ABI} failed"
-}
-
-src_install() {
- for ABI in $(get_install_abis); do
- make -C abi-${ABI} install DESTDIR="${D}" || die "make install for ABI ${ABI} failed."
- done
-
- dodoc AUTHORS ChangeLog* NEWS README* TODO
-}
-
-# vim:ai:noet:ts=4:nowrap