summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-06-01 08:41:03 +0200
committerUltrabug <ultrabug@gentoo.org>2016-06-01 08:41:03 +0200
commit10547a21006ad786ea3d365764056871d43508d2 (patch)
tree4680224510778e7d7793fea9e38175378a7fcc2b
parentimproved rethinkdb ebuild with enhanced config from bgo overlay (diff)
downloadultrabug-10547a21006ad786ea3d365764056871d43508d2.tar.gz
ultrabug-10547a21006ad786ea3d365764056871d43508d2.tar.bz2
ultrabug-10547a21006ad786ea3d365764056871d43508d2.zip
app-admin/nxlog-ce: new ebuild
-rw-r--r--app-admin/nxlog-ce/Manifest3
-rw-r--r--app-admin/nxlog-ce/files/nxlog.initd45
-rw-r--r--app-admin/nxlog-ce/nxlog-ce-2.8.1248.ebuild69
-rw-r--r--licenses/NXLOG-192
4 files changed, 209 insertions, 0 deletions
diff --git a/app-admin/nxlog-ce/Manifest b/app-admin/nxlog-ce/Manifest
new file mode 100644
index 0000000..ae87ccc
--- /dev/null
+++ b/app-admin/nxlog-ce/Manifest
@@ -0,0 +1,3 @@
+AUX nxlog.initd 858 SHA256 efb4694690f49e0bde016fb99df239d92a050358ac963993bfc8f0bd4d995a06 SHA512 8879a280258e5b8394ec57e0c3079ba4a5248e6b16caeaaec4f6d299a5622690244b9f09fbc48b5bc874a6ef935b5a7c343acd8f10e345a012f2b7a76f259411 WHIRLPOOL fd8972f07b38249646257464e6a1d4c5b747b2c69f38353321429cf154d064a01b6fced7e55876cd9189ac1a044a989cf73af0798b0d711faf828810041341ac
+DIST nxlog-ce-2.8.1248.tar.gz 2552618 SHA256 13c8e41ed7a41cd529822a54c7f7b8f44b7022e6ce870f1161a173a7930d890e SHA512 1cb31421f0a17c09ba5fc187dde8ffbe913bc176eaece7d9f614432ce857f8632c294e12fa8a0f1bfa3eff93d8ea5a4e76b281d67ba624b3bc47dd7775ea65dc WHIRLPOOL e89465ae9b870f78410a2af48e90bc33eafa2be78580365b4c1fa1c9f3d22c24383d0c9c8f41ca9e078521719e02fbf2e90c6070a640e7c8c12be0a503ca6997
+EBUILD nxlog-ce-2.8.1248.ebuild 1544 SHA256 2b7baf5b7f3005c07d8bb0ac1604ca5b7a1942d6c6dab089b5f4057d772bc942 SHA512 7f06c881dd05999e77b25e51e17e4720e3fe5e5ab799812f1c3407bfb7c299f43a91f9c076aeb891c4985279eb0ba951d8a5cbda4557edaf563ed54659b413a4 WHIRLPOOL 8cb64a3f4a7f8678922fb0716efaab3431bbd49e71af287ee1d5f9e230e93a19f96594863dd82fd1a06ecf830ba4fbcb9c1ca9ca143a9845ef998e9130b46941
diff --git a/app-admin/nxlog-ce/files/nxlog.initd b/app-admin/nxlog-ce/files/nxlog.initd
new file mode 100644
index 0000000..33490e3
--- /dev/null
+++ b/app-admin/nxlog-ce/files/nxlog.initd
@@ -0,0 +1,45 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+config_file=${config_file:-/etc/nxlog/${SVCNAME}.conf}
+run_dir=${run_dir:-/run/nxlog}
+
+command="/usr/bin/nxlog"
+command_args="-c ${config_file}"
+pidfile=${run_dir}/${SVCNAME}.pid
+user=${user:-nxlog}
+group=${group:-nxlog}
+
+extra_started_commands="${opts} reload"
+
+depend() {
+ use net
+}
+
+check_config() {
+ ${command} ${command_args} -v >/dev/null
+ return $?
+}
+
+start_pre() {
+ checkpath -d -m 0750 -o "${user}":"${group}" "${run_dir}"
+ if [ ! -f ${config_file} ]; then
+ eerror "Missing configuration file ${config_file}"
+ return 1
+ fi
+ check_config
+ return $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ check_config
+ if [ $? == 0 ]; then
+ ${command} ${command_args} -r
+ eend $?
+ else
+ eend 1
+ fi
+}
diff --git a/app-admin/nxlog-ce/nxlog-ce-2.8.1248.ebuild b/app-admin/nxlog-ce/nxlog-ce-2.8.1248.ebuild
new file mode 100644
index 0000000..46a1d57
--- /dev/null
+++ b/app-admin/nxlog-ce/nxlog-ce-2.8.1248.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools user
+
+MY_PN="nxlog"
+
+DESCRIPTION="Universal log collector and forwarder supporting different platforms"
+HOMEPAGE="http://nxlog.org"
+SRC_URI="http://nxlog.org/system/files/products/files/1/${P}.tar.gz"
+
+LICENSE="NXLOG-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="perl static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup nxlog
+ enewuser nxlog -1 -1 /var/lib/${MY_PN} "adm,nxlog"
+}
+
+# TODO: fix me ?
+# src_prepare() {
+# sed -e 's/.* -ggdb3 .*/echo/g' -i configure.in || die 'failed to remove ggdb3 flag'
+# mv configure.in configure.ac
+# find . -name Makefile.in -exec sed -e 's@/configure.in@/configure.ac@g' -i {} \;
+# eautoreconf
+# eapply_user
+# }
+
+src_configure() {
+ local conf_opts=(
+ --libexecdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)
+ --localstatedir=/var
+ --with-pidfile=/run/nxlog/nxlog.pid
+ $(use_enable perl xm_perl)
+ $(use_enable static-libs static)
+ )
+ econf "${conf_opts[@]}"
+}
+
+src_install() {
+ default
+
+ use static-libs || find ${D} -type f -name "*.la" -delete
+
+ insinto /etc/nxlog
+ doins packaging/debian/nxlog.conf
+
+ keepdir /var/log/nxlog
+ fowners nxlog:nxlog /var/log/nxlog
+
+ keepdir /var/spool/nxlog
+ fowners nxlog:nxlog /var/spool/nxlog
+
+ newinitd "${FILESDIR}/${MY_PN}.initd" ${MY_PN}
+}
+
+pkg_postinst() {
+ einfo "See the nxlog reference manual for configuration options."
+ einfo " http://nxlog.org/nxlog-docs/en/nxlog-reference-manual.html"
+}
diff --git a/licenses/NXLOG-1 b/licenses/NXLOG-1
new file mode 100644
index 0000000..eb0b245
--- /dev/null
+++ b/licenses/NXLOG-1
@@ -0,0 +1,92 @@
+NXLOG PUBLIC LICENSE v1.0
+
+1. DEFINITIONS
+“License” shall mean version 1.0 of the NXLOG PUBLIC LICENSE, i.e. the
+terms and conditions set forth in this document;
+“Software” shall mean the source code and object code form, all associated
+media, printed materials, and "online" or electronic documentation. All
+such software and materials are referred to herein as the "Software" and
+are copyrighted by Licensor;
+“Licensor” refers to the copyright holder of the Software, i.e. nxsec.com.
+
+2. GRANT OF LICENSE
+Licensor hereby grants you the following rights, provided that you comply
+with all of the restrictions set forth in this License and provided,
+further, that you distribute an unmodified copy of this License with the
+Software:
+i. You may copy and distribute verbatim (i.e. unmodified) copies of the
+Software as you receive it, in any medium;
+ii. You may modify the Software, create works based on the Software and
+distribute copies of such, in any medium.
+
+By downloading, using, modifying and copying the Software (or any work
+based on the Software), you indicate your acceptance of this license to
+do so, and all its terms and conditions for using, copying, distributing
+and modifying the Software or works based on it. Nothing other than this
+license grants you permission to modify, distribute the program or its
+derivative works. If you do not accept these terms and conditions, do not
+use, modify or distribute the Software.
+
+3. RESTRICTIONS ON COPYING, DISTRIBUTION AND USE
+The Software may be copied and distributed with or without modifications
+in source code and object code form and may be used for commercial and
+non-commercial purposes provided that the following restrictions are met:
+i. Distribution of the Software is prohibited if any payment is made in
+connection with such distribution. You may only charge a reasonable fee
+to cover the costs of copying and redistribution;
+ii. Bundling the Software with a commercial product or using it to
+provide commercial services is prohibited if your product or service
+explicitly depends on the Software to be able to operate or function.
+You may use the Software without modifications to provide commercial
+services or to bundle it with your product provided that your service or
+product can also operate or function without the Software.
+A commercial license is available if you wish to incorporate the Software
+into your product or service which explicitly depends on the Software to
+be able to operate or function.
+
+4. RESTRICTIONS ON MODIFICATION AND DERIVATIVE WORKS
+The Software may be modified and derivative works may be distributed only
+under the terms of this license with the following restrictions:
+i. Any modifications and enhancements to the Software, including any newly
+developed scripts, libraries, modules that depend on the Software, are
+considered derivative works (“Derivative Work”).
+ii. If you have modified the Software or created Derivative Work, you
+must cause the work to carry prominent notices stating that you have
+modified the Software's files and the date of any change. In each source
+file that you have modified, you must include a prominent notice that you
+have modified the file, including your name, your e-mail address (if
+any), and the date and purpose of the change;
+iii. All Derivative Works must be made public in source code form by
+making it accessible for download over the internet. You must also notify
+Licensor about the Derivative Work in e-mail;
+iv. All Derivative works must be distributed with an unmodified copy of
+this License;
+v. By creating a Derivative Work, you assign all copyrights relating to
+the modifications to Licensor. You acknowledge that Licensor will own all
+copyrights and Licensor may use and distribute the Derivative Work to
+third parties under different terms from that of this License.
+
+5. NO WARRANTIES
+The Software is provided “AS IS” and Licensor makes no warranty as to its
+use, performance, or otherwise. To the maximum extent permitted by
+applicable law, Licensor disclaims all other representations, warranties,
+and conditions, express, implied, statutory, or otherwise, including, but
+not limited to, implied warranties or conditions of merchantability,
+satisfactory quality, fitness for a particular purpose, title, and
+non-infringement. The entire risk arising out of use or performance of
+the Software remains with you.
+
+6. LIMITATION OF LIABILITY
+This limitation of liability is to the maximum extent permitted by
+applicable law. In no event shall Licensor be liable for any costs of
+substitute products or services, or for any special, incidental,
+indirect, or consequential damages whatsoever (including, without
+limitation, damages for loss of business profits, business interruption,
+or loss of business information) arising out of the use or inability to
+use the Software, even if Licensor has been advised of the possibility of
+such damages. In any case, Licensor's entire liability arising out of
+this Agreement shall be limited to the greater of the amount actually
+paid for the Software; provided, however, that if you have entered into a
+Technical Services Support Agreement, Licensor's entire liability
+regarding support services shall be governed by the terms of that
+agreement.