summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2013-12-25 21:20:16 +0100
committerUltrabug <ultrabug@gentoo.org>2013-12-25 21:20:16 +0100
commitb9c7c604983e578ad51bde99e354aee31c79afab (patch)
tree7f70c90c69c9f9789d2f5a9916944ca74189a724
parentdrop obsolete mongodb ebuild (diff)
downloadultrabug-b9c7c604983e578ad51bde99e354aee31c79afab.tar.gz
ultrabug-b9c7c604983e578ad51bde99e354aee31c79afab.tar.bz2
ultrabug-b9c7c604983e578ad51bde99e354aee31c79afab.zip
new dev-util/leapmotion-drivers and dev-util/leapmotion-sdk ebuilds
-rw-r--r--dev-util/leapmotion-drivers/Manifest4
-rw-r--r--dev-util/leapmotion-drivers/files/leapd.initd18
-rw-r--r--dev-util/leapmotion-drivers/leapmotion-drivers-1.0.9_p8411.ebuild49
-rw-r--r--dev-util/leapmotion-drivers/metadata.xml9
-rw-r--r--dev-util/leapmotion-sdk/Manifest3
-rw-r--r--dev-util/leapmotion-sdk/leapmotion-sdk-1.0.9_p8391.ebuild54
-rw-r--r--dev-util/leapmotion-sdk/metadata.xml9
-rw-r--r--licenses/LeapMotionSDK276
8 files changed, 422 insertions, 0 deletions
diff --git a/dev-util/leapmotion-drivers/Manifest b/dev-util/leapmotion-drivers/Manifest
new file mode 100644
index 0000000..f01d791
--- /dev/null
+++ b/dev-util/leapmotion-drivers/Manifest
@@ -0,0 +1,4 @@
+AUX leapd.initd 460 SHA256 218ac81b79bcac2d9c55f3b89735a33506cc6e30d38d4e7eef32e81a81b932fd SHA512 91353b6f74f02f953b857337f71a46a94e1277af1a7424e109488e9a7f77dbd8e9905610f5776eeead381e62dba236357b71c915117cd724a94fcfebccd36651 WHIRLPOOL 41a6b30ea3a79c3a0b933e26bd7005cb92b11048d821d13bf0e1763f77d0eb87f1c13c2a57f05e43cbf09c07b067d679bea33b37c6a6ac0d6d961b7d3458d8e1
+DIST Leap_Packages_1.0.9+8411_Linux.tgz 55932028 SHA256 f9d8f199929bbbbb6d10aeeeb77b17a3f137458d138b7179e2bac749a5e46839 SHA512 5697aff684a170c7ffebedc03367e4cc0bd4574a94fc2235af8d31b153cd2ab2c446dbda4b36fb74a6428b5024b61e0f4548b964975cff05603ee40aa67fd144 WHIRLPOOL 3fb22967dca85dd049e3c524275d2bd33b4b97b2135c07ec462b395f56d85239efdd54d283effe26d77fc63a49346668288356862e2c2f994e8602b748c026f3
+EBUILD leapmotion-drivers-1.0.9_p8411.ebuild 1220 SHA256 e7e92e49c170210a0181938b26b463d54a4fc5b0447bb2149ca94cd9413b2f51 SHA512 4c233239af929fdcd547639bd62160271b3e8a5bb849d492ce801422b3610ff9e75f482ab431b86a9b80ce21af6796d039c2794f16c43f839069465aa46e1552 WHIRLPOOL 16fa191c01dac9c0985222d7ac41908beac95947d88154e0fe2497b135469331f6a5c2d4388bbf216fdbe5adb793b1635ea0440f87799fd04e68dd5d28f94cbe
+MISC metadata.xml 306 SHA256 8c8dc3c2de6f4fa8f77ac9f50c88f1b63ae85b6fd10d4e192eac1e53768b2e4b SHA512 79503469ca409bf7b5050a47574f8a03ae3fd8b95972e42bb5fa4f2a8e54698edf18b123e91f419fe90d8398920362131c4c3931fd298038c681ccc74f0405fc WHIRLPOOL c623a6ab9f0f3a245289e6f8a38f2e8bd2f6faa627b6113caa9207d809ef42e21ba3220e9f14f716f4e3d0afa08de32988c0ef33bab0b2b64a7d3ed19e1b2baf
diff --git a/dev-util/leapmotion-drivers/files/leapd.initd b/dev-util/leapmotion-drivers/files/leapd.initd
new file mode 100644
index 0000000..c1e5bdc
--- /dev/null
+++ b/dev-util/leapmotion-drivers/files/leapd.initd
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+start() {
+ ebegin "Starting leapd"
+ start-stop-daemon --start --exec /opt/Leap/usr/sbin/leapd \
+ --pidfile /var/run/leapd.pid --make-pidfile --background
+ eend $? "Failed to start leapd"
+}
+
+stop() {
+ ebegin "Stopping leapd"
+ start-stop-daemon --stop \
+ --pidfile /var/run/leapd.pid
+ eend $? "Failed to stop leapd"
+}
diff --git a/dev-util/leapmotion-drivers/leapmotion-drivers-1.0.9_p8411.ebuild b/dev-util/leapmotion-drivers/leapmotion-drivers-1.0.9_p8411.ebuild
new file mode 100644
index 0000000..47c10b9
--- /dev/null
+++ b/dev-util/leapmotion-drivers/leapmotion-drivers-1.0.9_p8411.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MY_PYP_N=${PV/_p/.}
+MY_PVP=${PV/_p/+}
+MY_PV=${PV%_p*}
+
+inherit eutils unpacker multilib
+
+DESCRIPTION="LeapMotion runtime and drivers"
+HOMEPAGE="http://www.leapmotion.com/"
+SRC_URI="Leap_Packages_${MY_PVP}_Linux.tgz"
+
+LICENSE="LeapMotionSDK"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Leap_Packages_${MY_PVP}_Linux"
+
+pkg_nofetch() {
+ ewarn "Please visit https://developer.leapmotion.com/downloads and get the linux device drivers package."
+ ewarn "After downloading the package with version ${MY_PVP_N} move it to \"${DISTDIR}/${SRC_URI}\""
+}
+
+src_install() {
+ #NB: we dont need the etc folder
+ unpack_deb "Leap-${MY_PVP}-$(usex amd64 x64 x86).deb"
+ insinto /opt/Leap
+ doins -r usr lib
+
+ cd usr/bin
+ local i
+ for i in *; do
+ make_wrapper "$i" "/opt/Leap/usr/bin/$i" . "/opt/Leap/lib:/opt/Leap/usr/lib/Leap"
+ fperms +x "/opt/Leap/usr/bin/$i"
+ done
+
+ dosym /opt/Leap/lib/udev/rules.d/25-com-leapmotion-leap.rules /lib/udev/rules.d/25-com-leapmotion-leap.rules
+
+ fperms +x "/opt/Leap/usr/sbin/leapd"
+ newinitd "${FILESDIR}"/leapd.initd leapd
+}
diff --git a/dev-util/leapmotion-drivers/metadata.xml b/dev-util/leapmotion-drivers/metadata.xml
new file mode 100644
index 0000000..8b0bec6
--- /dev/null
+++ b/dev-util/leapmotion-drivers/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Ultrabug</name>
+ </maintainer>
+ <longdescription lang="en">LeapMotion runtime and drivers</longdescription>
+</pkgmetadata>
diff --git a/dev-util/leapmotion-sdk/Manifest b/dev-util/leapmotion-sdk/Manifest
new file mode 100644
index 0000000..92baadd
--- /dev/null
+++ b/dev-util/leapmotion-sdk/Manifest
@@ -0,0 +1,3 @@
+DIST LeapDeveloperKit_release_linux_1.0.9+8391.tgz 43913037 SHA256 7dbe72c532de5eade3e9c4dd2b22185fd4ea5fe303f64e186a476bf896e76412 SHA512 20c9df7c36efcbe37a035714a50845c9c89732b358e000155d2ce3e7dead0bfb5a096c9ba4135ff0ff4107a82d3359aa37ac7aa091fb1bf050b06f0675b87208 WHIRLPOOL cb1ccb0c45bce1ff00d11c709460436cfe866ad45cacad2f9f2211a59e01b7d9d2e93514f379becc98b9f8bd3a6d58c43d6cf895623416df9bb6adffdf111c0c
+EBUILD leapmotion-sdk-1.0.9_p8391.ebuild 1380 SHA256 c3ea26cd2d54da40377a23b5a317b0d50ec691746e57e251feffbe9e1b2909cc SHA512 52d353ebdd641c8e8cce5b565d3225607627ef1952eac88585a95dd9bfb1907dee0ae652cae97b3ec3063d49176f242447d46d1efd3de8980bc870f2ab3bbc99 WHIRLPOOL 2e2dda5aab442b573dfe39a60b70a7ea2bf5917b222f71e2cce3c03990f412d82d454b479f8ae32ed31d1b2d1fcd73c3e295431d91531221d109ebc774ececbf
+MISC metadata.xml 303 SHA256 22cd31bea6ac4d1d65dfaba3ad36dca34a9dda54dd6fca91556d01781a5a18b9 SHA512 2a259b2c283bf80531573d9aff3e6695f559c2c45818a1c96f075014126424c03f144da8ee95ead75fc798c74a1646089ca3fbdb861381018f1bddb8059275b3 WHIRLPOOL 227efb612965f84c1992b96530c905fa4e008f512cb751201c401c5ba42fb9534ab52415dcdc7076b2509c2399a203ecd221732f755e34e0fddde3fc943690d1
diff --git a/dev-util/leapmotion-sdk/leapmotion-sdk-1.0.9_p8391.ebuild b/dev-util/leapmotion-sdk/leapmotion-sdk-1.0.9_p8391.ebuild
new file mode 100644
index 0000000..ca80aee
--- /dev/null
+++ b/dev-util/leapmotion-sdk/leapmotion-sdk-1.0.9_p8391.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MY_PYP_N=${PV/_p/.}
+MY_PVP=${PV/_p/+}
+MY_PV=${PV%_p*}
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-r1
+
+DESCRIPTION="LeapMotion DeveloperKit SDK"
+HOMEPAGE="http://www.leapmotion.com/"
+SRC_URI="LeapDeveloperKit_release_linux_${MY_PVP}.tgz"
+
+LICENSE="LeapMotionSDK"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="doc examples"
+
+RESTRICT="fetch"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/LeapDeveloperKit"
+
+pkg_nofetch() {
+ ewarn "Please visit https://developer.leapmotion.com/downloads and get the linux SDK package."
+ ewarn "After downloading the package with version ${MY_PVP_N} move it to \"${DISTDIR}/${SRC_URI}\""
+}
+
+src_install() {
+ local libdir=$(get_libdir)
+
+ rm LeapSDK/lib/*.dll
+
+ insinto /opt/Leap
+ use examples && doins -r Examples
+ use doc || rm -rf LeapSDK/docs
+ doins -r LeapSDK
+
+ dosym /opt/Leap/LeapSDK/include /usr/include/Leap
+ dosym /opt/Leap/LeapSDK/lib/x64 "/usr/${libdir}/Leap"
+
+ if use amd64; then
+ dosym /opt/Leap/LeapSDK/lib/x86 "/usr/$(ABI=x86 get_libdir)/Leap"
+ python_foreach_impl python_domodule LeapSDK/lib/x64/LeapPython.so LeapSDK/lib/x64/libLeap.so
+ else
+ python_foreach_impl python_domodule LeapSDK/lib/x86/LeapPython.so LeapSDK/lib/x86/libLeap.so
+ fi
+ python_foreach_impl python_domodule LeapSDK/lib/Leap.py
+}
diff --git a/dev-util/leapmotion-sdk/metadata.xml b/dev-util/leapmotion-sdk/metadata.xml
new file mode 100644
index 0000000..3951e5b
--- /dev/null
+++ b/dev-util/leapmotion-sdk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Ultrabug</name>
+ </maintainer>
+ <longdescription lang="en">LeapMotion DeveloperKit SDK</longdescription>
+</pkgmetadata>
diff --git a/licenses/LeapMotionSDK b/licenses/LeapMotionSDK
new file mode 100644
index 0000000..5a0f3c0
--- /dev/null
+++ b/licenses/LeapMotionSDK
@@ -0,0 +1,276 @@
+LEAP MOTION SDK AGREEMENT
+
+ This Leap Motion SDK Agreement ("Agreement") is between the individual or entity ("you" or "Developer") that accepts it, and Leap Motion, Inc. You
+accept this Agreement by clicking the box displayed at the end of this Agreement, if you are reading this on a Leap Motion website, or by clicking an
+"agree" or similar button, where this option is provided by Leap Motion. Your agreement to these terms also binds your authorized users, your company
+or organization. If you do not agree to the terms of this Agreement, do not accept it. Before accepting this Agreement, please carefully read it.
+
+Last updated: August 20, 2013
+
+Purpose
+
+
+ Thank you for joining our worldwide community of Leap Motion developers!
+
+ This Agreement sets out the terms and conditions under which we are making our SDK available to you, and under which you may distribute Applications
+(as defined below). If you wish to submit your Applications for distribution through Airspace, the Leap Motion app store, the submission and
+distribution is subject to the terms and conditions of the Airspace Developer Distribution Agreement, and related Application review and other
+guidelines, available at https://developer.leapmotion.com/apps/guidelines.
+
+ You may also develop and test Specialized Applications (as defined below) under this Agreement. However, this Agreement does not grant you rights to
+distribute Specialized Applications. If you would like to distribute Specialized Applications, either independently or through Airspace, you may not
+do so under this Agreement, and must contact Leap Motion's business development team at bizdev@leapmotion.com.
+
+ Please read the complete terms and conditions below carefully, because the terms and conditions are binding on you and Leap Motion, and the summary
+above is qualified by them.
+1. Definitions.
+
+ Whenever capitalized in this Agreement:
+
+ "Airspace" means the Leap Motion website that allows for the discovery, download and purchase of Applications by end users.
+
+"Application" means a software application developed by you for use with the Leap Motion Controller (or a Leap Motion-authorized embedded optical
+module) and interaction with the Leap Middleware, including updates, upgrades, modifications, enhancements, revisions, new releases and new versions
+of such software application.
+
+ "Authorized Users" means your employees and contractors, members of your organization or, if you are an educational institution, your faculty, staff
+and registered students, who (a) have a demonstrable need to know or use the SDK in order to develop and test Applications on your behalf and (b)
+each have written and binding agreements with you to protect against the unauthorized use and disclosure of the SDK consistent with the terms and
+conditions of this Agreement. Authorized Users do not include End Users.
+
+ "Confidential Information" means the SDK, and all technology, know-how, algorithms, testing procedures, software, structure, interfaces,
+specifications, reports, analysis and other technical information learned, accessed or derived by you or your Authorized Users pursuant to this
+Agreement or pursuant to use by you or your Authorized Users of the SDK. Confidential Information does not include information that (i) has become
+generally publicly known without any improper action or inaction; (ii) was in the rightful possession of you or your Authorized Users without any
+obligation of confidentiality to any parties before having access to the SDK; (iii) was rightfully disclosed to you by a third party without
+restriction on disclosure; (iv) is independently developed by you without use of the Confidential Information as shown by contemporaneous
+documentation; or (v) is disclosed if required by law or court order (but only to the extent of such disclosure), provided that you will make
+reasonable efforts to give Leap Motion prior notice of the law or court order and cooperate with any attempts to obtain a protective order or similar
+treatment.
+
+ "End User" means your end user customer(s) or licensee(s).
+
+ "Leap Middleware" means the Leap Motion application that interacts with the Leap Motion Controller (or a Leap Motion-authorized embedded optical
+module) and an operating system to make motion control functionality available to Applications through a specified interface, and includes any
+Updates thereto.
+
+ "Leap Motion" "we" or "us" means Leap Motion, Inc., a Delaware corporation with a principal place of business at 333 Bryant Street, Suite LL150, San
+Francisco, California, 94107.
+
+ "Leap Motion Controller" means the Leap Motion USB peripheral device that detects and reads movements within a 3-D interaction space to precisely
+interact with and control software on a computing device.
+
+ "Leap Motion Redistributables" means any .lib code, .dll files, .so files, sample code, or other materials we specifically designate in the SDK as
+made available for incorporation into or distribution with Applications.
+
+ "Non-Redistributable Materials" means the documentation in the SDK, the Leap Middleware, and any other code, files or materials that are not
+specifically designated in the SDK as made available for incorporation into Applications or that are specifically designated in the SDK as not
+subject to distribution.
+
+ "SDK" means, collectively, the system files, Leap Motion Redistributables, tools, APIs, sample code, software documentation, other materials and any
+updates to the foregoing that may be provided or made available to you by Leap Motion in connection with this Agreement, via the Leap Motion
+developer portal or otherwise for use in connection with the Leap Motion development program to develop Applications.
+
+ "Specialized Application" means an Application which is: (i) sold, licensed, leased, or otherwise disposed of for a list price of more than US$500
+or local equivalent, or more than US$240 per year or local equivalent if on a subscription, lease or similar basis; (ii) sold, licensed, leased or
+otherwise disposed of as part of, or for use with, another application, system, machine or device (other than a personal computer), having a list
+price of more than US$500 or local equivalent, or more than US$240 per year or local equivalent if on a subscription, lease or similar basis; (iii)
+designed for use, or that is primarily used, with or for control, whether direct or indirect, of industrial, commercial, military or medical
+equipment.
+
+ "Updates" means updates, upgrades, modifications, enhancements, revisions, new releases or new versions to the SDK that Leap Motion may make
+available to you in connection with this Agreement.
+
+ Other capitalized terms used in this Agreement have the meaning given them elsewhere in this Agreement.
+
+2. Development License and Restrictions
+2.1. Development License. Conditioned upon compliance with the terms and conditions of this Agreement, Leap Motion hereby grants you and your
+Authorized Users a limited, non-exclusive, personal, revocable, non-sublicensable and non-transferable license to:
+2.1.1. Install a reasonable number of copies of the software in the SDK on computers owned or controlled by you, and to use the SDK solely
+internally by you or your Authorized Users and solely for the purpose of developing and testing one or more Applications.
+2.1.2. Make and distribute a reasonable number of copies of the documentation in the SDK to Authorized Users solely for use in the development and
+testing of your Application.
+2.1.3. Incorporate into your Application without modification the Leap Motion Redistributables other than sample code.
+2.1.4. Modify and incorporate into your Application any sample code provided in the SDK.
+2.2. Restrictions. The license granted to you in Section 2.1 is subject to the following restrictions, as well as others listed in this Agreement:
+2.2.1. You may not, directly or indirectly, publish, make available over a network, post or otherwise make available the SDK or any portion of the
+SDK to any person or entity other than your Authorized Users, or copy the SDK, in either case except as expressly permitted in Section 2.1.
+2.2.2. You may not modify, translate, or create derivative works of the SDK or any portion of it, except as expressly permitted in Section 2.1.
+2.2.3. You may not lend, lease, offer for sale, sell, or distribute the SDK or any portion of the SDK, except as expressly permitted in Section 2.1.
+2.2.4. You may not, and may not enable others to, reverse engineer, decompile, disassemble or otherwise attempt to reconstruct, identify or discover
+any source code, underlying ideas, techniques, or algorithms in the Leap Middleware, the Leap Motion Controller or any software that forms part of
+the SDK, nor attempt to circumvent any related security measures (except as and only to the extent any foregoing restriction is prohibited by
+applicable law or permitted by applicable law notwithstanding the foregoing restriction, or to the extent as may be permitted by licensing terms
+governing use of any open source software components or sample code included within the SDK).
+2.2.5. Unless otherwise provided in an agreement between you and Leap Motion, you may not use "Leap Motion", "Leap", "Airspace" or any other
+trademark of Leap Motion in connection with your Application or company, or in any URL, product, service, name field or logos created by you.
+However, you may indicate that your Application is "for Leap Motion" or "Leap Motion-enabled".
+2.2.6. You may not remove, obscure, or alter any proprietary rights or confidentiality notices affixed to or contained within the SDK or any
+software, documentation or other materials in it or supplied with it.
+2.2.7. You may not create Applications or other software that prevent or degrade the interaction of Applications developed by others with the Leap
+Middleware, and you may not establish or make available any market or app store whose primary purpose is to facilitate the distribution of
+Applications developed by others.
+2.3. Updates. The terms of this Agreement will apply to any Updates that Leap Motion makes available to you. You agree that Updates may require you
+to change or update your Application, and may affect your ability to use, access or interact with the Leap Middleware and/or the SDK.
+3. Distribution License and Restrictions
+3.1. Distribution License. Conditioned upon compliance with the terms and conditions of this Agreement, Leap Motion hereby grants you a limited,
+non-exclusive, personal, revocable, non-transferable license under Leap Motion's applicable intellectual property rights to the extent necessary to:
+(a) copy and distribute (or have copied and distributed) the Leap Motion Redistributables, solely as compiled with, incorporated into, or packaged
+with, your Application (provided it is not a Specialized Application); and (b) to make (but not have made), use, sell, offer for sale and import your
+Application (provided it is not a Specialized Application).
+3.2. Restrictions. The license granted to you in Section 3.1 is subject to the following restrictions, as well as others listed in this Agreement:
+3.2.1. Your Application may not be a Specialized Application or for a High Risk Use (as defined in Section 4.1.).
+3.2.2. You may not, directly or indirectly, publish, post or otherwise make available the Leap Motion Redistributables other than as compiled with,
+incorporated into, or packaged with, your Application.
+3.2.3. Your Application may not contain malware or malicious or harmful code or other harmful components (e.g., a software virus); or damage,
+corrupt, degrade, destroy or otherwise adversely affect the security of Leap Middleware, or any other software, firmware, hardware, data, systems, or
+networks accessed or used by your Application.
+3.2.4. You may not, and may not enable others to, distribute the Non-Redistributable Materials.
+4. No High Risk Use; Acknowledgment and Waiver
+4.1. Notwithstanding anything in this Agreement, you are not licensed to, and you agree not to, use, copy, sell, offer for sale, or distribute the
+SDK, Leap Motion Controllers, Leap Middleware or Leap Motion Redistributables (whether compiled with, incorporated into, or packaged with your
+Application or otherwise), for or in connection with uses where failure or fault of the Leap Motion Controller, Leap Middleware, Leap Motion
+Redistributables or your Application could lead to death or serious bodily injury of any person, or to severe physical or environmental damage ("High
+Risk Use"). ANY SUCH USE IS STRICTLY PROHIBITED.
+4.2. You acknowledge the SDK may allow you to develop Applications that enable the control of motorized or mechanical equipment, or other systems,
+machines or devices. If you elect to use the SDK in such a way, you must take steps to design and test your Applications to ensure that your
+Applications do not present risks of personal injury or death, property damage, or other losses. The Leap Motion Controller, the Leap Middleware, the
+Leap Motion Redistributables and other software in the SDK may not always function as intended. You must design your Applications so that any failure
+of a Leap Motion Controller, the Leap Middleware, a Leap Motion Redistributable and/or such other software does not cause personal injury or death,
+property damage, or other losses. If you choose to use the SDK, (i) you assume all risk that use of the Leap Motion Controller, the Leap Middleware,
+the Leap Motion Redistributables and/or such other software by you or by any others causes any harm or loss, including to the end users of your
+Applications or to third parties, (ii) you hereby waive, on behalf of yourself and your Authorized Users, all claims against Leap Motion and its
+affiliates related to such use, harm or loss (including, but not limited to, any claim that a Leap Motion Controller, the Leap Middleware, a Leap
+Motion Redistributable or such other software is defective), and (iii) you agree to hold Leap Motion and its affiliates harmless from such claims.
+5. Confidentiality, Privacy and Publicity
+5.1. Your Confidentiality Obligations. You agree to keep the SDK confidential. You also acknowledge and agree that you may learn Confidential
+Information of Leap Motion in connection with this Agreement or your use of the SDK. You agree not to disclose the Confidential Information to
+others, other than your Authorized Users as permitted under this Agreement, without the prior written consent of Leap Motion, to hold the
+Confidential Information in confidence using at least the same degree of care you use to protect your own Confidential Information of like nature and
+importance, but no less than a reasonable degree of care, and not to use the Confidential Information for any purpose other than those expressly
+permitted by this Agreement. Only your Authorized Users who have a need to know solely to test and develop your Application may be given access to
+Confidential Information, and you are liable for any unauthorized use or disclosure by any of them. You will immediately notify Leap Motion if you
+discover any unauthorized use or disclosure of any Confidential Information and will cooperate with Leap Motion to remedy the unauthorized use or
+disclosure.
+5.2. Leap Motion Use of Assets. Subject to the terms and conditions of this Agreement, you grant to Leap Motion and its affiliates a non-exclusive,
+worldwide and royalty-free limited license to use, reproduce, display, perform, publish and distribute screenshots, elements, assets, photographic,
+graphic or video reproductions or fragments of your Application in any medium or media, solely for purposes of promotion of your Application or of
+Leap Motion and its technology and business. This license will terminate if we terminate this Agreement, or, if you terminate it, if you inform us
+you have terminated it, except that in both cases the license will continue after termination with respect to any materials we created and first
+distributed prior to our termination or your notice of termination to us.
+5.3. Your Information. Leap Motion may collect personal information provided by you or your Authorized Users to Leap Motion in connection with the
+SDK, and may collect other information from you or your Authorized Users, including technical, non-personally identifiable and/or aggregated
+information such as usage statistics, hardware configuration, problem / fault data, IP addresses, version number of the SDK, information about which
+tools and/or services in the SDK are being used and how they are being used, and any other information described in Leap Motion's privacy policy,
+currently available at https://www.leapmotion.com/legal. Leap Motion may use the information collected to facilitate the provision of Updates and
+other services to you, to verify compliance with, and enforce, the terms of this Agreement, to improve the SDK and Leap Motion's products, and for
+any other purposes set out in Leap Motion's privacy policy (these uses, collectively, are "Permitted Uses"). By submitting information about you
+and/or your Authorized Users to Leap Motion through your access and use of the SDK, you consent to Leap Motion's collection and use of the
+information for the Permitted Uses and represent that you have obtained all consents and permits necessary under applicable law to disclose your
+Authorized Users' information to Leap Motion for the Permitted Uses. You further agree that Leap Motion may provide any information collected under
+this Section 5.4, including your or your Authorized Users' user name, IP address or other identifying information to law enforcement authorities or
+as required by applicable law or regulation.
+6. Ownership and Feedback
+6.1. Ownership. Except for the license rights granted by you in Section 5.2, and Leap Motion's ownership of the Leap Middleware and the Leap Motion
+Redistributables, Leap Motion agrees that it obtains no right, title or interest from you (or your licensors) under this Agreement in or to any of
+your Applications, including any intellectual property rights which subsist in those Applications. As between Leap Motion and you, Leap Motion owns
+all right, title and interest, including all intellectual property rights, in and to the SDK, including any related Confidential Information, the
+Leap Middleware and the Leap Motion Redistributables, other than any third party software or materials incorporated in the SDK, and you agree not to
+contest Leap Motion's ownership of any of the foregoing.
+6.2. Feedback. You may (but are not required to) provide feedback, comments and suggestions (collectively, "Feedback") to Leap Motion. You hereby
+grant to Leap Motion a non-exclusive, perpetual, irrevocable, paid-up, transferable, sub-licensable, worldwide license under all intellectual
+property rights covering such Feedback to use, disclose and exploit all such Feedback for any purpose.
+7. Your Obligations and Warranties
+
+ In addition to your other obligations under this Agreement, you warrant and agree that:
+7.1. You are at least 18 years of age and have the right and authority to enter into this Agreement on your own behalf and that of your Authorized
+Users, or if you are entering into this Agreement on behalf of your company or organization, you have the right and authority to legally bind your
+company or organization and its Authorized Users.
+7.2. You will use the SDK only in accordance with all accompanying documentation, in the manner expressly permitted by this Agreement, and your use
+of the SDK, and the marketing, sales and distribution of your Application, will be in compliance with all applicable laws and regulations and all
+U.S. and local or foreign export and re-export restrictions applicable to the technology and documentation provided under this Agreement (including
+privacy and data security laws and regulations), and you will not develop any Application which would commit or facilitate the commission of a crime,
+or other tortious, unlawful, or illegal act.
+7.3. You will not engage in any activity in connection with the SDK, including but not limited to the development or distribution of an Application,
+that interferes with, disrupts, damages, or accesses in an unauthorized manner the servers, networks, systems or other properties or services of any
+person or entity, including but not limited to Leap Motion.
+8. Agreement and Development Program We reserve the right to change this Agreement, the SDK or the Leap Motion development and licensing program at
+any time in our discretion. Leap Motion may require that you either accept and agree to the new terms of this Agreement, or, if you do not agree to
+the new terms, cease or terminate your use of the SDK. Your continued use of the SDK after changes to this Agreement take effect will constitute your
+acceptance of the changes. If you do not agree to a change, you must stop using the SDK and terminate this Agreement. Any termination of this
+Agreement by you under this Section 8 (and only this Section 8) will not affect your right, subject to your continued compliance with your
+obligations under this Agreement, to continue to distribute versions of your Application created and first distributed before termination, and will
+not affect the right of your End Users to continue using such versions of your Application, both of which rights will survive termination.
+9. Term and Termination
+9.1. Term. This Agreement will continue to apply until terminated by either you or Leap Motion as set out below.
+9.2. Termination by You. If you want to terminate this Agreement, you may terminate it by uninstalling and destroying all copies of the SDK that are
+in the possession, custody or control of you, your Authorized Users and your organization, and by ceasing distribution of your Application.
+9.3. Termination by Leap Motion. Leap Motion may at any time, terminate this Agreement with you for any reason or for no reason in Leap Motion's
+sole discretion, including as a result of non-compliance by you with the restrictions in Section 2.2 or Section 3.2, or for other reasons, such as,
+for example, for one or more of the following reasons:
+9.3.1. Leap Motion has reason to believe any information or document provided by you to Leap Motion for the purpose of verifying your identity is
+false, inaccurate, or was provided by an unauthorized party.
+9.3.2. Leap Motion is required by law, regulation or other governmental or court order to take such action.
+9.3.3. You breach any term or condition of this Agreement.
+9.3.4. You cease being an authorized developer.
+9.3.5. Leap Motion decides to no longer provide the SDK.
+9.4. Effect of Termination. Upon termination of this Agreement, all rights granted to you under this Agreement will immediately terminate and you
+must immediately cease all use and destroy all copies of the SDK and erase and destroy all copies of Leap Motion’s Confidential Information in your
+and your Authorized Users’ possession, custody or control, and, except as specifically set out in Section 8, cease your distribution of Applications.
+Sections 1, 2.2, 3.2, 4, 5.1, 5.2, 6, 9.4, and 10 - 13 will survive termination of this Agreement.
+10. Indemnification. You agree to indemnify, hold harmless and, at Leap Motion's option, defend Leap Motion and its affiliates and their respective
+officers, directors, employees, agents, and representatives harmless from any and all judgments, awards, settlements, liabilities, damages, costs,
+penalties, fines and other expenses (including court costs and reasonable attorneys' fees) incurred by them arising out of or relating to any third
+party claim (a) with respect to your Application, including products liability, privacy, or intellectual property infringement claims, or (b) based
+upon your negligence or willful misconduct or any breach or alleged breach of your representations, warranties, and covenants under this Agreement.
+In no event may you enter into any settlement or like agreement with a third party that affects Leap Motion rights or binds Leap Motion in any way,
+without the prior written consent of Leap Motion.
+11. Warranty Disclaimer. THE SDK, THE LEAP MIDDLEWARE AND THE LEAP MOTION REDISTRIBUTABLES ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. LEAP
+MOTION, ON BEHALF OF ITSELF AND ITS SUPPLIERS, HEREBY DISCLAIMS ALL REPRESENTATIONS, PROMISES, OR WARRANTIES, WHETHER EXPRESS, IMPLIED, STATUTORY, OR
+OTHERWISE, WITH RESPECT TO THE SDK, THE LEAP MIDDLEWARE AND THE LEAP MOTION REDISTRIBUTABLES, INCLUDING THEIR CONDITION, AVAILABILITY, OR THE
+EXISTENCE OF ANY LATENT DEFECTS, AND LEAP MOTION SPECIFICALLY DISCLAIMS ALL IMPLIED WARRANTIES OF MERCHANTABILITY, TITLE, NONINFRINGEMENT,
+SUITABILITY, AND FITNESS FOR ANY PURPOSE. LEAP MOTION DOES NOT WARRANT THAT THE SDK, THE LEAP MIDDLEWARE OR THE LEAP MOTION REDISTRIBUTABLES WILL BE
+ERROR-FREE OR THAT THEY WILL WORK WITHOUT INTERRUPTION.
+12. Limitation of Liability. IN NO EVENT WILL LEAP MOTION'S LIABILITY, OR THOSE OF ITS SUPPLIERS, ARISING OUT OF OR RELATED TO THIS AGREEMENT OR TO
+THE SDK EXCEED ONE THOUSAND DOLLARS. EXCEPT FOR INDEMNIFICATION OBLIGATIONS, A BREACH OF THE LICENSE RESTRICTIONS OR CONFIDENTIALITY OBLIGATIONS, IN
+NO EVENT WILL EITHER PARTY HAVE ANY LIABILITY FOR ANY INDIRECT, INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES, HOWEVER CAUSED AND BASED ON ANY THEORY
+OF LIABILITY, WHETHER FOR BREACH OF CONTRACT, TORT (INCLUDING NEGLIGENCE) OR OTHERWISE, ARISING OUT OF OR RELATED TO THIS AGREEMENT, INCLUDING BUT
+NOT LIMITED TO LOSS OF ANTICIPATED PROFITS OR BUSINESS INTERRUPTION, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THESE LIMITATIONS WILL APPLY
+NOTWITHSTANDING ANY FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. THE PARTIES AGREE THAT THE FOREGOING LIMITATIONS REPRESENT A REASONABLE
+ALLOCATION OF RISK UNDER THIS AGREEMENT.
+13. Miscellaneous.
+13.1. Assignment. You may not assign this Agreement without the prior written consent of Leap Motion. Any assignment without such consent is void and
+of no effect. Leap Motion may assign this Agreement without your consent in connection with (1) a merger or consolidation of Leap Motion, (2) a sale
+or assignment of substantially all its assets, or (3) any other transaction which results in another entity or person owning substantially all of the
+assets of Leap Motion. In the event of a permitted assignment, this Agreement will inure to the benefit of and be binding upon the parties and their
+respective successors and permitted assigns.
+13.2. Waiver; Severability. The failure of the other party to enforce any rights under this Agreement will not be deemed a waiver of any rights. The
+rights and remedies of the parties in this Agreement are not exclusive and are in addition to any other rights and remedies provided by law. If any
+provision of this Agreement is held by a court of competent jurisdiction to be contrary to law, the remaining provisions of this Agreement will
+remain in full force and effect.
+13.3. Reservation. All licenses not expressly granted in this Agreement are reserved and no other licenses, immunity or rights, express or implied,
+are granted by Leap Motion, by implication, estoppel, or otherwise. The software in the SDK is licensed, not sold.
+13.4. Export Restrictions. The software is subject to United States export laws and regulations. You must comply with all domestic and international
+export laws and regulations that apply to the software. These laws include restrictions on destinations, end users, and end use.
+13.5. Governing Law and Jurisdiction This Agreement will be exclusively governed by and construed under the laws of the State of California, without
+reference to or application of rules governing choice of laws. All disputes arising out of or related to this Agreement will be subject to the
+exclusive jurisdiction of the state and federal courts located in San Francisco, California and you hereby consent to such jurisdiction. However,
+Leap Motion may apply to any court or tribunal worldwide, including but not limited to those having jurisdiction over you or your Authorized Users,
+to seek injunctive relief.
+13.6. Relationship of the Parties. This Agreement does not create any agency, partnership, or joint venture relationship between Leap Motion and
+you. This Agreement is for the sole benefit of Leap Motion and you (and indemnified parties), and no other persons will have any right or remedy
+under this Agreement.
+13.7. Notice. The address for notice to Leap Motion under this Agreement is:
+
+
+ Leap Motion, Inc.
+ 333 Bryant Street, Suite LL150
+ San Francisco CA 94107
+ Attention: Director of Developer Relations
+ Copy: General Counsel
+
+ Leap Motion may provide you notice under this Agreement by email or other electronic communication or by posting communications to its development
+community on the Leap Motion developer portal. You consent to receive such notices in any of the foregoing manners and agree that any such notices by
+Leap Motion will satisfy any legal communication requirements.
+13.8. Entire Agreement. This Agreement is the entire understanding of the parties with respect to its subject matter and supersedes any previous or
+contemporaneous communications, whether oral or written with respect to such subject matter.