summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2020-01-06 18:42:54 +0100
committerUltrabug <ultrabug@gentoo.org>2020-01-06 18:42:54 +0100
commit20d967e858a885418cd3f7138cc13686db503c05 (patch)
treec5dfe63708b0102573eb31801653e0f3e277b801 /dev-db/scylla/scylla-3.1.2.ebuild
parentdev-db/scylla: fix unable to set SCHED_FIFO scheduling (diff)
downloadultrabug-20d967e858a885418cd3f7138cc13686db503c05.tar.gz
ultrabug-20d967e858a885418cd3f7138cc13686db503c05.tar.bz2
ultrabug-20d967e858a885418cd3f7138cc13686db503c05.zip
dev-db/scylla: filter -fomit-frame-pointer
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Manifest-Sign-Key: 34FCB257983BA23A8CEC5EB7EB9E6405C24BFAE5 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'dev-db/scylla/scylla-3.1.2.ebuild')
-rw-r--r--dev-db/scylla/scylla-3.1.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-db/scylla/scylla-3.1.2.ebuild b/dev-db/scylla/scylla-3.1.2.ebuild
index ba9ceaf..86aa597 100644
--- a/dev-db/scylla/scylla-3.1.2.ebuild
+++ b/dev-db/scylla/scylla-3.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -150,7 +150,8 @@ src_configure() {
# native CPU CFLAGS are strongly enforced by upstreams, respect that
replace-cpu-flags "*" "native"
- append-cflags "-Wno-attributes -Wno-array-bounds"
+ filter-flags -fomit-frame-pointer
+ append-cflags -Wno-attributes -Wno-array-bounds
${EPYTHON} configure.py --enable-gcc6-concepts --mode=release --with=scylla --disable-xen --c-compiler "$(tc-getCC)" --compiler "$(tc-getCXX)" --ldflags "${LDFLAGS}" --cflags "${CFLAGS}" --python ${EPYTHON} --with-antlr3 /usr/bin/antlr3.5 || die
}