summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2020-01-07 13:18:58 +0100
committerUltrabug <ultrabug@gentoo.org>2020-01-07 13:18:58 +0100
commit2b1300595c76dce35c69d6734538d95a7532252e (patch)
tree94b45c48d326de4fa2aa5c66a8eb7786a7e6c2a7 /dev-db/scylla/scylla-3.1.2.ebuild
parentdev-db/scylla: filter -fomit-frame-pointer (diff)
downloadultrabug-2b1300595c76dce35c69d6734538d95a7532252e.tar.gz
ultrabug-2b1300595c76dce35c69d6734538d95a7532252e.tar.bz2
ultrabug-2b1300595c76dce35c69d6734538d95a7532252e.zip
dev-db/scylla: drop fcaps and obsolete cflags, add -g
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Manifest-Sign-Key: 34FCB257983BA23A8CEC5EB7EB9E6405C24BFAE5 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'dev-db/scylla/scylla-3.1.2.ebuild')
-rw-r--r--dev-db/scylla/scylla-3.1.2.ebuild22
1 files changed, 3 insertions, 19 deletions
diff --git a/dev-db/scylla/scylla-3.1.2.ebuild b/dev-db/scylla/scylla-3.1.2.ebuild
index 86aa597..b119924 100644
--- a/dev-db/scylla/scylla-3.1.2.ebuild
+++ b/dev-db/scylla/scylla-3.1.2.ebuild
@@ -11,7 +11,7 @@ inherit git-r3
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit autotools fcaps flag-o-matic linux-info python-r1 toolchain-funcs systemd user
+inherit autotools flag-o-matic linux-info python-r1 toolchain-funcs systemd user
DESCRIPTION="NoSQL data store using the seastar framework, compatible with Apache Cassandra"
HOMEPAGE="http://scylladb.com/"
@@ -86,9 +86,6 @@ ERROR_TRANSPARENT_HUGEPAGE="${PN} recommends support for Transparent Hugepage (T
# ERROR_VFIO="${PN} running with DPDK recommends support for Non-Privileged userspace driver framework (VFIO)."
DOCS=( LICENSE.AGPL NOTICE.txt ORIGIN README.md README-DPDK.md )
-FILECAPS=(
- cap_sys_nice /usr/bin/scylla
-)
PATCHES=(
"${FILESDIR}/fix-fmt-3.5.0-compilation.patch"
"${FILESDIR}/3.1-thrift-support.patch"
@@ -137,21 +134,8 @@ src_prepare() {
src_configure() {
python_setup
- # copied from dist/redhat/scylla.spec.mustache
- # we want a package compiled with old kernel headers to
- # support nowait aio if the user upgrades their kernel
- if ! grep -qwr RWF_NOWAIT /usr/include/linux; then
- append-cflags "-DRWF_NOWAIT=8"
- fi
- if ! grep -qwr aio_rw_flags /usr/include/linux; then
- append-cflags "-Daio_rw_flags=aio_reserved1"
- fi
-
- # native CPU CFLAGS are strongly enforced by upstreams, respect that
- replace-cpu-flags "*" "native"
-
- filter-flags -fomit-frame-pointer
- append-cflags -Wno-attributes -Wno-array-bounds
+ # needed for blocked reactors logging as it disables -fomit-frame-pointers
+ append-cflags -g
${EPYTHON} configure.py --enable-gcc6-concepts --mode=release --with=scylla --disable-xen --c-compiler "$(tc-getCC)" --compiler "$(tc-getCXX)" --ldflags "${LDFLAGS}" --cflags "${CFLAGS}" --python ${EPYTHON} --with-antlr3 /usr/bin/antlr3.5 || die
}