summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2017-06-01 18:20:06 +0200
committerUltrabug <ultrabug@gentoo.org>2017-06-01 18:20:06 +0200
commit080e31bccdd16bc5a58480aebd82416804be53a5 (patch)
tree5daeb726d22693196213ad3bcdfa3f55eaaee852 /dev-db/scylla/scylla-9999.ebuild
parentscylla: add python_usedep on python dependencies (diff)
downloadultrabug-080e31bccdd16bc5a58480aebd82416804be53a5.tar.gz
ultrabug-080e31bccdd16bc5a58480aebd82416804be53a5.tar.bz2
ultrabug-080e31bccdd16bc5a58480aebd82416804be53a5.zip
scylla: update kernel conf and remove useless irqbalance
Diffstat (limited to 'dev-db/scylla/scylla-9999.ebuild')
-rw-r--r--dev-db/scylla/scylla-9999.ebuild20
1 files changed, 5 insertions, 15 deletions
diff --git a/dev-db/scylla/scylla-9999.ebuild b/dev-db/scylla/scylla-9999.ebuild
index 9807fd2..1907d08 100644
--- a/dev-db/scylla/scylla-9999.ebuild
+++ b/dev-db/scylla/scylla-9999.ebuild
@@ -40,7 +40,6 @@ RDEPEND="
net-libs/gnutls
net-misc/lksctp-tools
sys-apps/hwloc
- sys-apps/irqbalance[numa]
sys-fs/xfsprogs
sys-libs/libunwind
sys-libs/zlib
@@ -52,14 +51,14 @@ DEPEND="${RDEPEND}
dev-util/ninja
"
-CONFIG_CHECK="~HUGETLBFS ~KPROBES ~NUMA_BALANCING ~PROC_PAGE_MONITOR ~SYN_COOKIES ~TRANSPARENT_HUGEPAGE ~UIO_PCI_GENERIC"
-ERROR_HUGETLBFS="${PN} recommends support for Huge Table Pages FS (HUGETLBFS)."
-ERROR_KPROBES="${PN} recommends support for KProbes Instrumentation (KPROBES)."
+# Discussion about kernel configuration:
+# https://groups.google.com/forum/#!topic/scylladb-dev/qJu2zrryv-s
+# For DPDK, removed HUGETLBFS PROC_PAGE_MONITOR UIO_PCI_GENERIC in favor of VFIO
+CONFIG_CHECK="~NUMA_BALANCING ~SYN_COOKIES ~TRANSPARENT_HUGEPAGE ~VFIO"
ERROR_NUMA_BALANCING="${PN} recommends support for Memory placement aware NUMA scheduler (NUMA_BALANCING)."
-ERROR_PROC_PAGE_MONITOR="${PN} recommends to enable /proc page monitoring (PROC_PAGE_MONITOR)."
ERROR_SYN_COOKIES="${PN} recommends support for TCP syncookie (SYN_COOKIES)."
ERROR_TRANSPARENT_HUGEPAGE="${PN} recommends support for Transparent Hugepage (TRANSPARENT_HUGEPAGE)."
-ERROR_UIO_PCI_GENERIC="${PN} recommends support for Generic driver for PCI 2.3 and PCI Express cards (UIO_PCI_GENERIC)."
+ERROR_VFIO="${PN} running with DPDK recommends support for Non-Privileged userspace driver framework (VFIO)."
DOCS=( LICENSE.AGPL README.md )
PATCHES=()
@@ -182,15 +181,6 @@ pkg_postinst() {
}
pkg_config() {
- elog "Setting up irqbalance..."
- if $(grep -q systemd /proc/1/comm); then
- systemctl enable irqbalance.service
- systemctl start irqbalance.service
- else
- rc-update add irqbalance default
- service irqbalance start
- fi
-
elog "Running 'scylla_setup'..."
scylla_setup
} \ No newline at end of file