summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2017-08-23 09:09:34 +0200
committerUltrabug <ultrabug@gentoo.org>2017-08-23 09:09:34 +0200
commitd0b0469eb9ff2b1df323b0afdc81e7fc42b47cc3 (patch)
tree39d2b070e4461b2f172411a365e8aac5240740fa /dev-db/scylla/scylla-9999.ebuild
parentscylla: overall bump to 2.0_rc2 (diff)
downloadultrabug-d0b0469eb9ff2b1df323b0afdc81e7fc42b47cc3.tar.gz
ultrabug-d0b0469eb9ff2b1df323b0afdc81e7fc42b47cc3.tar.bz2
ultrabug-d0b0469eb9ff2b1df323b0afdc81e7fc42b47cc3.zip
dev-db/scylla: respect user CFLAGS, add comments on debugging
Diffstat (limited to 'dev-db/scylla/scylla-9999.ebuild')
-rw-r--r--dev-db/scylla/scylla-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-db/scylla/scylla-9999.ebuild b/dev-db/scylla/scylla-9999.ebuild
index c444c2f..80be83b 100644
--- a/dev-db/scylla/scylla-9999.ebuild
+++ b/dev-db/scylla/scylla-9999.ebuild
@@ -30,7 +30,7 @@ fi
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit autotools linux-info python-r1 toolchain-funcs systemd user
+inherit autotools flag-o-matic linux-info python-r1 toolchain-funcs systemd user
DESCRIPTION="NoSQL data store using the seastar framework, compatible with Apache Cassandra"
HOMEPAGE="http://scylladb.com/"
@@ -39,6 +39,13 @@ LICENSE="AGPL-3"
SLOT="0"
IUSE="doc systemd"
+# NOTE:
+# if you want to debug using backtraces, enable the 'splitdebug' FEATURE:
+# https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
+#
+# then check out:
+# https://github.com/scylladb/scylla/wiki/How-to-resolve-backtrace
+
RESTRICT="test"
RDEPEND="
@@ -152,8 +159,10 @@ src_prepare() {
}
src_configure() {
- # TODO: --cflags "${CFLAGS}"
- ./configure.py --mode=release --with=scylla --enable-dpdk --disable-xen --compiler "$(tc-getCXX)" --ldflags "${LDFLAGS}" || die
+ # native CPU CFLAGS are strongly enforced by upstreams, respect that
+ replace-cpu-flags "*" "native"
+
+ ./configure.py --mode=release --with=scylla --enable-dpdk --disable-xen --compiler "$(tc-getCXX)" --ldflags "${LDFLAGS}" --cflags "${CFLAGS}" || die
}
src_compile() {