summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/parted/parted-1.7.1-r1.ebuild')
-rw-r--r--sys-apps/parted/parted-1.7.1-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-apps/parted/parted-1.7.1-r1.ebuild b/sys-apps/parted/parted-1.7.1-r1.ebuild
deleted file mode 100644
index 42e9a33..0000000
--- a/sys-apps/parted/parted-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.7.1-r1.ebuild,v 1.10 2007/01/31 18:43:02 wolf31o2 Exp $
-
-inherit eutils
-
-DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
-HOMEPAGE="http://www.gnu.org/software/parted"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls readline debug"
-
-# specific version for gettext needed
-# to fix bug 85999
-DEPEND=">=sys-fs/e2fsprogs-1.27
- >=sys-libs/ncurses-5.2
- nls? ( >=sys-devel/gettext-0.12.1-r2 )
- readline? ( >=sys-libs/readline-4.1-r4 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/parted-1.7.0-pyparted.patch
- epatch "${FILESDIR}"/parted-1.7.1-fix-seg.patch
-}
-
-src_compile() {
- econf \
- $(use_with readline) \
- $(use_enable nls) \
- $(use_enable debug) \
- --disable-Werror || die "Configure failed"
- emake || die "Make failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "Install failed"
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
- dodoc doc/{API,FAT,USER.jp}
-}