summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-06-15 22:08:25 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-06-15 22:08:25 +0000
commit8adc55956de63925cc8d88fc1aa0d48a147bf633 (patch)
tree9b19df870111492075d8372f4dbf7e6a6e38a5b3
parentCorrected source dir (diff)
parentComments update (diff)
downloadoverlay-8adc55956de63925cc8d88fc1aa0d48a147bf633.tar.gz
overlay-8adc55956de63925cc8d88fc1aa0d48a147bf633.tar.bz2
overlay-8adc55956de63925cc8d88fc1aa0d48a147bf633.zip
Second part of moving flickfs related ebuilds to testing
svn path=/testing/; revision=720
-rw-r--r--net-fs/flickrfs/Manifest6
-rw-r--r--net-fs/flickrfs/files/digest-flickrfs-1.11
-rw-r--r--net-fs/flickrfs/files/digest-flickrfs-1.1.91
-rw-r--r--net-fs/flickrfs/files/flickrfs-1.1.9.patch104
-rw-r--r--net-fs/flickrfs/files/flickrfs-1.1.patch151
-rw-r--r--net-fs/flickrfs/flickrfs-1.1.9.ebuild40
-rw-r--r--net-fs/flickrfs/flickrfs-1.1.ebuild40
-rw-r--r--net-fs/flickrfs/trac.BAK1
-rw-r--r--python-fuse/Manifest2
-rw-r--r--python-fuse/files/digest-python-fuse-2.31
-rw-r--r--python-fuse/python-fuse-2.3.ebuild25
-rw-r--r--python-fuse/trac.BAK2
12 files changed, 374 insertions, 0 deletions
diff --git a/net-fs/flickrfs/Manifest b/net-fs/flickrfs/Manifest
new file mode 100644
index 0000000..bee1329
--- /dev/null
+++ b/net-fs/flickrfs/Manifest
@@ -0,0 +1,6 @@
+MD5 d23f17626247ad3959cc02f2a1ee9c3f files/digest-flickrfs-1.1 64
+MD5 bb21edae03a6b5c20749cce6f340da6c files/digest-flickrfs-1.1.9 65
+MD5 948b675fe63e6198d03d3d99253fbdc9 files/flickrfs-1.1.9.patch 3714
+MD5 cac85198773dd9a7d78d4781be526f55 files/flickrfs-1.1.patch 6062
+MD5 6ea686949225674d15de28f91a7e51bc flickrfs-1.1.9.ebuild 713
+MD5 7f16a72a5ca4c1afca9d95ea72682731 flickrfs-1.1.ebuild 721
diff --git a/net-fs/flickrfs/files/digest-flickrfs-1.1 b/net-fs/flickrfs/files/digest-flickrfs-1.1
new file mode 100644
index 0000000..4608806
--- /dev/null
+++ b/net-fs/flickrfs/files/digest-flickrfs-1.1
@@ -0,0 +1 @@
+MD5 0aef813ce386c5195fcfd58a51e06b87 flickrfs-v1.1.tar.gz 12161
diff --git a/net-fs/flickrfs/files/digest-flickrfs-1.1.9 b/net-fs/flickrfs/files/digest-flickrfs-1.1.9
new file mode 100644
index 0000000..8d06e0a
--- /dev/null
+++ b/net-fs/flickrfs/files/digest-flickrfs-1.1.9
@@ -0,0 +1 @@
+MD5 65a78c68ba11c527b9e9619a9fac7199 flickrfs-1.1.9.tar.gz 15396
diff --git a/net-fs/flickrfs/files/flickrfs-1.1.9.patch b/net-fs/flickrfs/files/flickrfs-1.1.9.patch
new file mode 100644
index 0000000..9df6566
--- /dev/null
+++ b/net-fs/flickrfs/files/flickrfs-1.1.9.patch
@@ -0,0 +1,104 @@
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrapi.py flickrfs-1.1.9-mod/flickrapi.py
+--- flickrfs-1.1.9/flickrapi.py 2005-11-08 15:21:57.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrapi.py 2005-11-14 22:07:26.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!python
+ #
+ # Flickr API implementation
+ #
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.conf flickrfs-1.1.9-mod/flickrfs.conf
+--- flickrfs-1.1.9/flickrfs.conf 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrfs.conf 2005-11-14 21:03:03.000000000 +0100
+@@ -0,0 +1,18 @@
++[USER]
++
++# for out-of-band auth inside a web browser
++browserName : /usr/bin/firefox
++
++
++#-------------------------------------------------------------------
++
++# It is not necessary to change these. They just identifies this as
++# this application as flickrfs so that flickr.com can track the
++# usage by different api's
++
++# API key
++flickrAPIKey : f8aa9917a9ae5e44a87cae657924f42d
++
++# shared "secret"
++flickrSecret : 3fbf7144be7eca28
++
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/flickrfs.py flickrfs-1.1.9-mod/flickrfs.py
+--- flickrfs-1.1.9/flickrfs.py 2005-11-08 22:01:39.000000000 +0100
++++ flickrfs-1.1.9-mod/flickrfs.py 2005-11-14 21:56:16.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!python
+ #@+leo-ver=4
+ #@+node:@file flickrfs.py
+ #===============================================================================
+@@ -58,11 +58,22 @@
+ #Import flickr python api
+ from flickrapi import FlickrAPI
+
+-# flickr auth information
+-flickrAPIKey = "f8aa9917a9ae5e44a87cae657924f42d" # API key
+-flickrSecret = "3fbf7144be7eca28" # shared "secret"
+-browserName = "/usr/bin/firefox" # for out-of-band auth inside a web browser
++# Import ConfigParser
++from ConfigParser import ConfigParser
+
++def read_config(config_file = '/etc/flickrfs/flickrfs.conf'):
++ defaults = {
++ 'flickrAPIKey' : "f8aa9917a9ae5e44a87cae657924f42d", # API key
++ 'flickrSecret' : "3fbf7144be7eca28", # shared "secret"
++ 'browserName' : "/usr/bin/firefox",} # for out-of-band auth inside a web browser
++
++ config = ConfigParser(defaults)
++ config.add_section('USER')
++
++ if os.access(config_file, os.R_OK):
++ config.read(config_file)
++
++ return config
+
+ class TransFlickr: #Transactions with flickr
+ def uploadfile(self, filepath, taglist, bufData, mode):
+@@ -1141,6 +1154,12 @@
+
+ #@+node:mainline
+ if __name__ == '__main__':
++
++ config = read_config()
++ flickrAPIKey = config.get('USER', 'flickrAPIKey')
++ flickrSecret = config.get('USER', 'flickrSecret')
++ browserName = config.get('USER', 'browserName')
++
+ try:
+ server = Flickrfs()
+ server.multithreaded = 1;
+diff -Naur --exclude='*.pyc' flickrfs-1.1.9/setup.py flickrfs-1.1.9-mod/setup.py
+--- flickrfs-1.1.9/setup.py 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1.9-mod/setup.py 2005-11-14 20:23:31.000000000 +0100
+@@ -0,0 +1,20 @@
++#!/usr/bin/env python
++
++import sys
++
++from distutils.core import setup
++
++# this affects the names of all the directories we do stuff with
++sys.path.insert(0, './')
++
++setup(name = 'flickrfs',
++ version = '1.1.9',
++ description = 'A virtual filesystem that provides easy access to flickr',
++ author = 'Manish Rai Jain',
++ author_email = 'manishrjain@gmail.com',
++ url = 'http://flickrfs.sourceforge.net/',
++ py_modules = ['flickrapi'],
++ scripts = ['flickrfs'],
++ data_files = [('/etc/flickrfs', ['flickrfs.conf'])],
++ license = 'GPL',
++ )
diff --git a/net-fs/flickrfs/files/flickrfs-1.1.patch b/net-fs/flickrfs/files/flickrfs-1.1.patch
new file mode 100644
index 0000000..c9a6500
--- /dev/null
+++ b/net-fs/flickrfs/files/flickrfs-1.1.patch
@@ -0,0 +1,151 @@
+diff -Naur --exclude='*.pyc' flickrfs-1.1/flickrapi.py flickrfs-1.1-mod/flickrapi.py
+--- flickrfs-1.1/flickrapi.py 2005-11-08 15:21:57.000000000 +0100
++++ flickrfs-1.1-mod/flickrapi.py 2005-11-14 22:07:26.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!python
+ #
+ # Flickr API implementation
+ #
+diff -Naur --exclude='*.pyc' flickrfs-1.1/flickrfs.conf flickrfs-1.1-mod/flickrfs.conf
+--- flickrfs-1.1/flickrfs.conf 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1-mod/flickrfs.conf 2005-11-14 21:03:03.000000000 +0100
+@@ -0,0 +1,18 @@
++[USER]
++
++# for out-of-band auth inside a web browser
++browserName : /usr/bin/firefox
++
++
++#-------------------------------------------------------------------
++
++# It is not necessary to change these. They just identifies this as
++# this application as flickrfs so that flickr.com can track the
++# usage by different api's
++
++# API key
++flickrAPIKey : f8aa9917a9ae5e44a87cae657924f42d
++
++# shared "secret"
++flickrSecret : 3fbf7144be7eca28
++
+diff -Naur --exclude='*.pyc' flickrfs-1.1/flickrfs.py flickrfs-1.1-mod/flickrfs.py
+--- flickrfs-1.1/flickrfs.py 2005-11-08 22:01:39.000000000 +0100
++++ flickrfs-1.1-mod/flickrfs.py 2005-11-14 21:56:16.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!python
+ #@+leo-ver=4
+ #@+node:@file flickrfs.py
+ # v0.9 - Initial release
+@@ -48,11 +48,22 @@
+ #Import flickr python api
+ from flickrapi import FlickrAPI
+
+-# flickr auth information
+-flickrAPIKey = "f8aa9917a9ae5e44a87cae657924f42d" # API key
+-flickrSecret = "3fbf7144be7eca28" # shared "secret"
+-browserName = "/usr/bin/firefox" # for out-of-band auth inside a web browser
++# Import ConfigParser
++from ConfigParser import ConfigParser
+
++def read_config(config_file = '/etc/flickrfs/flickrfs.conf'):
++ defaults = {
++ 'flickrAPIKey' : "f8aa9917a9ae5e44a87cae657924f42d", # API key
++ 'flickrSecret' : "3fbf7144be7eca28", # shared "secret"
++ 'browserName' : "/usr/bin/firefox",} # for out-of-band auth inside a web browser
++
++ config = ConfigParser(defaults)
++ config.add_section('USER')
++
++ if os.access(config_file, os.R_OK):
++ config.read(config_file)
++
++ return config
+
+ class TransFlickr: #Transactions with flickr
+ def uploadfile(self, filepath, taglist, bufData, mode):
+@@ -246,26 +257,28 @@
+ running in foreground, you can have threads
+ """
+ log.info("sets_thread: started")
+- self._mkfileOrDir("/sets", isDir=True)
++ self._mkfileOrDir("/sets", isDir=True)
+ rsp = fapi.photosets_getList(api_key=flickrAPIKey, auth_token=token)
+ if rsp!=None:
+- for a in rsp.photosets[0].photoset:
+- title = a.title[0].elementText.replace('/', ' ')
+- curdir = "/sets/" + title
+- if title.strip()=='':
+- curdir = "/sets/" + a['id']
+- set_id = a['id']
+- self._mkfileOrDir(curdir, id=set_id, isDir=True)
+- photos = fapi.photosets_getPhotos(api_key=flickrAPIKey, photoset_id=set_id)
+- if photos!=None:
+- for b in photos.photoset[0].photo:
+- title = b['title'].replace('/', ' ')
+- if title.strip()=='':
+- title = str(b['id'])
+- title = title[:32] #Only allow 32 characters
+- self._mkfileOrDir(curdir+'/'+title, \
+- id=str(b['id']), isDir=False)
+-
++ try:
++ for a in rsp.photosets[0].photoset:
++ title = a.title[0].elementText.replace('/', ' ')
++ curdir = "/sets/" + title
++ if title.strip()=='':
++ curdir = "/sets/" + a['id']
++ set_id = a['id']
++ self._mkfileOrDir(curdir, id=set_id, isDir=True)
++ photos = fapi.photosets_getPhotos(api_key=flickrAPIKey, photoset_id=set_id)
++ if photos!=None:
++ for b in photos.photoset[0].photo:
++ title = b['title'].replace('/', ' ')
++ if title.strip()=='':
++ title = str(b['id'])
++ title = title[:32] #Only allow 32 characters
++ self._mkfileOrDir(curdir+'/'+title, \
++ id=str(b['id']), isDir=False)
++ except Exception, e:
++ print str(e)
+
+
+
+@@ -700,6 +713,12 @@
+
+ #@+node:mainline
+ if __name__ == '__main__':
++
++ config = read_config()
++ flickrAPIKey = config.get('USER', 'flickrAPIKey')
++ flickrSecret = config.get('USER', 'flickrSecret')
++ browserName = config.get('USER', 'browserName')
++
+ try:
+ server = Flickrfs()
+ server.multithreaded = 1;
+diff -Naur --exclude='*.pyc' flickrfs-1.1/setup.py flickrfs-1.1-mod/setup.py
+--- flickrfs-1.1/setup.py 1970-01-01 01:00:00.000000000 +0100
++++ flickrfs-1.1-mod/setup.py 2005-11-14 20:23:31.000000000 +0100
+@@ -0,0 +1,20 @@
++#!/usr/bin/env python
++
++import sys
++
++from distutils.core import setup
++
++# this affects the names of all the directories we do stuff with
++sys.path.insert(0, './')
++
++setup(name = 'flickrfs',
++ version = 1.1,
++ description = 'A virtual filesystem that provides easy access to flickr',
++ author = 'Manish Rai Jain',
++ author_email = 'manishrjain@gmail.com',
++ url = 'http://flickrfs.sourceforge.net/',
++ py_modules = ['flickrapi'],
++ scripts = ['flickrfs'],
++ data_files = [('/etc/flickrfs', ['flickrfs.conf'])],
++ license = 'GPL',
++ )
diff --git a/net-fs/flickrfs/flickrfs-1.1.9.ebuild b/net-fs/flickrfs/flickrfs-1.1.9.ebuild
new file mode 100644
index 0000000..714c0f9
--- /dev/null
+++ b/net-fs/flickrfs/flickrfs-1.1.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils eutils
+
+DESCRIPTION="Flickrfs is a virtual filesystem based upon FUSE that provides easy access to flickr."
+HOMEPAGE="http://flickrfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~x86"
+
+RDEPEND="
+ =dev-lang/python-2.4*
+ dev-python/python-fuse"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ epatch ${FILESDIR}/${P}.patch
+
+ mv flickrfs.py flickrfs
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README test.py
+}
diff --git a/net-fs/flickrfs/flickrfs-1.1.ebuild b/net-fs/flickrfs/flickrfs-1.1.ebuild
new file mode 100644
index 0000000..1250185
--- /dev/null
+++ b/net-fs/flickrfs/flickrfs-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils eutils
+
+DESCRIPTION="Flickrfs is a virtual filesystem based upon FUSE that provides easy access to flickr."
+HOMEPAGE="http://flickrfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~x86"
+
+RDEPEND="
+ =dev-lang/python-2.4*
+ dev-python/python-fuse"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ epatch ${FILESDIR}/${P}.patch
+
+ mv flickrfs.py flickrfs
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README test.py
+}
diff --git a/net-fs/flickrfs/trac.BAK b/net-fs/flickrfs/trac.BAK
new file mode 100644
index 0000000..5f57005
--- /dev/null
+++ b/net-fs/flickrfs/trac.BAK
@@ -0,0 +1 @@
+BUG="112550"
diff --git a/python-fuse/Manifest b/python-fuse/Manifest
new file mode 100644
index 0000000..a5ebc59
--- /dev/null
+++ b/python-fuse/Manifest
@@ -0,0 +1,2 @@
+MD5 80235cf0bc98dd3beadb50852a66b69f files/digest-python-fuse-2.3 66
+MD5 f60dcd1e6d44bdb3b585a4bfd6e94514 python-fuse-2.3.ebuild 480
diff --git a/python-fuse/files/digest-python-fuse-2.3 b/python-fuse/files/digest-python-fuse-2.3
new file mode 100644
index 0000000..f4e6ad7
--- /dev/null
+++ b/python-fuse/files/digest-python-fuse-2.3
@@ -0,0 +1 @@
+MD5 b0ec113341ae9c9a396fc9fd120eda36 python-fuse-2.3.tar.gz 12855
diff --git a/python-fuse/python-fuse-2.3.ebuild b/python-fuse/python-fuse-2.3.ebuild
new file mode 100644
index 0000000..644d0f5
--- /dev/null
+++ b/python-fuse/python-fuse-2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Python bindings for FUSE (Filesystem in Userspace)"
+HOMEPAGE="http://fuse.sourceforge.net/"
+SRC_URI="http://www.gunnarwrobel.de/downloads/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+
+ distutils_src_install
+
+ dodoc AUTHORS README ChangeLog xmp.py
+}
diff --git a/python-fuse/trac.BAK b/python-fuse/trac.BAK
new file mode 100644
index 0000000..33adcbb
--- /dev/null
+++ b/python-fuse/trac.BAK
@@ -0,0 +1,2 @@
+NOTE="It is labeled 2.3 but it works with fuse-2.4.1-r1 also. Will upgrade the version number once the code changes and is incompatible."
+BUG="63789"