summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-04 17:38:17 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-04 17:38:17 +0000
commitd37df96bc3a057de0ec6bfa6365aa57b59b9fe2a (patch)
tree94b7afbfecefa8582e84f60ce403d72900d3a7a4 /app-admin/webapp-config
parentFixed digests (diff)
downloadoverlay-d37df96bc3a057de0ec6bfa6365aa57b59b9fe2a.tar.gz
overlay-d37df96bc3a057de0ec6bfa6365aa57b59b9fe2a.tar.bz2
overlay-d37df96bc3a057de0ec6bfa6365aa57b59b9fe2a.zip
Added testing to the webapp-config ebuild
svn path=/; revision=594
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.4.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.4.ebuild b/app-admin/webapp-config/webapp-config-1.50.4.ebuild
index ec40628..6978051 100644
--- a/app-admin/webapp-config/webapp-config-1.50.4.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.4.ebuild
@@ -33,6 +33,11 @@ src_install() {
dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
}
+src_test() {
+ einfo "Running PYTHONPATH='.' ${python} WebappConfig/tests/dtest.py in `pwd`"
+ PYTHONPATH="." ${python} WebappConfig/tests/dtest.py || die "DocTests failed - please submit a bug report"
+}
+
pkg_postinst() {
echo
einfo "Now that you have upgraded webapp-config, you **must** update your"